[OBSOLETE] Sonoff, Sonoff TH, S20, Dual, 4CH, POW, & Touch Device Handler & SmartApp ($5 & $10 Smart Switches)

It should work in theory. What temperature sensor are you using?

Well I only tried the DS18B20 when i first posted. Last night I tried the AM2301 and it works!! The only issue I see is that the led stays on regardless of the relay state.

Awesome! Now I can add temp/humidity to my regular sonoff switches!

Excuse me I’m beginner for sonoff hacking so my problem is after flashing the Sonoff touch touch sensor it doesn’t work could you help me? thank you

Can you please try to flash the Sonoff Touch firmware that I posted just a few minutes ago?

1 Like

@erocm1231 So recently one of my sonoff switch (basic) died. Before it gave up, I got some stats that i would like to share:

  • Total on/off state toggle: 500 Times
  • Total Uptime check frequency: 5000 Times

I cannot find your post Could you sent the link to my Email: hi_5c@hotmail.com ? Thankyou so much.


Thank you so much now Touch sensor it working again

@erocm1231 Excuse me, I’m beginner with sonoff hacking. My problem is when finish flashing Sonoff POW from Windows it doesn’t show signal to config with local wifi. And the light doesn’t flash when holding the button - It just stays on.

Interesting, those numbers seem low. I decided to do some stress testing. I grabbed one of my oldest Sonoff switches and wrote a script to turn it on/off. Hooked a 60 Watt light bulb up to it. I made sure to change the boot up state to “previous” so that the flash storage would be written to every time a state changed. I ran the test for several hours and will continue it later. So far:

5987 on/off events
~6100 events sent

So i got 6 basic, and 4 sonoff sv. kept 2 of them under monitoring, and one gave up early, but others are humping happily :slight_smile: May be a defective piece! I did a lil more research and ESP blew off. relay, capacitor and other components all work fine :). Manual switch still toggle relay and that is little surprising to me.

Might be possible that i was not super visioning this so there was some power fluctuation which caused this micro controller to gave-up early. The others are under more stress than this one.

I have started using few of them inwall behind my existing switch, and so far no complaints, rather impressive results. equivalent to wemo or other branded switches. But best thing is the lightweight firmware that you wrote. keeping things simple yet effective is far better than making fancy stuff.

1 Like

Hi Eric
Is it possible to have a simulated temperature sensor to miror the temperature of a sonoff th,i have try with core and webcore but did’nt find anything.

By the way ,im having problem with my sonoff pow,it loose the wifi connection ,i had to go to and try to reconnect,that switch is outside just beside a sonoff th and the sonoff th never loose it connection ,today i move my router ,better reception now outside ,will see how it goes

I don’t know of an easy way to mirror the temperature of the TH to a simulated sensor. Not sure why you would want to do that.

The wifi on these devices is pretty good. If you find that the POW has disconnected and is presenting it’s access point then you are either using an old firmware or the AP is out of range.

Yes the pow was presenting it acces point ,sometime there was only one bar and i have try to connect , my ssid and password was already there ,but it has fail to connect .like 10 min after those bar was full ,and then i was able to connect again(Its was raining when its happens) ,anyway since i have move the router no more problem ,will see if it old it .

For the temperature to be mirroring in a virtual temp sensor,it just becaus im lazy!!! I have create a room and control every device from there but i need to clic on the sonoff th to see the temperature .
Not a big deal ,just some fine tuning !

Hi everybody,
is there any way to connect manual switch (with 2 buttons) to Sonoff Dual ?

Yes, it has headers for that purpose.

Hi Eric
is there any way to push physical button to flashing Sonoff 4CH ?

To get the 4Ch into flashing mode you hold down the CH1 button while powering.

Hi Eric, I have been testing the new firmware on the Sonoff POW and although it works, it is reporting the wrong current and hence the wrong power. Based on my measurements, the current is about third of what it is suppose to be. I have tested it on two devices and both gives the same result. Any ideas?

A few questions:

  • What kind of device is connected?
  • What is the expected V, A, & W?
  • What values are you getting?