[OBSOLETE] PlexPlus - Control Lighting with Plex Play Status

Just add the build to “switches off when playing” no other sections, should turn back on during pause and stop… If it’s not then it’s a bug and I’ll need to fix it…

I can’t check it’s working right now as at the pub :smile:

Ah ok. I didn’t know that is how it works. I will try it out. Thanks for the replies :slight_smile: drink up!

I tried that but the bulb did not turn off. It stayed on while in play. Take your time in looking into this. I am in no rush.


New code uploaded to GitHub, give that a go… I’m still seeing a few issues where not all bulbs update, but this must be ST related…

I’ve made a few other changes as well to support a new device type, although not fully functional yet…

It seems to work now. The bulb I want off when playing turned off and then back on when I paused. I also had no issue getting all of my lights to response. It went through each bulb in succession. Not the most elegant but it works! I also got scenes to appear with ST and used that on momentary switches and that provided a smoother transition instead of it going bulb by bulb.

Good to know! I had a thought while queuing for a coffee, there is potentially another change I can make to make it quicker (but only if “Dim only if on” is not selected… this is the bit of code that means you need to do a loop, but if not selected I can just get the code to bypass the loop… I’ll push another update in the next day or two…

v2.7 - 05/05/16 - Further code efficiencies and also added support for trailers with Plex media device type

Child app now updated, this should provide the best possible experience for multiple lights that ST can deliver, although using direct scene triggering on your Hue hub should provide the best results overall.

Also now official support for the Plex HT Manager / Device Type, including trailer handling thanks to the great work by @iBeech thus meaning that your server does not need to be on a Windows computer for PlexPlus to work.

There seems to be an issue with the latest release. When saving the child app it throws an error because the namespace of the parent app is “ChristianH” but the child app is looking for a parent with the name of “jebbett:Plex Plus” (line 44).

I went in and manually changed the namespace on the parent to “jebbett” and it solved the problem, but you may want make this small update.

1 Like

Cheers @gh0stbeef, my local version has got out of sync with GitHub (my mistake) updated both references and new code uploaded, cheers for flagging!

I have run into a bit of a hiccup that relates to Plex and not the app but I was wondering if maybe you are seeing the same thing. The issue I am having is that my Plex client,(App on FireTV and home theater client running on PC that runs the server) will not show that playing has stopped. So that means that when I stop watching a video, PlexPlus, beacuse of Plex, still thinks the video is playing so I never get to run my “stopped” actions. Eventually Plex does detect that playing has stopped and then PlexPlus does as programmed but that time varies. Any ideas how I can get Plex to update my status right away? Playing and Paused mode work right away. Stopped is the only one that doesn’t

So I have seen the same issue recently with the Plex HT client on the PC when testing another change, I assume you are using the Plex2Smarthings exe to generate the trigger, or were you using the device type? I had the issue when integrating the device type, but didn’t test the EXE.

Having a quick look on the Plex forum the same issue was highlighted back in November 2015, with no response…

I am using the EXE. Using the webclient works perfectly. Plex sees that it stoped and PlexPlus responds accordingly. I will have to try it with my fire tv stick to see if I get the same issue. I guess I will try to get some Plex support since it really is their issue.

Let me know how you get on… If you do add a post in the plex forum let me know the link and I’ll also respond, may get more traction with a couple of people complaining maybe (possible wishful thinking)

this is working great for me still thank you!

I apologize but I’m a bit confused, specifically what to do with the “Token and API Endpoint values” once I get them.

After re-reading I see mention of it in the EXE steps, however I never reached that point as I used the Alternate method (which indicated to skip to step 4, which in turn bypasses this).

Am I correct in thinking this value isn’t needed if one isn’t using the EXE setup???

Yes if not using the exe then you just need to add the device to the room no need to worry about tokens etc.

1 Like

Is there a way to uninstall this app? I appear to have created a few mis-configurations and now it’s not working at all. Hoping that completely removing it and re-installing it will work. When I open the Plex Plus smart app, it gives the option to create a new room, but it doesn’t list existing rooms, giving me no way to delete them.

Looking at my “Installed SmartApps” list in the web interface, I have 3 instances of Plex Plus with no children, and 2 instances with a single child that I can’t access to remove. I think the 2 with child instances were set up to run a routine and nothing else, so I have no way to remove the app since routines are not aware of the app.

Any suggestions/help appreciated. Thanks.

Nevermind, figured out that I had to click the “edit” link to uninstall apps from that page. Got everything cleaned up yet. The orphaning and the smart app not listing created rooms is still an issue though.

I think the issue is that you are creating a new smart app every time… If you are on iPhone at least you need to hit the button on the top right to open installed apps, going via the route to setup the app initially will install another instance, which would explain why you had 3 instances in the first place!

Aaah, so that’s how that works! Yep, that was exactly the issue. Other smart apps I’ve used before somehow re-opened the same instance when I accessed them through the marketplace rather than creating a new one. That’s where my confusion came from. Thanks.

Any chance you could build the Plex2SmartThings.exe to work on Server 2012 R2? I’d love to use this but currently can’t as the exe won’t run

I can try, I didn’t write the exe and the code is there to compile yourself, I assume you are on 64bit? Do you get any error? Have you also tried to run in compatibility mode?

Also do you have the C+ runtime installed?