[OBSOLETE] Original Xiaomi Aqara Smart Wireless Switch (Aqara Button)

Could you code the DH for two presses with a second or two to be a held command? Bit hit and miss though…

I could but I’d have to wait for two seconds to process push requests as well then otherwise the first press would activate the push rule and the second in a second would activate the hold rule and it would alway depend on SmartThings getting the signals close enough together to be reliable.

1 Like


I have the square button showed in this post. So I created a new device using the catchall method and your DH.

Now, both the Android app and the hub log when I press the button but neither Smart Lighting nor Notify Me When smartapps react on button presses. Am I missing something?

Oh, I searched the whole evening but that’s only after posting the question that I go it working!
The following DH worked directly: https://community.smartthings.com/t/xiaomi-aqara-zigbee-switch-dth-help-needed/82072/48

Hi Terk

I’ve added your DH v1.3, then tried pairing my Aqara button. It was paired correctly as the “Xiaomi Zigbee Aqara Button AQ”.

Noticed in the logs each time I press the button, I get Last Checking, but I do not get the “Button 1 was pushed” in conjunction with the Checkin.

Help? I’ve already deleted and re-paired to the same result.

Hi I am trying to maintain a set of DH for all Xiaomi sensors over here:

I would love to collaborate with you if you have some working DHs.

I branched from @a4refillpad originally.

I just got a ST hub today and have managed to set up a couple of my Aqara buttons I purchased last month. They are working fine together but I noticed that there is a slight delay between pressing the button and my hue lights responding (operating the bulbs directly through ST app feels instant). I’m still very new to this but having dug around a bit I discovered that the button is being handled on the cloud whereas the bulbs are handled locally. I imagine this could explain the delay. Is there any way to handle the button locally? Is it down to how I have set it up or is it a limitation of the device(s)? Any pointers would be appreciated!

How did you get yours to work? Mine doesn’t register a Button Push, in the recent events it only comes up as Last Checkin registered.

I didn’t really have any trouble getting the buttons to work (other than registering them with the hub which took loads of attempts).

I just checked and realised that in my haste to get them up and running, I installed v1.2 of the handler from this thread, not the newer v1.3.

My buttons are the same as the ones pictured at top of this thread and so far 3 out of 3 that I’ve tried are all functioning correctly as push buttons for my lights. All I did was add the handler, add the ‘things’ then start using them.

Have you tried the DH I linked to in my post a little above? I was in the exact same situation as you. Also, my button is not the same as the one pictured in the first post.

I’ve got the same exact square button as in the first post.
When I try pairing it, it gets detected and matched with the DH but the logs do not show buttons pressed. I can’t find V2…need to dig deeper.

Mine is the Aqara button as pictured above, not the wall button that yo have.

Unfortunately the only remote that I know of that runs locally is the Aeon Minimote, the Xiaomi remotes require custom DTHs to make them work and any time you use a custom DTH the device will run via the cloud. There are still a few devices that run in the cloud even though they are using the built in DTH like the SmartThings presence sensors still run via the cloud at this point.

Yeah, sorry the switch you have is not what this DTH was designed for, I’m glad you found the correct DTH.

Can someone please help tell me why my button is not responding with a push?

Are you using my DH?

And you have an aqara button?

In the Web IDE look at the logs, you will probably see that the button ok only reports a state of on/off:0

So in my DH, I send an event for press, and immediately an event for release. I figure if your using corrupt something to trigger a light you would get the state change to toggle a light on or off.

I’m using this DH

and I have the Aqara Button.

So it appears that V1.2 does the trick, my button is now reporting “Button Push” in the Recent Events.

My next problem is, the device is not supported by Stringify :frowning:


I have an Xiaomi Smart Wireless Switch and I tried to pair 'it with the Smartthings HUB firmware 19.20.
I didn’t succeed in being recognized by the hub.
Can someone help with the pairing procedure? Or how to fix the issue.
Thank you.

Is it the switch above? If so I have always just pressed the button when it is not already paired and waited about 30 seconds and it pairs, otherwise I think you can hold the button for 10 seconds or so to reset it first. Also make sure it didn’t pair as unkown or thing which will happen if the DTH wasn’t published before pairing or if it wasn’t detected by the DTH as the same fingerprint.

I haven’t tried pairing with the newest firmware on the hub yet so I’m not sure if that may have something to do with it, hopefully not.