[OBSOLETE] Original Xiaomi Aqara Smart Wireless Switch (Aqara Button)

The only difference is the one you asked about sends both an on and an off response when the button is pressed so the "Xiaomi Zigbee Button” DTH is able to check how long the button was held and provide both a pushed and a held function.

Do we know if the button held feature will ever get back in for the Aqara?

No, sorry this button only sends an on command when pressed but does not send anything when released so there is no way I have been able to think of to determine if the button is held. The original round button I believe does send a command on both push and release so the DTH for that checks to see if there is more than a configurable amount of time between pushed and released to make the held feature available.

2 Likes

Does anyone know how to replace this thing’s battery? I cannot open it, the back of the button is being destroyed by my attempts to open it.

Use a quarter to turn the slot in the back an 1/8 inch counter clockwise, you should hear a click most likely. Then the back should drop off when you turn it right side up. When you go to put the back on again you need to match up the little tab on the back with the slot in the switch (the tab and slot are next to each other in this picture.

Thanks man, will do.

Could you code the DH for two presses with a second or two to be a held command? Bit hit and miss though…

I could but I’d have to wait for two seconds to process push requests as well then otherwise the first press would activate the push rule and the second in a second would activate the hold rule and it would alway depend on SmartThings getting the signals close enough together to be reliable.

1 Like

Hello,

I have the square button showed in this post. So I created a new device using the catchall method and your DH.

Now, both the Android app and the hub log when I press the button but neither Smart Lighting nor Notify Me When smartapps react on button presses. Am I missing something?

Oh, I searched the whole evening but that’s only after posting the question that I go it working!
The following DH worked directly: https://community.smartthings.com/t/xiaomi-aqara-zigbee-switch-dth-help-needed/82072/48

Hi Terk

I’ve added your DH v1.3, then tried pairing my Aqara button. It was paired correctly as the “Xiaomi Zigbee Aqara Button AQ”.

Noticed in the logs each time I press the button, I get Last Checking, but I do not get the “Button 1 was pushed” in conjunction with the Checkin.

Help? I’ve already deleted and re-paired to the same result.

Hi I am trying to maintain a set of DH for all Xiaomi sensors over here:

I would love to collaborate with you if you have some working DHs.

I branched from @a4refillpad originally.

I just got a ST hub today and have managed to set up a couple of my Aqara buttons I purchased last month. They are working fine together but I noticed that there is a slight delay between pressing the button and my hue lights responding (operating the bulbs directly through ST app feels instant). I’m still very new to this but having dug around a bit I discovered that the button is being handled on the cloud whereas the bulbs are handled locally. I imagine this could explain the delay. Is there any way to handle the button locally? Is it down to how I have set it up or is it a limitation of the device(s)? Any pointers would be appreciated!

How did you get yours to work? Mine doesn’t register a Button Push, in the recent events it only comes up as Last Checkin registered.

I didn’t really have any trouble getting the buttons to work (other than registering them with the hub which took loads of attempts).

I just checked and realised that in my haste to get them up and running, I installed v1.2 of the handler from this thread, not the newer v1.3.

My buttons are the same as the ones pictured at top of this thread and so far 3 out of 3 that I’ve tried are all functioning correctly as push buttons for my lights. All I did was add the handler, add the ‘things’ then start using them.

Have you tried the DH I linked to in my post a little above? I was in the exact same situation as you. Also, my button is not the same as the one pictured in the first post.

I’ve got the same exact square button as in the first post.
When I try pairing it, it gets detected and matched with the DH but the logs do not show buttons pressed. I can’t find V2…need to dig deeper.

Mine is the Aqara button as pictured above, not the wall button that yo have.

Unfortunately the only remote that I know of that runs locally is the Aeon Minimote, the Xiaomi remotes require custom DTHs to make them work and any time you use a custom DTH the device will run via the cloud. There are still a few devices that run in the cloud even though they are using the built in DTH like the SmartThings presence sensors still run via the cloud at this point.

Yeah, sorry the switch you have is not what this DTH was designed for, I’m glad you found the correct DTH.