[OBSOLETE] MyQ Lite Door and Lamp Control (for Liftmaster/Chamberlain)

Hey thanks @brbeaird! Just wanted to mention something in case others need it too! I know you kind of mentioned it in the notes but mine would not find the device in docker until I switched the container setting of Network Mode to Bridge.

Thanks again just wanted to leave this here in case someone else needed help :slight_smile:

This likely varies on your setup, and I haven’t done a ton of testing with mine. I always thought host mode just acted as if the container was running 1:1 with the host ports (no mappings). Bridge mode isolates the container, but as long as you map ports up to the host, it will still have access to the outside world. It’s strange that switching to bridge mode in this case would make things easier.

Hi @brbeaird, great work thanks Im in the middle of trying to set up a docker for this in unraid have the docker installed but not sure where to add variables: MYQ_EMAIL and MYQ_PASSWORD ? docker is there but will not start, any input on this thanks.

Thanks @brbeaird it’s been running smoothly. I’ve seen the prompts show that there are some random token issues but it seamlessly goes and grabs another.

Any help here guys do i need to add MYQ_EMAIL and MYQ_PASSWORD in the docker in Unraid [Add another Path, Port, Variable, Label or Device](javascript:addConfigPopup()) section if so how and where should it be? docker log reads: MyQ credentials must be specified either MYQ_EMAIL and MYQ_PASSWORD env variables or within the config.json file

Check this thread:

[ST Edge] SmartThings MyQ Edge - Devices & Integrations / Community Created Device Types - SmartThings Community

Thank you yes i did read it still not clear where to input the user and password I’m fairly new with dockers. Not sure if I have to edit the jason file or input it in the Unraid docker after install. I manage to install it but lost to configure the docker and where it has to be done. I’ll give the unraid forum a shot see if they can guide me in the right direction.

This comment has the information you need -

Edit: (Check github link for updated instructions)

Thank you very much will give that a try.

@brbeaird That worked perfect first shot very nice work thank you, picked up garage door first scan in app.

1 Like

Is this officially dead now? Asking because after the latest app update it is turned off and when I try to turn it on I get the set up screen, click done and then see the “Something went wrong. Please try to install the SmartApp again.” error. If so it has been a great run and I appreciate @brbeaird for all the support over the years. I will definitely miss the luxury of my garage door opening when we arrive.

There is an Edge version for MyQ that replaces the groovy version


Thanks…I don’t have any servers, Pi’s or anything running constantly to host this so unfortunately I am out of luck. :frowning:

So my Smart app is turned off now but everything is still working. Any insight @brbeaird or anyone. I assume when it needs to authenticate it may break.
I only have a laptop that is not always on so I haven’t converted to MyQ Edge yet. I guess I’ll get a Pi.
Fingers crossed for now.

Same here but it is intermittent. Also have noticed some random routines not working consistently either though. :woman_shrugging:

That is my guess as well. I’m surprised it still works at all.

1 Like

Legacy SmartApp was not being consistent and ST obviously wants us to move to edge drivers. I was able to set everything up with Docker Desktop for Windows installed on a box that is always on. I initially had issues with getting the port to listen for requests. I just had to specify the ports in the command:

docker run -d -p 8090:8090 --name=‘smartthings-myq-edge’ ‘brbeaird/smartthings-myq-edge:latest’

I like that I no longer need to have a sensor on the door to detect status! Thanks @brbeaird for all your work! I am a long-time user of your SmartApp and appreciate your work!

Question: Do you see any issues adjusting the polling interval less than 10 seconds?


Not particularly. It is possible there is a threshold at which MyQ throttles polling traffic from an individual IP, but I do not specifically know what that is.

Well this had been running flawlessly until this morning…

I opened the app to discover both gargage doors were offline. So I checked my always on PC bridge server and it was reporting all sorts of difficulties. I shut down the bridge server and restarted, then the ST app was reporting “searching for bridge server”, or “MyQ server” offline, and when connected it would say “Invalid credentials”. Got it to function correctly once, but it was only functional for a few minutes, then I would return to all the errors. Tried manually inserting the IP and Port info, and the MyQ-Controller immediately reported “Invalid credentials”.

This is what the bridge server is showing on my last attempt:

And the MyQ-Controller is showing this:

Should I just start over? Any help would be apprecoiated…