[OBSOLETE] MyQ Lite Door and Lamp Control (for Liftmaster/Chamberlain)

Any help here guys do i need to add MYQ_EMAIL and MYQ_PASSWORD in the docker in Unraid [Add another Path, Port, Variable, Label or Device](javascript:addConfigPopup()) section if so how and where should it be? docker log reads: MyQ credentials must be specified either MYQ_EMAIL and MYQ_PASSWORD env variables or within the config.json file
Thanks

Check this thread:

[ST Edge] SmartThings MyQ Edge - Devices & Integrations / Community Created Device Types - SmartThings Community

Thank you yes i did read it still not clear where to input the user and password I’m fairly new with dockers. Not sure if I have to edit the jason file or input it in the Unraid docker after install. I manage to install it but lost to configure the docker and where it has to be done. I’ll give the unraid forum a shot see if they can guide me in the right direction.

This comment has the information you need -

Edit: (Check github link for updated instructions)

Thank you very much will give that a try.

@brbeaird That worked perfect first shot very nice work thank you, picked up garage door first scan in app.
louy

1 Like

Is this officially dead now? Asking because after the latest app update it is turned off and when I try to turn it on I get the set up screen, click done and then see the “Something went wrong. Please try to install the SmartApp again.” error. If so it has been a great run and I appreciate @brbeaird for all the support over the years. I will definitely miss the luxury of my garage door opening when we arrive.

There is an Edge version for MyQ that replaces the groovy version

2 Likes

Thanks…I don’t have any servers, Pi’s or anything running constantly to host this so unfortunately I am out of luck. :frowning:

So my Smart app is turned off now but everything is still working. Any insight @brbeaird or anyone. I assume when it needs to authenticate it may break.
I only have a laptop that is not always on so I haven’t converted to MyQ Edge yet. I guess I’ll get a Pi.
Fingers crossed for now.

Same here but it is intermittent. Also have noticed some random routines not working consistently either though. :woman_shrugging:

That is my guess as well. I’m surprised it still works at all.

1 Like

Legacy SmartApp was not being consistent and ST obviously wants us to move to edge drivers. I was able to set everything up with Docker Desktop for Windows installed on a box that is always on. I initially had issues with getting the port to listen for requests. I just had to specify the ports in the command:

docker run -d -p 8090:8090 --name=‘smartthings-myq-edge’ ‘brbeaird/smartthings-myq-edge:latest’

I like that I no longer need to have a sensor on the door to detect status! Thanks @brbeaird for all your work! I am a long-time user of your SmartApp and appreciate your work!

Question: Do you see any issues adjusting the polling interval less than 10 seconds?

2 Likes

Not particularly. It is possible there is a threshold at which MyQ throttles polling traffic from an individual IP, but I do not specifically know what that is.

Well this had been running flawlessly until this morning…

I opened the app to discover both gargage doors were offline. So I checked my always on PC bridge server and it was reporting all sorts of difficulties. I shut down the bridge server and restarted, then the ST app was reporting “searching for bridge server”, or “MyQ server” offline, and when connected it would say “Invalid credentials”. Got it to function correctly once, but it was only functional for a few minutes, then I would return to all the errors. Tried manually inserting the IP and Port info, and the MyQ-Controller immediately reported “Invalid credentials”.

This is what the bridge server is showing on my last attempt:

And the MyQ-Controller is showing this:
2

Should I just start over? Any help would be apprecoiated…

All is now fine… shut down bridge server for a couple of hours, then restarted it and everything has been working fine for about a half an hour. Suspect it might have had something to do with this:

SmartThings Status - Aeotec Smart Home Hub, SmartThings Hub 2015 (v2), and SmartThings Hub 2018 (v3) Firmware Update

They rolled out a hub update today, any chance you were affected by that?

2 Likes

That’s what I’m thinking… everything’s fine now.

2 Likes

Brian
I cannot get Docker to recognize my garage doors. When I use the Windows exe file it will bring in the controller and garage doors. I have docker loaded with your image and container but just cant seem to get it to work.

Any help would be greatly appreciated

Steve