[OBSOLETE] MyQ Lite Door and Lamp Control (for Liftmaster/Chamberlain)

As much as I’d like to have some alternative figured out beforehand, I doubt I’ll find the time or will to do anything before this one is totally broken. I have played around with the new API enough to have a general idea of how it would work, but it would mean self-hosting a piece of the logic, which is something a think a lot of people are not going to want to deal with. Still, one way or another I plan to have some kind of solution and will share it whenever it comes to that.

3 Likes

I don’t see any way to pull it off with edge directly. There is another project where someone has created a REST forwarding service that allows edge drivers to communicate with the outside world, but it requires installing a Raspberry PI device into your network that does the forwarding. The best bet looks like it would be the SmartThings Schema integration for Cloud-to-Cloud setups.

No, Edge is limited to device drivers and is not intended to handle web callouts. I believe the intended method would be to use the new SmartApp API.

This particular app would not be technically cloud-to-cloud because it wouldn’t be SmartThings connecting directly to MyQ. It would be a self-hosted SmartApp that connects to MyQ and handles the commands.

I too am running into this same issue.

Seems the only way to have the google home recognize the ST door is to set it up as a door opener with sensor. Selecting the type as no sensor doesn’t wont show up in google home.

When i set it up with sensor i can long press the garage door and open and close it as on/off. however the ST app keeps showing up as door open and wont timeout or anything so an error always presents itself in the ST app. it’s not a huge show stopper as i only use the google app for my commands, would the only way to fix this is to buy a sensor and connect it to the door?

Hello- New to all these smart integrations so bear with me please.

I cannot seem to get my tilt sensor to associate with the MyQ Lite app.

I have installed the device handlers (both sensor and non-sensor versions). Then added the tit sensor after. If I open the MyQ Lite app and follow the directions. I can use my MyQ credentials and open my door but theres no sensor listed. Thie last part from the instructions doesn’t happen for me:

Enter in your login details and pick your gateway brand. If login is successful, you’ll see a list of doors available for you to pick. ***

After you choose your doors, you can select optional sensors to be tied to those doors

.*

I recently removed the handler and republished it and opened the app but still no change change.

Do I need to do the same with the app?

Any suggestions appreciated.

More info here on my issues. Sorry if I’m not supposed to link other threads…

Do you see this page when opening the smartapp?

Click tap to modify devices which brings up your door

Either select your door or click next if already selected to open this page where you can select your tilt sensor

@brbeaird My whole SmartThings setup got hosed last week during the upgrade and I’m trying to reinstall things now. I had the MyQ Lite working just fine before then, but it stopped.

I’ve updated the SmartApp and drivers to the latest version (honestly I think I had them already). However, now I cannot authenticate through the SmartApp. I’m logged into the actual MyQ app just fine, and have tried re-logging in to ensure my credentials are correct, and they are.

But, they don’t work for MyQ Lite. I get, “Error! The username or password you entered is incorrect. Try again.” No…it’s not.

Suggestions?

Hard to say exactly what’s going on. You could check the IDE logs when you try to log in to see if there are more details. You can also try to download the separate auth token app (see GitHub details) and see if it you can get a token that way. It’s possible something is weird with your MyQ account?

Brian, still having this issue, and went to try again today and still no luck. Not only that, I can’t even figure out how to get back to the IDE–I just get a bare-bones map of my rooms and devices and no hint of any more advanced functionality. So at the moment I’m lost.

/mike

IDE → https://graph.api.smartthings.com/

Once you login: You may need to go to My Locations and tap on the name of your location before you can get access to your data

Thanks, @jkp. I wasn’t on the right page before. @brbeaird here is the log data I get when trying to install the MyQ Lite and login to the Liftmaster account. Any ideas why this happens?

I’m seeing that it’s showing an older version of MQ Lite, but I swear I deleted and reinstalled the whole thing from my IDE from current Github code–not sure what’s happening there.

/mike

The older version is probably what’s getting you. Other than again trying to flush it out and manually copy/paste, I’m not really sure.

However, the bigger news is that this SmartApp (and all other groovy apps) now has an official expiration date: Sept 30. The End of Groovy Has Arrived

Once that goes through, we’re dead in the water as far as this method goes.

I have made a couple attempts at getting this working with an Edge driver. I think it should work conceptually but will still require running some kind of local server on your network to handle the connection to MyQ. I will see what I can do.

3 Likes

Something like a Pi?

Thank you Brian for continuing to support your program which we have all grown to use and love.

2 Likes

May as we get HA going then. lol :slight_smile:

1 Like

Why not? I’ve got everything else: Smartthings, Sharptools, Hubitat, Alexa, Google Home, Tasker, an RPi running a node server, and probably a couple of other tools I forgot. :rofl:

But not HA!

Hey i just heard groovy is ending. Does that mean we will need something different to get myq to qork with smartthings?

An alternative is to wire in a zwave relay to a physical button. User discretion advised of course, as the warning beep will not be available when the door is remotely triggered. I created a virtual edge door driver that allows the relay and a contact sensor to behave as a single door device and enable local control. It’s a little basic wiring, but removes the need for MyQ integration.

https://www.getzooz.com/zooz-zen17-universal-relay/

1 Like

+BUMP

…with impending EOL of Groovy support in SmartThings, does anyone know the status of the brbeaird/SmartThings_MyQ (master) custom DH?

2 Likes