[OBSOLETE] Kevo Plus Device Type (DTH Link in post 18)

Hey guys… wondering if there are any new updates with connecting Kevo to Google Home… ?

I went ahead and adapted the by Jeremy_Foran’s nodejs logic (with some pretty awful groovy) into a device handler: https://github.com/kennelbound-smartthings/kevo-unofficial

You have to specify username, password, and lockid in the settings, it logs into mykevo for literally every command (no token or session reuse), and doesn’t wait long enough to verify the lock status (so after locking, unlocking the status is almost always wrong). But it works and you can lock/ unlock directly.

If you want to not allow for unlocking, you can change the capabilities appropriately. Let me know if you have any trouble.


I knew it.

Strong work

Thanks for writing the device handler! If anyone else is having trouble adding it, this latest commit appears to have broken it:

I forked the repo, reverted that commit, and now it works.

1 Like

Is there any way to get the status to update?

I do not need auto locking/unlocking on a device that only needs to be touched to activate. My main reason for wanting a device handler was to know if someone forgot to lock the door. This is a basic functionality that the KEVO plus itself lacks. They have notifications if someone uses the app, but nothing that monitors the status or alerts if left unlocked for XX minutes.

1 Like

I’m so glad someone finally added this! Thank you for your hard work.

Can someone help me install? Sorry, I have only installed 1 custom handler before, and it came with instructions.

I logged into my IDE, copied the code from the website for the smartapp, chose to create a new SmartApp from code in my IDE, pasted the code, then clicked save, then publish.

Followed the same process for the code in the devicetypes folder.

Opened my SmartThings mobile app, went to Automation, add a SmartApp, then My Apps, then Kevo Unofficial, but the only options are “Assign a Name” and “Set for Specific Modes”. No spot to put in my username, password, or select which locks I want to import.

What am I missing?

go back into the IDE. Then go to devices. Click the +New Device button to add a new device.

The items with asterisks are required. Name it, give it an ID (must be unique, I used Door01), Select “KB Kevo Plus Lock” in the dropdown under type(It will be very near the bottom of the drop down selections), Select your location and hub, click save.

Click Edit next to “preferences”, enter your lock ID (can get from your kevo app or copy paste from logging in to your kevo in a browser), userid, and password.

1 Like

Thank you very much for your help. Where do I find “Device Network ID”?

Also, what if my hub isn’t showing up under location?

Edit: Do I have to be on my home wifi connection to access my hub and make these changes?

You make up the device network ID. It just has to be unique to your system.
If your hub is not showing up under your location, you might not be in the right part of the IDE.

Are there other devices shown in the my devices page? Does the address include graph-na02 or graph-na04?

1 Like

I finally got it working, thank you so much. Seems to work really well!

Well, this is frustrating. I seem to have an issue with the implementation of this device handler as well. Logs are showing a warn of “Couldn’t update state from java.lang.IllegalArgumentException: Failed with status code 500”. I tried every commit in the repo. Anyone having similar issues?

Is there any way you could create virtual switches for the kevos in addition to the actual locks?

Google assistant won’t let me control the locks with my voice, but if they were virtual switches then Google wouldn’t be able to prevent it.

Before anyone suggests creating a routine that contains the locks, it still doesn’t work in Google assistant. They have really locked it down if it is a lock device type.

File an issue in the github and I’ll take a look.

This means that your credentials aren’t getting submitted correctly. Have you edited the preferences yet?

I just fixed this with the latest version in master. Thanks for finding and fixing it.

I filed the issue. Thanks! I’m happy to do testing for you if you don’t have any devices with Google Assistant, let me know.

Thanks for the feedback. Looks like simplifying the password did the trick. My guess is it may have been an encoding issue with special characters. Nevertheless, it’s working great now. Nice work!

Now that I’m up and running, I was successful in triggering this device with Google Assistant. Yes, I did made a routine (e.g. “Lock X Door”), I triggered the “sync my devices” command with Google Assistant, then said “Activate Lock X Door”.