[OBSOLETE] IKEA Styrbar 4 button remote

Noob here. I’ve managed to create the DH (published it) and added the remote (Styrbar) to my ST hub (Aeotec V3). I was able to create a routine so that if I press button 1, one of my lights turns on. The problem is, I can’t create a routine to increase light intensity by pressing button 1. Is this a limitation of the light itself? Or is it the remote? Can you help me out?
The light in question is a G125 Filament (WizConnected - [Phillips]).

If you mean gradual increase in brightness the n it is limitations of SmartThings. Unfortunately. I don’t know if there ever will be driver for Ikea dimmers to work like that.

try super close to the hub

1 Like

I’m sorry, what do you mean by trying super close to the hub?
The Styrbar is connected to the Hub already, and it appears on the app as well.
The only issue is that I can’t get it to function as a dimmer with long presses. Is there a way to make it work?

Sorry, meant to reply to the previous post as some suggest pairing from last than a metre away had greater chance of success

Currently gradual increase can be done using ABC Manager SmartApp.

This solution will go away with Groovy going away.

However there is another solution available, with Edge driver, currently available for some Zigbee lights, as this is Beta only.
Increase and decrease is added to lights

Thanks! I’m really new to all of this. I don’t really know what Groovy is nor Edge driver.
I mean, from what I’ve read, these have something to do with Device Handlers (which from my understanding is the “code” used to integrate some hardware devices to ST that are not officially supported(?)). But I really don’t know what all that means. With Groovy going away, does that mean that the DH i’m using for the Styrbar 4 button remote won’t work in the future? Also, as for the solution to the dimmer option you have suggested, should I then go with the beta option, or the Groovy?
Please be kind, as I’m trying my best to absorb all of this new knowledge.


Actually I didn’t know this. I thought lack of gradual dimming was SmartThings problem. It is good to know there is hope. My wife won’t understand why our dimmers won’t have that option. I’ve tried to explai but :grinning_face_with_smiling_eyes::grinning_face_with_smiling_eyes:

1 Like

ABC Manager was in use for many of those scene controllers (switches/dimmers), like Inovelli and Zooz brands. That’s is why we need replacement for that feature.

There is one Remote controller, that might have issue, as when SmartLightning goes away, it will become useful.
Sengled remote is integrated as Dimmer Switch, and it doesn’t have any button capabilities. To use it currently you need to use Mirror function from SmartLightning, for all remote’s functions. Otherwise…

I need to try ABC although it is groovy based. It will work still quite some time I reckon.

In SmartThings beta stock drivers there is a zigbee dimmer remote driver. There is one Sengled dimmer included in fingerprints. Could that be it? :thinking:

@ Scubaandre,
I’ve installed the DH, but can only assign 1 button with actions.
What am I doing wrong?

Hi Tim.

Probably not you. Fluke of the system. Remove and reinstall usually does it.

Remove the DH or the thing (button) in the smartthingsapp.

Btw, do you know what the problem is of ikea buttons loosing connecties and drown battery?

Thanx in advance.

Hi, I have the same problem as Tim makes me configure button 1 (only pressed and held, double press doesn’t work) and always gives me the battery to zero (the batteries are new). I did as you advised I remove it and set it up again but it doesn’t work. What can I do? Thanks

Are we talking about the IKEA styrbar 4 buttons remote or something else?

That’s right Ikea Styrbar 4 buttons

I confirm that with the Ikea Styrbar button (4 buttons) the first one works well, very responsive. If I enter a command on the second button even if it seems that I have not saved it (nothing appears) in reality if at the second button (the one at the bottom) it works. I can’t get the two arrow buttons to work. For the sake of completeness I tell you that I tried to restart the hub and I have more removed and reassociated the Styrbar. Do you have any advice for me? Thanks

I added the remote to my setup, using add device, selected an ikea button device. My device was found, the four child buttons were created. Each button had press, double press and long press. I programmed each press with an action and all worked as planned.
Best friend in this case, is to look at the logs on graph.api.smartthings.com, for that specific device. It will look something like this:

1a974d1d-1c59-49b0-bf11-a45de94fc746 10:46:14 AM: info Button 4 pushed

1a974d1d-1c59-49b0-bf11-a45de94fc746 10:46:14 AM: debug IKEA Styrbar remote parsing: catchall: 0104 0005 01 01 0000 00 A3DB 01 01 117C 07 00 00010D00

1a974d1d-1c59-49b0-bf11-a45de94fc746 10:46:13 AM: info Button 3 pushed

1a974d1d-1c59-49b0-bf11-a45de94fc746 10:46:13 AM: debug IKEA Styrbar remote parsing: catchall: 0104 0005 01 01 0000 00 A3DB 01 01 117C 07 00 01010D00

1a974d1d-1c59-49b0-bf11-a45de94fc746 10:46:11 AM: info Button 2 pushed

1a974d1d-1c59-49b0-bf11-a45de94fc746 10:46:11 AM: debug IKEA Styrbar remote parsing: catchall: 0104 0006 01 01 0000 00 A3DB 01 00 0000 00 00

1a974d1d-1c59-49b0-bf11-a45de94fc746 10:46:10 AM: info Button 1 pushed

1a974d1d-1c59-49b0-bf11-a45de94fc746 10:46:10 AM: debug IKEA Styrbar remote parsing: catchall: 0104 0006 01 01 0000 00 A3DB 01 00 0000 01 00

If you go on the same interface, and click on your device under “My devices”, it should show four child devices like this:

If that is not the case, I would delete the device. It is the simplest way.

Sleepy end devices like buttons only wake up to send events/statuses like battery level or button presses so unless they are configured to communicate very frequently, they should last a long time. But anytime the zigbee network is reconfigured, it tends to be super expensive in battery lives.
You can check in the logs to see how often the device sends events, if configured to log.
Also check the next hop and ensure it is stable on the network.

In the meantime, thank you for your prompt reply! I have already eliminated the Ikea pilsante several times but the result is always the same. I have verified that as in the image you sent me it created 4 child buttons, but the behavior is different. Button no. 1 in the head I can save an event, if I try to save it on n. 2 (which appears to be the one below) does not save the event even if it then executes it. So even if it didn’t save the routine if I press button two it executes it. Only buttons 1 and 2 work even if button 2 does not save the routine. I hope these pointers remind you of how to get me to fix the problem. Can it make sense to clear the DH and re-enter it? Thanks for your time.