Ikea STYRBAR support

Does anybody know if this remote is supported by Smartthings or will I need to use a custom driver?

I have one of these, and it works fine with the Styrbar edge driver

I tried using this driver. I am successfully able to pair device. However, once paired, It does not seems to work. Whatever button I press on the device, there is no response. There is nothing logged in History

Hello i bought a styrbar button e2002 and tryied a lot of handlers and nothing works, can someone help me out, thanks in advance

Same for me.

I bought today Ikea styrbar, it is connected but not working. And after connecting it says error but it still visible.

However I have older styrbar and that works without any issues. Older model is W2139 and newer one W2333

@Yasser_Rasheed @putefabio @Santander You all probably have one of the new models with 2.4.5 firmware, could you please check if this driver works for you? Make sure to uninstall non-working drivers first, otherwise the configuration won’t be correct.


Hello and thanks for the reply

Since the button didnt work with smartthings and the bulb didnt dim low enough for beeing in my bedside table i have offered the kit (button and bulb) to a friend, but now maybe i will buy another button so i can give it a go on your driver, maybe this weekend ill go to ikea.

Do you recomend other button rather then styrbar and by the way do you know any bulb that dims very low light so it can be always on at night, its because i have a baby and need a very low presence light, could no acomplish that with tradfri.

I like the SOMRIG except for the one second delay in the single-tap (that you can remove it with my drivers but then you’ll lose held and double tap actions). I’d get the RODRET if you don’t need the arrows of the STYRBAR, they also use just one AAA and are smaller/lighter.

Bulbs that dim low… I guess those around 200lm decorative filament ones, they’re not even bright at full brightness, but haven’t tried them.

so i can solve this new firmware problem when the styrbar is connected but not registering any buttons pressed. unlike the guy before who suggested to uninstall all other drivers - you can keep other drivers. you go in the smartthings advanced web platform. change the driver to ikea button tweaks. now the styrbar is still not working. dont remove it from smart things, just go to add new device search nearby and put the styrbar with 4 short pushs in pairing mode again. it will find the same named device like you have installed before - and now it works.

the smartthings app dont work with driver changes. it needs to be the default while pairing selected driver , otherwise later driver changes dont work.

i made this work cause i have old and new switches in my system at the same time

check my post below

AFAIK in SmartThings you can’t choose which driver is the default if there are two drivers targeting the same exact fingerprint. I wonder if that change of driver before scanning again was just luck, unless it’s an undocumented feature that forces a doConfigure in the current driver.

why would you say its luck. ive got multiple switches working - old and new together, have a total of 6 different drivers simultaniously installed, before deciding to help and write about it. not an “undocumented feature”. just a coding mistake in the driver change. it should reset the device when changing the driver, not just when re-adding it.

As said before, I didn’t say it was luck or not, just that it’s the first time I read about the possibility of choosing which driver will configure the device when scanning for new devices.

If you’ve been able to replicate the process successfully with multiple buttons then it’s a great feedback for other users since the bindings of each Styrbar driver are different.

Typically, the order of preference in drivers when adding a device is determined by the fingerprint, if it matches the exact device then a custom driver will take preference over the stock drivers, but I’ve never seen documented the behaviour if there are multiple custom drivers targeting the very same device, hence that I said undocumented.

That can’t be done in battery-powered devices (at least Ikea’s) because they’re sleeping and will ignore configuration commands.

Other platforms like Hubitat have a reconfigure option but then you have to click/tap the option and press a button on the device at the very same time to wake it up or it won’t work.

1 Like