[OBSOLETE] Hue Advanced (Connect)

I was actually just chatting with Tim from SmartThings about this, he looked over the code and everything seems right, so unfortunately it sounds like it’s an issue on your end. It seems like the options now are to either contact support and see if they can do anything on your end, completely remove Hue Advanced and all devices and set up again, or uninstall the SmartThings app from your phone and reinstall it.

I wish there was something else I could tell you, I know those options aren’t great. I would just start with whatever you think would be easiest based on your setup and work from there. Definitely let me know if you get it working.

EDIT: Do you only have the SmartThings app on one device? Is there any other device you could install it on to test?

Uninstalling the app from my phone is probably the easiest first step and if that doesn’t work I’ll try to uninstall the Advanced hue app.

But that will probably have to wait until tomorrow… I’ve been having some other problems in the last several days so perhaps this is related.


Does your smartapp work with hue hub v1?

I tried adding the smartapp and proceeded to the last (?) step, advanced settings, and got stuck.

GUI is flashing unexpected error.

It should, do you see anything in live logging when the error comes up?

physicalgraph.app.exception.UnknownDeviceTypeException: Device type ‘Hue Advanced Bridge’ in namespace ‘claytonjn’ not found.

Edit: I didn’t follow instructions. Didnt install device handlers…

I added and my 3rd party light fixtures (KUDLED brand) are working perfectly.

Glad you got it working, thanks for the update.

Clayton, I added a state for colorloop so that color loop turns back on when the bulb is turned back on if it was set prior to the bulb turning on.
You can merge it if you think it’s good

How do other people feel about this? I appreciate the contribution, my only hesitation is that this is not the default Hue behavior so I’m not sure everyone will want this. Would an option in Hue Advanced (Connect) SmartApp be best?

1 Like

I have implemented a fix for the forthcoming Grails platform update. Although the update is delayed, the fix is backwards compatible and if you don’t have the new code before the platform update happens you’ll loose control of your Hue lights through SmartThings. Therefore, I recommend everyone update. Only the SmartApp is changed and you shouldn’t need to reconfigure or change anything - just update the code and save/publish.

So has anyone seen a problem with this SA not refreshing bulb states?

For example, if I use a CoRE piston to turn on my living room - the bulbs in the living room 30 minutes later will be about 50% on and 50% off in the app even though all are in an on state.

Also, hitting the refresh button does nothing.

@AlmostTan I just verified this morning and a bulb that was turned on outside of SmartThings correctly polled and updated its state in SmartThings, so polling is working, at least for me.

That being said, if you’re setting state withing SmartThings itself, using ANY SmartApp, state should be updated immediately and does not require any polling, which is what hitting refresh does. If the bulbs are turning on but not changing state that means one of two things: either the on() function is not executing fully (due to execution time timeout or other platform issues) for the on() function is fully executing but sending the event change is not working (again, this would be due to platform issues).

I have noticed a couple instances of devices in general not matching their current state, but it has spanned multiple device types and SmartApps sending the commands, so I’m reasonable confidant that it’s being caused by platform issues. Unfortunately that means that my best advice at this time would be to wait it out, or contact support. If you want to send me some logs from Live Logging I would be glad to look over them, but to be honest you would probably just be wasting your time.

1 Like

Clay as a follow-up to the previous problem relating to the device page not showing the state of the Circadian Color being enabled or disabled on bulbs.

I did attempt a reinstall of the app on my iPhone which didn’t work. I also migrated from a V1 hub to a V2 hub and rebuilt my entire SmartThings system.

As another check I recently (today) side loaded the SmartThings Moble app on a Fire Tablet and it seems that when I tap one of the buttons on a device page using the fire tablet the device first shows “Working” and then shows it as off correctly on the app device page.

It seems as though this is only a problem with my iOS device.

It is strange that it doesn’t work on my iOS device but seems to work just fine running on Android.

I don’t have any iOS devices. Can anyone with an iPhone confirm whether they are or are not experiencing the same behavior as @scottashell? (Circadian Daylight buttons in a device not showing proper state)

I just pushed a big update to Hue-Advanced-Developer beta branch. This update is a merge of the recent major changes to the native Hue (Connect). The big change is that the device state gets updated based on the confirmation from the Hue hub, rather than from ST sending the command. This means that there’s a longer delay from states updating (i.e. turning a light on keeps the state as “turning on” until the hub actually confirms that the light is on), but the ST state will more accurately reflect the state.

It shouldn’t be necessary, but it would be a lot cleaner to remove all Hue devices and Hue Advanced (Connect) before updating and adding them back so I strongly suggest doing so.

Anyone testing, please let me know if you have any issues because there were major code rewrites.

Hi Clayon,

I was using the old version of hue-adv and circadian. I removed all the apps and handlers, and installed by hand the ones on the dev branch of your github. Unfortunatelly, I end up with and “unexpected error” at the last step of the hue-adv install. I manage to find and link the bridge, add a couple of bulbs, but the last error doesn’t let me pass through.

I wonder if this has to do with the fact that I am on a UK hub. It’s a pity, because I love your app. I tried to debug a bit, but as the simulator does not find the bridge, I can’t use it.
Let me know when you come up with an updated version, or if you have any tips in how to debug my error.

Any time the mobile app shows an error there should be errors in Live Logging in the IDE. Can you open up live logging and try running through the setup in the app until you get the error, then send me whatever errors show up in live logging? That should show exactly what’s causing the problem.

You shouldn’t have any issues being in the UK, I’ve kept things as close to the stock Hue (Connect) as possible for that exact reason.

1 Like

I found this:

groovy.lang.MissingMethodException: No signature of method: script14784599659971984064553.setupDeviceWatch() is applicable for argument types: () values: [] @ line 411

and indeed, I cannot find the method setupDeviceWatch in the smartapp

Looks like it is defined in https://github.com/SmartThingsCommunity/SmartThingsPublic/blob/master/smartapps/smartthings/hue-connect.src/hue-connect.groovy

I have added the method back, and now everything works like a charm :slight_smile:

I just found out about your app. I will probably install tonight or tomorrow.

I have a thought for a added feature:

Your app already shows the “Ready” status of a light. It would be cool if there were a a feature to turn on a “Master” switch if the light is not “Ready”.

I have about 4 lights that are on Z-wave light switches or plug-in modules.

I just looked at the device types and noticed like the main connect, this is missing the Bloom and LightStrip (both versions).

Are you working on these?

Hi Olivier,

I’m having the same problem, 8:46:25 AM: error groovy.lang.MissingMethodException: No signature of method: script14785082235651100475799.setupDeviceWatch() is applicable for argument types: () values: [] @ line 411

What did you add back in to fix this?