[OBSOLETE] - Hive (Connect) V3.2c (British Gas Hive)

Ok, so I have set this integration up for my Hive boiler control, room stat and trv’s (x17) and all appears to be working ok. The problem is now I dont know what to do with it. How is everyone else using it? Do you turn everything off in the Hive app and set up the on/off schedules in SmartThings?

I must admit, I’ve had this set up 18 months and rarely touch the heating part (I’d got Hive bulbs which ST can now control) I still have the schedules firing in Hive app. I did set one thing up, I have a ‘morning’ automation, which is triggered by the movement sensor the first time someone comes downstairs, I added a 20c boost to the heating control to that (There doesn’t seem to be a way to turn off the boost but eventually the Hive schedule will reduce it) Also, since I finally got presence working for the whole family, I might look at reducing temp when no one is home.

Thats interesting. Can it be set for the last person to leave and the first person home triggers it?

Anyone else getting a 403 error when it tries to authenticate with Hive?

Tried removing the smart app and re-adding. Guessing a problem at the Hive end or they’ve changed something.

In theory yes, I have ‘no one home’ and ‘someone home’ automations which i could add heating control to. The problem is that presence is mostly busted in the new app and people are also having problems with life360 integration. By chance, I installed a smartapp to detect presence based in wifi connection to my ubiquiti access point (Doesn’t require anything installed on kids phones, doesn’t require them have location tracking turned on as long as they are connected to home wifi, they are marked as ‘present’

Any chance you could share that app please?

Agreed the detection via mobile phones is terrible.

I don’t control Hive through smartthings as Hive does a better job in its own app. I honestly think ST is going to die off now because everything is going via WiFi which Google and Amazon do natively. ZWave and Zigbee devices are more expensive and with a decent router, I’d bet the reaction time is minimal. Just my opinion.

See this post :

You can often pick up the APs cheaply on FB market, ebay etc - the smart app needs a controller & bridge (which I run on a raspberry pi) The only thing to look out for is that for the original, square, APs you need to run older controller code (Ubiquiti has the older code on their site) Even if it didn’t do ST integration, I’d still be pleased with ubiquiti wifi kit - it’s really good)

The thing about zigbee over wifi is power consumption. Door sensors, motion sensors are nearly always zigbee as they can run for months on a small lithium battery, wifi devices can’t do that.

Hi im having the same problem, when this happened before HIVE was in accessible from all apps including the Hive on. Worryingly they are working just the connection from Smart things is not authenticating properly. Has anyone else one experienced this issue?

So I rang Hive who were particularly unhelpful, it went along the lines that they dont support third party products. :frowning:

Thanks Tim, let us know if you have any luck, I cant believe my luck, 2 years of no issues with my little set up has been decimated by smartthings upgrade and now this :frowning: talk about if its not broken :slight_smile:

So update i learnt a bit more today from this blog https://jedkirby.com/blog/hive-home-rest-api it turns out beekeeper is used by the official hive login webpage. So i tried that and that too wont allow the page to authenticate so I assume the issues are related… Im on to hive now hoping that due to the issue being on its own product they can be more helpful than last time.

It looks like they have changed there myhivehome to sso.hivehome.com so its probable that the beekeeper interface is now dead :frowning:

Maybe they have changed something after that outage a few days ago. I played around with this script earlier - https://raw.githubusercontent.com/imcfarla2003/domoticz-hive/master/collect_json.py and it works which suggests the API is still there. but it uses different endpoint URLs to this smart app (api.pro.bgchprod.info as opposed to beekeeper-uk.hivehome.com) I google that and found people saying the beekeeper URL was actually the newer one. I’ll see if I can get a response from a script using beekeeper URL but I need to get my head around the auth mechanism first :slight_smile:

Made some progress (don’t tell my boss please) I can reproduce this with curl outside the smartapp

The code from the smart app essentially does this to retrieve the access token :

curl -X POST -k -H ‘Content-Type: application/json’ -i ‘https://beekeeper.hivehome.com/1.0/global/login’ --data ‘{“username”:“my_email”,“password”:“my_passwd”, ‘devices’: false, ‘products’: false}’

Running that on the command line give me :


However, I can get an access token from :

curl -X POST -k -H “Content-Type: application/vnd.alertme.zoo-6.2+json” -H “Accept: application/vnd.alertme.zoo-6.2+json” -H “X-AlertMe-Client: Hive Web Dashboard” -d ‘{“sessions”:[{“username”:“my_email”, “password”:“my_passwd”}]}’ -i ‘https://api-prod.bgchprod.info:443/omnia/auth/sessions

but the headers are different so it’s not just a case of swapping the URL as I’d hoped…

Really interesting how this will work out. Im not a developer, but following this thread as I have Hive hub and Thermostats and so far it was working flawlessly last few years. Hope someone will be able to get this fixed. I have also noticed that it has stopped working on Home assistant integration. So im guessing it has something to do with authentication on Hive end anyway.

Ditto, I am hoping this gets sorted as it was an excellent intergration and how I ran all my lights in the house!

We should probably continue this conversation over at Hive Connect not Working

I’m looking into this today. Bear with me and I’ll update this thread.

My initial findings are not looking good.

It looks like they’ve shifted the authentication mechanism to AWS IDP. Unfortunately this requires a token on the Hive side to be created for each application to have permission to call the authentication service. This means that authentication may no longer be possible via this SmartThings app.

Did you see Hive Connect not Working ? The HA community found a fix (for non 2FA at least)

1 Like

Thank you all for doing the hard work for me! I’ve updated the authentication URL and published to GitHub. The fix seems to working for me although I had to reselect my thermostat in the Hive smart app.


Cheers for the swift fix. Heating is back to normal. Unfortunately, although Hot water works fine in old app and works in new app it shows offline in new app. Ideas?

Sweet. Thanks for update! :slightly_smiling_face: Working like before. Except for Hot water showing offline. Same as @siwilson mentioned above.