[OBSOLETE] Four button Tuya Zigbee device DTH (DTH link in post #7) (Same device from multiple brands: Zemismart, Yagusmart, Losonho , DYHF, etc)

To use it with automation:

  • click on “+” at the top right and click on Automatic Action.
  • In the “If” part, press “+” and choose the device, remote control
  • Choose the button and type of button action.
  • you can add more devices with the OR or AND condition.
  • In the “then” part, press “+” and choose the actions you want to execute

Did anyone have any luck getting this to work?
If i add it to Smartthings, it still just picks it up as a “Thing”. If i try to re-add, it still only ever detects as a “Thing”.
If i go to the IDE and change it to the Zemismart button, it only shows up 1 button with a heap of possible events (pressed, double pressed, held, standby, pressed 2 times, pressed 3 times, etc)
When i press the 1st button, nothing is registered as an event…
I’ve tried re-adding it many times but no luck. Nothing seems to be detected when i press any of the buttons.

Go to Smartthings Brasil. It has a link to the needed DTH for the 4 button remotes (scene switches).


1 Like

Does the DTH in post 7 of this thread not work anymore? :thinking:

After reviewing it appears to be the same DTH.

1 Like

Yeah I tried the DTH from that link and it still doesn’t work unfortunately…

At least not for me it doesn’t.

What I seem to notice after buying 22 more switches… Is that the newer ones don’t work anymore for some reason. They come in as thing and when you give them the “type” for the switch config it just gives a long list of actions but doesn’t respond to it. When I deleted everything and started over the old switches immediately came in as the 4 way switch while the new ones still came in as thing.

  1. how many total Zigbee devices do you have?
    Of those, how many are mains powered?
    Of those, how many are Sengled brand?

  2. what model number is your hub?

  3. when you deleted everything and went to add them back did you try adding one of the new switches early in that process, or did you just start with the old ones again?

I’m asking all of that because obviously there’s a possibility that something has changed with the new switches, they may have different firmware or whatever. But it’s also possible that you hit a max limit of some kind on your smartthings account. There are a couple that can affect you.

  1. 6 with the with the new switches, I didn’t try to many because I want them to work first
    1 Is main powered and the 5 switches are battery powered.

Segled brand? If you mean from the same store 1 sonoff light switch, 3 older tuya switches and 2 newer tuya switches

  1. The hub is the smartthings hub 3 model number can’t check at the moment

  2. First old, then new, then old…


1 Like

Sorry, your previous post said you bought 22 new switches. So now I’m confused. :thinking:

Sengled is a specific brand, like Honeywell or Sonoff or Hue or IKEA Tradfri.

This switch is a China product it is supported by tuya but a real brand is not known because every seller on aliexpress sets its own brand on it when there all from the same maker.

And yes I have bought 22 new switches but Im not gone bother learning them all in if it doesn’t work so for now I only use these 5 and when it works again I go further with more switches.

1 Like

i’ve looked in to the device details and what i found is that it has a new model number and manufacturer.

The Manufacturer is: _TZ3000_xabckq1v
The Model is : TS004F

The older ones (the ones from the original device handler)

The Manufacturer is: _TZ3000_vp6clf9d
The Model is : TS0044

changing the data in the device handler code made it know what kind of switch it is but it still not recieving data from it so no action when pressing any button.

anyone have more info on this or how to change the device handler the right way.

Here are the device information of the “working” one and the “broken” one.
like you can see the “broken” one hasnt made an action.

Any success yet?
I’m at the same point as you.
Change manufacturer and model on device handler. Recognises it. But the Button pressing doesn’t trigger anything.

I’m afraid its waiting for a new device handler from the maker I’m messaging the shop where I bought it but they say they did not say it works so they don’t have to do anything. And I messaged zemismart but they don’t want to help because I didn’t order from them.

Basically where F’ed

I’ve reached the same point as you too. I’ve noticed that the “Manufacturer” code is different.

ive contacted Zemismart and they say these dont work with smartthings yet and they dont know if they will ever. tuya updated these and knowing tuya, it is probably an update to disable smartthings support, so you can only use it with there system.

That’s allowable under the Zigbee protocol as long as they describe the device as being “manufacturer proprietary.“

However, if they describe it as being certified for either a Zigbee 3.0 or zigbee Home Automation 1.2 (ZHA 1.2), then it has to work to the independent standard, regardless of what hub is being used.

Now whether smartthings has implemented all of the standard is a separate question. :thinking: for example, smartthings has historically not been good with multi button devices, quite a few devices which work out of the box with other hubs need special code to work with smartthings.

Also, there’s a difference between buying some thing which is branded “Tuya” and something which was made by tuya for another company and sold under the other company’s brand name. At that point firmware changes might be made that would affect compatibility.

Tuya offers an integration for its own brand Devices with smartthings, but I don’t think they’ve included this particular device in that yet.

yeah i get that but there support with other platforms has dropped enormously the last year. so thats why i thought of this.