[OBSOLETE] Fibaro Motion Sensor - New device-handler with all settings and auto sync feature

I just started using your new device type down here in Brazil. Very good work on the settings screen. IMHO this should become the default ST device handler soon :wink:

1 Like

So, how do I use this device type for an already added Fibaro motion sensor? Do I have to exclude and re-add the sensor or can I edit current device? I am using the device typ from the pre-relase for fibaro motion sensor thread by Twack.

Really looking forward to trying this out.

1 Like

Easy. Add the code using IDE and then in device list click on the one you want to change. From here you can change the device type of your existing devices.

1 Like

Seems to work great this far! THANKS!

This is awesome. Thanks!

Cool! Seems like a pretty flesh-out device type. Waiting on the next wakeup from my two Fibaro sensors for them to sync, as I’m pretty lazy about plucking them from their mounts and triple-clicking the button to sync the configuration. Looks promising!

The only caveat is that the battery level is still showing 100%. But I got this value from proper zwave cmd class so either this device is a low energy eater, or it doesn’t report the battery level properly.

1 Like

My device went from 100% to 1% one day. I think the device only sends a “low battery alert” as opposed to battery percentages.

Ok, first let me apologize for my newness, but I’ve had smartthings for almost a year with only a lock and some light switches on it. I’ve recently added a Fibaro motion sensor and would like to control more of the parameters. I don’t know where to start. I think I’ve used the ide, but I’m not sure. Is there a newbie post that tells you how to get started with all of this? I’m also looking at picking up a few of the quirky door sensors and I see the same type of instructions, so I’d like to educate myself and get more involved with this. Thank you very much in advance!

Create a new device type in the ide and paste the code. Then in you device list you can change the device type of the device to use this one instead of the built in device type.

1 Like

This is AWESOME! Thank you!

Any news on getting this submitted for approval? I would love to have local processing with these sensors when I install a V2 hub.

3 Likes

Not trying to hijack the discussion from this awesome device type, but I am having a hell of a time including this device. Does anyone have any good tips?

Update: as soon as I posted this, I was able to successfully include it. It took me several inclusions and exclusions before it worked.

Try excluding it first then include it.

I cant seem to get the LED’s to turn off, I have set parameter 80 to LED Inactive but still they flash when they detect movement. Has anybody been able to successfully turn them off?

My sensor LED is turned off. I set 80 and 81 to zero, as well as 89. And of course, you have to wait for the changes to sync.

1 Like

Sorry if this was already answered and i missed it, I have my 5 Fibaro motion sensors set to turn on lights in dark rooms based on illumination of less than 5 LUX, i used this excellent IDE and am trying to get the LUX to report quickly as my issue is that it seems to take long for the Fibaro to send back the report when the rooms in question are light again, basically they would be in 0 to 1 Lux at night and when lights are on in the rooms or daylight arrives, they still report the LUX below 5 so lights are still turning on even though it s bright in the room. Then after mid day i get the higher Lux reading but by nightfall they are still reading the higher Lux preventing lights from turning on. i set the illumination threshold down as far a 1 to report change but still takes long. Any suggestions would be greatly appreciated. thank you

Sounds like its not polling that lux level on a regular interval. You might want to use pollster (I think its called that). Have a search, this basically forces the device to update its readings to the hub (as far as I’m aware?)

Found the thread:

Thank you deano12, i will take a look at that.

I adjusted the settings in my Fibaro to sample the lux more frequently. I believe the settings to change are:

  • Parameter 40 Illumination report threshold - Set mine to 50
  • Parameter 42 Illumination report interval - Set mine to 180

The p.40 is suppose to report changes in lux of 50 or more, but I find it reports pretty much any change within about 2-4 lux. The p.42 means it will report every three minutes – however, it only reports a change, so in real world it only reports that frequently when the lighting is changing (which is exactly what I wanted).

You might find this SmartApp helpful, it controls the lighting using dark and bright lux values.


Make sure the dark and bright lux values are a good 15-30 units apart, or you might get a flashing effect. Also make sure your Fibaro units aren’t pointed right at lamp.

1 Like