[OBSOLETE] Enhanced Z-Wave Garage Door Controller GD00Z-4/GD00Z-5/Linear/GoControl/Iris/Nortek Device Handler with Switch and Automated Garage Door Open/Close when People Arrive/Leave/Timer [OBSOLETE]

Updated, thanks

Installed your device handler today and now the status screen is stuck at opening. I can’t get the close or open buttons to do anything. Any suggestions.



That would mean likely the device isn’t communicating with the hub. The open and close should work independent of status. Open Live logging and see what happens when you click open/close. Is it sending a Z-wave command?
I would suggest start with bring the device closer to the hub and try it out and work backwards from there. (also reboot the hub power on/off, that often helps with communication issues).

Open and Close do not send commands, but refresh does. Below is the output from live logging. I was using a different device type that open and close was working with. As soon as I changed it to your device type it just stuck on opening. I’ve also tried opening and closing manually to reset the tilt sensor. That hasn’t worked. Tried changing the device type back to the original. That wasn’t working either.

acab7166-a891-4a3d-aa3e-d57381400af6 9:21:50 PM: debug "zw device: 2E, command: 9881, payload: 00 66 03 FE " parsed to [['name':'door', 'value':'opening', 'isStateChange':false, 'displayed':false, 'linkText':'Garage Door', 'descriptionText':Garage Door door is opening]] acab7166-a891-4a3d-aa3e-d57381400af6 9:21:50 PM: debug BarrierOperatorReport BarrierOperatorReport(barrierState: 254) acab7166-a891-4a3d-aa3e-d57381400af6 9:21:50 PM: debug encapsulated: BarrierOperatorReport(barrierState: 254) acab7166-a891-4a3d-aa3e-d57381400af6 9:21:49 PM: debug Resetting low battery notifications acab7166-a891-4a3d-aa3e-d57381400af6 9:21:49 PM: debug Device MSR 014F-4744-3030 acab7166-a891-4a3d-aa3e-d57381400af6 9:21:49 PM: trace Poll called acab7166-a891-4a3d-aa3e-d57381400af6 9:21:49 PM: trace Refresh called

Looks like the garage door is responding to the refresh commands. I would just delete the device and start over and try it. (don’t forget to exclude it and repair it)

OK. I’ll prob have to do that this weekend. Thanks for the help.


1 Like

@RBoy I just setup this device type with my 2 garage doors. I had a routine that turned On the switch that is associated with this device type, but it oddly opened up BOTH of my garage doors. Is this normal behavior? I am concerned that since the garage doors are next to each other, perhaps there is some sort of interference going on?

Basically, what I am looking to do is have a routine that opens/closes the Garage door by just hitting the widget or calling it from Alexa. I was doing this fine previously with my MyQ doors, but these same routines aren’t working right with my Linear devices. I am trying to avoid having a separate routine for open and close, and of course to use Alexa to say “Open garage door”.

No it’s not. Devices cannot communicate with each other. I woul check your settings in case you accidentally selected both devices in your routine. If not report it to ST support

Not a problem with your device type. I opened a new thread here:

Strange Linear Behavior

1 Like

@RBoy Donated today and got the app. Thanks for the great work. One quick question, how would I go about putting a notification if the garage door has been left open for more than lets say 10 mins? Notify Me smart app seems to be instantaneous or did I miss something?

1 Like

I added that functionality with Rule Machine. I had it before the developer pulled it.

I’ll try it out with CoRE later

I use the notify app from the market place. Since it presents itself as a door you can use the doors and windows dashboard app and configure it to notify when the door or window is open or closed etc.

The only issue I am having with that approach is, I need a notification only if the door is open for a set period of time. The notify me app notifies you immediately.

I’ve set it for 15 minutes. Somewhere in the advanced options I found that setting.

I just installed a GD-001-Z (from lowes bought online for 1/2 the price).

I was disappointed to learn it would not work after a power outage. I started researching and found the threads in the community.

I can tell you with the default handler I waited up to an hour with no refresh in the “Unknown” status.

I tried out gouldner’s code from Ron’s post above: https://github.com/gouldner/SmartThingsPublic/blob/master/devicetypes/gouldner/rg-linear-gd00z-garage-door-opener.src/rg-linear-gd00z-garage-door-opener.groovy

When I changed the handler in the IDE the door immediately changed to closed from unknown (it was closed). I was then able to control the door again with the interface!!

I put it back to default and tried again. I pulled the power cord for 15 seconds and plugged it in and got status “Unknown”. I waited the 15 minutes RBoy talks about and saw nothing. I again changed the handler but this time nothing. As I recall I was on the new handler, changed to default and then back to the new one when I got no result. I changed back to the default one again and then back to the modified one a second time and this time it showed closed again?!

Perhaps this is a workaround. Toggle the handler in the IDE a couple of times?!

Anyone else want to give it a try and report back?

The only solution I have found to this issue is to connect the GD001Z to a UPS. I bought the cheapest UPS I could get since this is a very low power device. It works like a charm. Just DO NOT connect the door opener itself to the UPS that would burn it out, just the GD001Z. The UPS keeps it from ever losing power so it never loses it’s state.

Ron, I am afraid you might have missed what I was saying. I am saying when I change device handler in the IDE the state of the door changes from unknown to a known state such as closed and then it starts working after a power loss. I haven’t tried it when the door is open but I am about to.

I had a power outage last night and saw it switch into unknown. After about 10 minutes I checked and said closed. So it’s working fine for me.

Here is one difference I see, you’ve bought it from Lowes where as I bought it from Amazon. Also they appear to be different models. I have the GD00Z-4 and you seem to have the 1 model. Maybe there is a difference in how they process resetting the sensor after a power failure.

Ok I did nothing this last time and after almost 45 minutes (I forgot to check sooner) it says closed and works just fine. So maybe it wasn’t the device handler change?

One thing of note, I didnt have the “THING” open. I was on the status screen with all my things and it said :“unknown” when I put the phone down. I opened it after 45 minutes and it loaded the same screen and changed suddenly to closed. I then opened the “thing” and clicked open and it worked. I waited a few seconds once opened and clicked closed.

I have also noted that if you operate it quickly back to back its not always great at doing what it says. For instance after a few seconds of it being opened I tapped the status icon to close it (not the open/close buttons) and it said “Closing” but nothing was happening. Because I could tell that I clicked “Close” and then it started beeping and going.
It didn’t work when it was open as of yet but it has 3 times now while closed.

Yes RBoy its an Iris branded from Lowes.GD-00Z-1