[OBSOLETE] Enhanced Z-Wave Garage Door Controller GD00Z-4/GD00Z-5/Linear/GoControl/Iris/Nortek Device Handler with Switch and Automated Garage Door Open/Close when People Arrive/Leave/Timer [OBSOLETE]

Yea I guess I missed your point. I thought you where looking for solutions. I didn’t think you had already found one. Sorry about that I was just trying to be helpful.

I have the gd00z-4 from amazon and mine doesn’t clear as yours does. And as I have mentioned in the past according to Linear this is by design and required by UL requirements since after a power outage the status of the door is lost and the tilt sensor only reports status after it changes it’s position. So until the tilt sensor reports it’s position UL code says you can’t “assume” the current position of the door. At least that is what Linear is telling me. I wonder if maybe your tilt sensor sends it’s status more often for some reason. Maybe it’s installed in a way that it is in between open/closed and any vibration (wind etc) causes it to send it’s position…just one guess as to why only your device seems to do this.


I am sure it is supposed to work that way by design. I suspect though that the tilt sensor is updating more frequently than well… never (until its moved) and that is why it starts working. The position becomes “known” and it will allow normal function to resume.

I have no idea why mine works and others do not? From what I had read and even from the instructions that came with it, this unit is made by Linear.

If anyone wants to compare notes about production date info if we can find such stamps I am willing. Technically I bought it from eBay but it is branded iris on the box and unit.

1 Like

Hey @RBoy,

Your device handler coupled with an nfc tag and Sharptools has made my life so so easy. Once again thank you!


Not to keep resurrecting this but I am hoping for some kind of commonality that others can use to help them…

Last night I added GE Z-Wave Toggle switch and wierdly my house wiring was garage lighting/opener, kitchen lights and my back flood/porch were all on the same circuit. Since I was replacing the flood switch I flipped the breaker and killed the Garaged door module. I didnt know until I turned it back on and heard it beep.

After an hour or so it was back operational stating “Closed” without any intervention from me at all.

I bet what you have to do is reset the sensor status to the controller. To do that you need to hold the button on the linear device for about 7 seconds until you hear a beep. Next open or close your garage door so the tilt status changes and it should beep again. Your status should update.


What I am saying is that it happened on its own. A good portion of threads on this opener are griping that it doesnt reset and work after a power outage. What I am saying is that mine does after anywhere from 15-20 minutes to an hour and a half so far

1 Like

If you’re trying to control the device using Alexa (Amazon Echo), please note that the stock ST Amazon Echo does not support operating locks and garage doors due to security issues. If you still want to control them using Amazon Echo, please use Ask Alexa, a custom integration which allows for the same.

I’ve had mine installed for about 9 months… Multiple power outages, and never a glitch out of the controller.

I’ve never had to reset it or anything.

1 Like

Interesting, I wonder if they changed something in newer editions.

My power went out this morning from around 6:20am to 12pm (transformer down the street blew). I did not have to do a reset, the device auto updated the status after a while.


GoControl/Linear GD00Z-4/others Device Handler - Version 2.4.0

  • Show a “Reset Battery” button on low sensor battery notification


I have been really frustrated with my Linear GD00Z-4 garage door opener. I think your App might solve the problem but I want to ask you some questions because I can’t find the answers from the manufacturer.

I was able to successfully pair this device to my SmartThings hub as well as several other pocket sockets and (this AM) a Schlage Door lock.

Even though the Door Opener is “working” with my hub, when I press Open the garage door will open but it will not display that it is “Opening”. The status continues to display “Closed” unless I repeatedly hit the Refresh on the Smart Things App on my phone. I have the same problem when Closing it.

In other words, it seems that either Smart Things is not polling the device regularly enough to figure out it’s actual status or the device is not reporting itself regularly enough.

SO, my question for you is this: Is this the incompatibility issue you know about that you resolve with your Device Type?

If I can use your device type to be able to keep track (accurately) of whether my garage door is open or closed then I’ll buy it in a heartbeat because, right now, I don’t trust the status that my SmartThings app is telling me.

I used the normal device handler before switching to @RBoy for more functionality. With the normal one it should still show opening and closing properly. I only used it for a day however since I needed a toggle switch functionality which Rboys DH provides.

There are multiple things that can impact it, first how the DH is written and how it communicates event, can’t speak to the version you’re using.
Second if the DH is correct reporting the events, is the SmartApp processing and displaying those events correctly. If the ST server is slow then it could be an issue but should resolve itself automatically after a while. Again until you’re 1 is solid you can’t comment on 2.

It’s literally the only device in my home that’s having this kind of slow reaction. I have 3 pocket sockets that instantly register their on/off status and one of them is in the basement (furthest from the hub).

I’ve got a Schlage deadbolt that instantaneously detects that it is in a Locked/Unlocked status.

The only device that’s not showing whether the garage is open/closed is the Garage Door Opener. I had a similar problem with the opener and got a replacement from Amazon.

I thought that maybe it’s the distance between the Hub and the Garage Door opener so I put pocket sockets to get a better mesh between the garage and the hub. That didn’t solve it. I then tried moving the hub into the garage with practically line of sight to it and it still didn’t solve it.

I’m thinking about just ditching this whole solution because it sounds to me like your app is not meant to resolve the kind of problem I’m experiencing. Is that a fair assessment?

You may want to start with trying our DH out if all other Z-Wave devices are working fine.

Did you do a Z-Wave Repair, this tends to fix a lot of problems, also reboot your hub? Also adjust the angle of the device when mounted (the antenna seems to do better in some directions than other).

I’ve tried the Z-wave repair a number ot times. One of the pocket sockets is in the garage. I haven’t tried changing the angle but will try that tonight when I get home. That’s a good idea.

When you say I should try out your “DH” what does that acronym stand for?

Device Handler :slight_smile:

I figured it out right after I asked. I downloaded the device handler and added it to my account and then changed it for the garage. It’s a really nice device handler.

Unfortunately, that didn’t resolve the issue. It’s not displaying the “opening” or “closing” status while it is happening and the only way to get it to update the status is to refresh.

I could live with this (a bit) if the handler would occasionally poll the device to see what its status is because, right now, I have to refresh in order to get the system to even know that the device status has changed.

When I get home tonight I’m going to try to see if changing the angle for the device will improve the communication a little bit.

1 Like

The DH does poll the device it should between 15 minutes to an hour but it depends up ST. I would also try to log out of the ST app and log in again.