[OBSOLETE] Circadian Daylight: SmartThings + Smart Bulbs

GE would have you drop $20 per bulb per color with their Align line:


Hey Kristopher,

Not sure if you are still around here or not, but I finally got around to ordering those lightify bulbs, and have noticed some really strange behavior. From your end, with circadian daylight app, it works fine. I used the v2 lightify device type you posted, but for some reason, if I have the bulb set to come on with motion and with it turning off 2 mins after motion stops, it will never turn on. However if I remove the turning off when motion stops, it will turn on, but obviously never turn off. Do you have any insight to why this is?

Hey Adam,

I have seen a couple things funky with this light. One of the things that happened over the last few months is that the official device driver is using a different method for setting the color temperature than I used. I suspect that is at the root of your problem. I plan to release a new version very soon.

To get more into the reeds about why this is happening – when Sticks and I wrote the unofficial device driver, we kept some of the state information on the bulb. ST moved all the state information to the Hub. So what’s happening is the bulb thinks its on already, which is why its not turning on.

Please check back in a couple days!


1 Like

Any word on the new version? My bulbs are basically just useless atm haha.

This sounds great. Where is the code for this in the app? I am looking at the CIrcadian app and do not see it.

You are talking about the blue LED in the dimmer switch correct? How can this LED be controlled from a smart app?

Almost all of the zwave wall switches/dimmers have a feature that determines when that LED is lit. If you look in the “Thing” tile for them, it’s there. “On when lit”, “off when lit” or “never lit”, so the SmartApp can change that option to control when it’s on or off.

I wrote a small SmartApp for my fan switch, so the light is never on because the “never lit” option doesn’t seem to work.

Do you have some sample that shows this?


Here’s the GitHub link for that SmartApp. indicatorWhenOn() method sets the option, so the LED is on when the switch is on. indicatorWhenOff() method sets the option, so the LED is on when the switch is off. There is a 3rd for the “Never Lit” option, but I found that selection doesn’t work for most of my zwave switches. This is built into the zwave switches, so those methods should be in any device handler for them.


Thanks, I will play with the code, I think this will help me with something I am trying.

Thanks again


Here is the fork – I rewrote Brian’s app pretty heavily. I feel my interpretation is more of a “blink” than a solid on or off.



Is it possible to blink the indicator light? What I am looking for is that when a push button is pressed, the indicator lights would temporarily blink to provide feedback that the “mode” has changed. One mode is normal manual operation of room lights and one mode is motion controlled.

For areas like a hallway, having the hallway lights always motion controlled works well.

But for a family room, having the lights sometimes manual and sometimes motion controlled is the best solution. I have a push button to change mode but I would like to be able to show some kind of feedback that the mode has changed.

Currently I am blinking the room lights, but that is less than ideal.

Yeah you can blink the indicator. Just turn it on and off with a 100ms delay or so. Even a few seconds looks pretty cool


Hi Everyone,

I updated the code to better support the updated Osram bulbs, and some modifications for the v2 hub. In addition, there are some new features sprinkled in like Dynamic Lighting (adjusts brightness based on time of day) and an option to have the starlight effect swap with a camp fire effect. Enjoy!


Having an odd issue, It seems that the mid day and end of day color change doesn’t happen reliabily. Any thoughts? I work from home several days a week and it seems that sometimes the mid-day color change just doesn’t happen (they stay yellow. If I shut off the light and turn them back on, they turn on to the correct color. I am also seeing a similar issue in the evening as they just stay blue all night in stead of changing to yellow again. Using the latest version of your code. Its obvious it works, just not sure why its not always working. To confirm though, I wake up before sunrise to start working and the tigger from night to day (at sunrise) has worked ever time.

Hey @Tweak3d – Do you have any mode restrictions? I’ve seen some funny interaction with that.

Also, what kind of bulbs are you using? Hues?

do you have a V1 hub or a V2 hub? I have found that the V2 hub is insanely unreliable for timers.

@Timgray - The app is all event driven. It relies on mode changes and motion detection in order to update.

@Tweak3D - It’s also possible that those events are not firing, for whatever reason. If you can get me some of your log, I can help diagnose better

@Kristopher Is there big differences between Hue and Lightify bulbs on how they work with this smartapp?
You mentioned some problem with Lightify bulbs that requires hub reset, is this still a case and would getting Hue bulbs be safer bet?

@LakeEnd - I updated the code about a month ago to handle both better. The big difference is the Osram bulbs are better at keeping track of their state than the Hues. In addition, they do better attribute reporting (i.e., if you turn it on via a switch, the Hub will know faster). So if anything, the Osram should work a little better.

Let me know if that works!


Just a heads up for those of you using this app with either Osram RGB bulbs or directly connected Hue bulbs, I’ve modfied the Improved Zigbee Hue devicetype to add Color Temperature capability (and some UI tweaks). The bulbs implement the color temperature aspect in addition to RGB, so you can treat them as color temp when used with this app for direct control of the various white shades.

1 Like