[OBSOLETE] Aeon HEM v1 DH Discussion (DTH link in post 411)

That must make you absolutely nutty. Setting to standardTile makes it align incorrectly and valueTile shows correctly, but disappears until you close the SmartThings app and reopen. Looking at where the data comes from, both the energyDisp and energyTwo seem to be in the same zwaveEvent, so I can’t fathom what the big difference is that would have the odd behavior.

You have no idea… Up until the last update everything was looking great, and now it’s crap. Frustrating is an understatement, especially when DH’s should work for any of ST’s supported phone OS’s.

As the saying goes, if it’s not broke, don’t fix it. I had the original code of yours working fine and refreshing every 10 seconds IIRC, but now it doesn’t refresh unless I force it. I have gone as far as deleting the HEM, resetting all settings, removing any code, copying the latest version and adding as a new device type, then re-adding the HEMv1 by pushing the button a few times in the back.

Everything looks fine from what I can tell, but it refuses to auto-refresh, thus isn’t logging power changes as configured. I will contact ST support tomorrow in case there is an issue I am affected by and just unaware.

I just got a hemv1 and not sure if it is working correctly or not. Lots of small issues. Under “recently” the last update was about 12 hours ago (running on batteries at the moment). Cost is “–” even though I have entered some0.107 for cost per kWh. It keeps forgetting the icon I selected. On android the device image is not used (I think it was showing on ios though).

Does hemv1 accumulate data? Or if I miss a high load period (a/c on and frig/freezer running hard for example), due to how often the hem reports data, would it just not count that high usage period? Thanks!

Running only on batteries does limit how often (and what) things report (rounded up to the nearest 4 minutes when battery powered).

With all the other issues you’re reporting, I would recommend excluding it and re-including the HEM. If at all possible, do that when on AC power. If you did join it correctly using AC power, and then switched to batteries (perhaps you moved the device), pull a battery so the HEM powers down, and then put the battery back in. You should see a red light on the front stay on and never blink if it joined correctly.

No it does not accumulate. It sends whatever data it reads based on your preferences you set up. If you miss a high load, then I recommend adjusting the report type to 1 and setting a low “change in watts” value and a low % change value.

I got it installed last night into circuit breaker box and have it on AC now. It is updating much more frequently now.

The SmartThings app tiles seem to be updating but the data from power(W) doesn’t seem to be getting “sent” outside the app/tile…
(1) it is not logging to my GoogleSheets via SmartApp (last entry was 800.4W yesterday)
(2) it is not updating on my SmartTiles webapp. SmartTiles has been stuck at 800W as well even though the energy (kWh) has been gradually increasing every hour.

So I pulled the trigger on Hub V2 and had to readd all of my items to SmartThings.
Ever since then my HEM v1 has not reported, even with the original DTH I was using for it which worked beautifully for the previous year.

I tried this DTH, and it is still not showing me any data.
The device is connected to the Hub, and when I use yet a third DTH I get readings from it, but I don’t get the functions I want, such as in this DTH.

Anyone have any ideas?

Reset and re-add, then hit configure a number of times and watch the logs to make sure it fully updates the device. Also, running a z-wave repair may help. One of my HEM’s actually stopped reporting a few days ago, the others were working fine, repair brought it back to life. All of mine are ac powered, if using batteries, try the usb adapter.

I just went through this and found it necessary to exclude the HEMv1 from the SmartThings IDE under the hub\Utilities section. Once doing so, re-adding it fixed the HEMv1 reporting. According to Aeotec support, it may be due to the following reason:

Thats odd that the automatic reports are not working anymore while polling does, I am unsure what would cause this issue. Although it is possible that the association group somehow lost the smartthings hub (nodeID = 1), which may require you to re-associate ST hub to Group 1 of the HEM G1.

The steps were found on their FAQ in the following link: https://aeotec.freshdesk.com/support/solutions/articles/6000113113-how-do-i-factory-reset-my-aeotec-z-wave-device.

After rediscovering the HEM, I immediately started seeing data, but it was completely off, so a 255 reset later and reconfigure with desired values did the trick.

Just updated to the latest release and I’m seeing a warning FYI.

Thanks for passing that along @greg. I’ll have to watch mine to see if I get anything similar. It’s not something to worry about, but I’ll investigate regardless. It looks like some type of message from the HEM is being passed that the DH doesn’t know what to do with.

I think I know what happened. I wasn’t keeping up on the thread and didn’t see that you added settings-

GitHub told me there was an update so I just updated and kept it moving. Today I noticed my plot watt wasn’t getting info from the HEM so I started looking deeper. Going into the Device settings in App and just hitting done seems to have fixed the issue.

1 Like

(moved here as this topic seemed more appropriate for my question)

@johnconstantelo - Quick question… Is it possible with the Aeon-HEM v1 to monitor both current transformers independently? I was hoping to use the HEM v1 to monitor both my Washing Machine and Dryer independently, and receive notifications when they finish a load of laundry.

Thank for your work on this DTH!


Each sensor is for one phase, two phases are used for 220v devices, your washer probably is just 110 but you need both to monitor the dryer.

Thanks for the reply. I understand what you’re saying, however I should have been more clear in my objective. I don’t really care about monitoring power consumption. I want to know when each machine finishes a load of laundry. The accelerometer trick doesn’t work on my units, so I wanted to monitor the power lines instead.

My first recommendation would be to use a couple Aeon Smart Outlets, which is what I do; but if your dryer is electric and 220v, then that won;t help you much.

Each clamp can be read independent of each other, and I believe someone in the Community did tweak theirs to do just that.

Thanks John. I’ll keep searching. I think Mike Maxwell may have a DTH to do exactly what I need. I found a discussion late last night.

1 Like

Yes, sorry I misunderstood your intent. Mike’s will work for your needs with just one device.

1 Like

Is anyone using this DTH with Simple Event Logger? This DTH worked well for bidgely and plottwatt for me, but bidgely shut down and plottwatt is supposed to. So I’m moving to SEL.

I’m guessing that this is due to the 2/16 edit where activity was removed from the phone and event log. Is it possible to have an option to re-enable for the event log? :smirk:

Hi @greg,

I use Google Sheets just fine. Even though the constant activity doesn’t show up on the phone or event logs, the values always update. A smart app shouldn’t need to subscribe to events, but to Power or Energy capabilities.