New SmartThings Alexa skill (2020)

So has anyone found a work around for scenes not working in alexa? I NEED to be able to lock doors by voice. Does the virtual switch fix work well? or is there a better option?

Yeah over this weekend I disabled the Alexa/SmartThings link, deleted all the devices on Alexa, and waited 48 hours before re-initializing everything.

Routines still don’t work. I’d love to move everything over to SmartThings, but I don’t think they see my CE Smart smart plugs, so I’m kinda boned here.

Edit Basically the routines that don’t work are the ones triggered by SmartThings devices (motion/door sensors). Basically we have toddlers and I want a voice notification that the front, back, or garage door has opened.

Helpful instructions, Nathan, thank you!

They would have been even more helpful if I’d read a bit more carefully!

I managed to skip right past where you say to delete scenes. I was able to recover by deleting all scenes (new skill and old), then doing discovery again.

I’m up and running on the new skill. Took about an hour and a half. I had fully migrated, manually, to the new app a couple of months back. I’ve got 55 devices in SmartThings and about a dozen scenes.

Have about 15 routines in Alexa that interact with SmartThings, all triggered only by voice commands.

Probably not related but I found I had some odd duplication of Sonos “devices” in rooms where I have Sonos stereo pairs and surround sound setup. Deleted all Sonos from those rooms via the Alexa app and did a discover. The only reason I have Sonos connected to Alexa is to set preferred speakers in each room so requested music plays via Sonos and not my Echo Dots.

1 Like

Well, it’s done. New skill installed and absolutely no routines with ST devices are running AT ALL!

Thanks SmartThings for a bunch of wasted time. This is absolutely the worst Alexa integration I have ever experienced with any home automation device or platform.

Shame on you SmartThings. Class action anyone?

3 Likes

It may be a cloud to cloud issue. If it doesn’t fix itself after a day or so try to delete all your device from Alexa and the setup the integration again.

Virtual switch to trigger an automation that does the locks works fine. Here’s the community FAQ. (The topic title is a clickable link.)

Virtual device to trigger Alexa routines (not SmartThings routines) is still unpredictably erratic for some users.

1 Like

I can testify to that - as can many others. Works sometimes, slowly works at other times, and doesn’t work AT ALL frequently :weary:

1 Like

This new Alexa integration is crap.

I have 2 ST locations, and I have to exclude all the devices from location 1 inside Alexa location 2, this is a very time consuming process.

Triggering Alexa routines from ST contact or motion sensors has a 5 min delay. Never had a delay with the old skill.

Alexa routines will sometimes do what they are supposed to do, but most of the time they do nothing.

The only thing that does work, is voice control of devices, everything else is broken.

4 Likes

I did some informal testing yesterday since I am seeing the same slow behavior with my new ST -> Alexa skill. I would push the virtual switch in ST, go to the Alexa app and watch for my routine to fire between the ST virtual switch and the actual device connected to Alexa. Usually I would see the ST trigger to on or off within 30 seconds, but then noticed Alexa wasn’t firing the routine that would trigger the light/plug/whatever in a timely manner. This is where I saw the minutes to never time lapse. I don’t know why changing the ST skill would impact Alexa routines, but it does appear to do so for me. I didn’t delete/recreate these routines after the migration, just fixed them as needed - maybe they need to be completely deleted? Anyone else test like this and see this behavior?

If you read this entire thread you will see that this is a known problem with many people being affected, but not everyone, and the effects are erratic so that sometimes it works, sometimes it’s delayed, sometimes it doesn’t work at all. That is it doesn’t fire the Alexa routine. This was introduced with the new Alexa skill.

Smartthings engineering is aware of it and is working on a fix for it and that fix should be announced once it’s done, but it’s not done now and there’s no timeline and there’s nothing a customer can do on their side. We just have to be patient.

1 Like

My observation was this is an Alexa problem. ST changed it’s status in the Alexa app, it was the Alexa routine not firing - I didn’t see mention of that earlier. That is why I posted - not to add the same complaint over again, simply to offer the suggestion it’s an Alexa issue.

1 Like

The Alexa routine not firing even though Alexa notes that the device status changes is a problem with the smartthings integration to Alexa. :disappointed_relieved: It is not a problem on the Alexa side. Again, smartthings engineering is aware of it and is working on it.

BTW, when this first started to happen I noted above that I have sensors from four or five different platforms that I use with Alexa routines, including Phillips hue, Wyze, Ring security, etc and all of those continued to work fine to fire Alexa routines. It’s only the smartthings sensors that fail in this regard.

Interesting - I thought the skill just passed the device status change to Alexa, I didn’t realize it played a part in the Alexa routines firing. Hopefully they can fix it soon.

1 Like

Some previous reports where people saw the status change in the Alexa app but the routine did not fire.

.

But then there were other people who were not seeing the devices update their status in the Alexa app. So multiple different problems, or maybe different problems while they were working on fixing the base problem.

In any case, you know you’re not alone and that engineering knows about the details of the issue that you saw. I know that’s not much, but it’s something.

On a lark I just installed the classic app again, and I noticed that my migration did not succeed. One of my Smart Locks was holding up the works. I removed that smart lock, and managed to get the migration to work. I’ve re-installed the new app, and removed all the skills. I’m gonna wait an hour or two and try once again re-adding the skill to Alexa and see if everything works again.

It might work and it might not, but the problem is not yet officially fixed and people are reporting erratic performance with the new Alexa skill. There’s nothing we as customers can do about it except be patient until the official fix is released.

Yeah I just want to add some data points in case someone else comes behind me with the same issue.

1 Like

You’ll need to reselect the triggers / actions that come from ST since the original targets were removed with the old skill.

Might be it for me. ST blew it. WAY too many headaches with this. This is no small thing, and I should not have to spend so much time on things that worked fine a few days ago. Never should have rolled this out when it is clearly still at beta level. Not happy at all, and may just move on from ST. Already VERY disappointed with the “Family hub” limited functions.

6 Likes

In what way are scenes not working?

I can invoke SmartThings scenes by saying “Alexa, activate [scene name]” and I extensively use scenes in Alexa routines.

Worked with the old integration and still working (after recreating my routines) in the new integration.