(NEW RELEASE) Edge Driver Beta Z-Wave Siren Mc Modified for Ecolink Firefighter


I’m glad it works fine!

Tomorrow I will add a preference to correct the temperature offset.

I will also put a preference so that can be customized the wakeUp with the temperature update from 1 hour to 6 hours

And I will merge it to the Z-Wave Siren Mc driver

Try it today and if something doesn’t work tell me


Cheers to you for your work! Much Thanks!


I have published this version 3 with preferences for temperature offset and wakeUp interval from 1 to 24 hours, the same as DTH.

Please, when you can try it to see if it works well and does not give any error in the driver installation and changes in the preferences.

If everything works fine I will merge it to the Z-Wave Siren Mc driver

│ Driver Id   │ c51a87ab-dcb9-42ba-bf9d-55d4c3b422bb │
│ Name        │ Z-Wave Siren v3                      │
│ Package Key │ zwave-siren-v3                       │
│ Version     │ 2022-04-24T18:01:39.145895           │
1 Like

Looks good! Wake up defaults to 4 hours which is a decent standard.

Again, much thanks!

1 Like

Thanks to the request of and @Jason_Meudt help for testing and debugging driver, I have released a new version of the Z-Wave Siren Mc driver for Ecolink Firefighter:


  • Added Capabilities TemperaturMeasurement and TamperAlert
  • A preference has been added to configure the WakeUp from 1 to 24 Hours, by default it is 4 Hours.
    This will periodically update the temperature and battery.

The driver update will be done automatically in the next 12 hours

@Jason_Meudt will have update driver manually changing from your test version v3 to the definitive Mc

│ Name        │ Z-Wave Siren Mc                      │
│ Version     │ 2022-04-26T17:41:08.36624            │

@Jason_Meudt will have update driver manually changing from your test version v3 to the definitive Mc

Done and thank you! You can delete the V3 version now!

1 Like

I feel like I’ve seen this asked many times but now can’t find the answer - after testing my smoke and co alarm with the firefighter next to it, the CO detector isn’t clearing.

Historically I’d edit the device in the IDE and click update and that would clear it. But that’s not working now presumably because this is edge. I tried testing the alarm again, excluding+re including + test alarm again =same issue, pull the batteries for a while, refreshing in the app detail by pulling screen down. All to no avail.

Anyone know how to clear it?

@Mariano_Colmenarejo have you made these modifications to the ZigBee driver for the ecolink firefighter that is ZigBee?

Raw data from my ecolink firefighter

firmwareManufacturerCode: 4130

firmwareFullVersion: 03180531

application: 01

endpointId: 01

firmwareImageType: 4

manufacturer: Ecolink

model: FFZB1-SM-ECOn

Raw Description01 0104 0402 00 07 0000 0001 0003 0020 0402 0500 0B05 01 0019

fingerprint mfr:"014A", prod:"0005", model:"000F"

I have an ecolink firefighter that now does not work .
Can u direct me to a driver that I can install to work with all the new software?

Hi @Todd_Basche

Is a Z-Wave or Zigbee device?



Hi @Todd_Basche

You can use the Z-Wave Siren stock driver. It has sound capability and will automatically switch to this driver when migrating.

You can use Z-Wave Siren Mc.
It has sound, smoke, CO and temperature capabilities.

The link to my channel is in the first post of the thread.

Thank u.
I’m not sure what to do I enrolled and installed that driver.
So I reboot hub ?
Thank you

Once the driver is installed in the Hub and if you were not using a custom DTH:

  • Exclude the device with the App
  • Put the device in inclusion mode
  • Add new device and choose search nearby
  • The device will appear in an unassigned room

If you used a custom DTH, you should delete the DTH from your IDE

1 Like

I have two homes with a hub in each.
I installed your driver in my ide .
One house the ecolink installed and works fine .
(Though it does not show up as ecolink)
My other house I have not been able to get the ecolink installed and working .
Does your driver in ide work for all hubs ?

Hi @Todd_Basche

Sorry, I don’t know if I understood you correctly.
Have you installed the driver in your IDE?

If so, you have to install the Edge driver Z-Wave Siren Mc from this shared channel on each Hub.
Once the driver is installed in each Hub you have to exclude the device and re-include it with the search nearby option.
Device will appear in unassigned room

Thanks so much I did not realize I had to install in each hub.


Thank u .
It works now but now my device keeps going offline.

Hi @Todd_Basche

By excluding and including Zwave devices for pairing with the edge driver, your network mesh may have changed and you may have to wait for them to find their most efficient path again.
It can help you by performing Z-wave repair in Hub zwave utilities menu in App or IDE page

Hello and thanks for all your help.
I have these drivers working now in two locations
And the device reports status fine.
However when I test my smoke alarm it does not trigger the sensor now.
Any thoughts?

Will there be an official supported driver for these devices?