New Leviton In-Wall Dimmers

GE Z-wave plus out already:

Cool. Amazon doesn’t have the GEs in yet, but hopefully Leviton will follow soon.

I’m still waiting for my official Homeseer dimmers to arrive, but I did notice that as of 10/20/2016 there is a “new” Dragon Tech switch on the Z-wave alliance page. It looks like the same old switch with a new firmware. They are listed as in stock at zwaveproducts so I ordered a 3 pack of them testing.

The Dragon Tech still has the same specs as the Homeseer switches, and the 10/20/2016 versions appears to have the “new” direct association feature that Homeseer said they would be releasing an update for.

This makes sense since the Dragon Tech switch is listed as running firmware 5.15 on Z-wave alliance while Homeseer lists 5.14 as their current version.

I’ll have to play around with cross flashing them as updates come out.

I didn’t want to keep cluttering up this thread with Dragon Tech / HomeSeer switch information, so I posted my review of the switches in the HomeSeer thread. I’ll be continuing to report my findings there.


Strangely, I saw one of these in Home Depot today, but can’t find it on their site. At least they exist now.


1 Like

I also found them in-store at Home Depot. Decided to pick one up to compare with my Homeseer/DragonTech and VRMX1 dimmers I have now.

1 Like

These are finally showing up on the Z wave alliance product site again. Interestingly enough, the manufacturer for the zwave plus devices is shown as “Leviton,” while the manufacture for the older zwave classic devices is shown as “Vizia” even for the nonVizia models.

I mention that, because it means that if you are looking at one of the older zwave classic models and you click on “other devices by this manufacturer” you won’t be shown the Z wave plus models.

FYI, this is my first post ever!

I bought a few of the GE Z-Wave dimmers based on thewirecutter’s rec - they were the runner up but I saw no need for the Z-Wave plus features and they were easily/cheaply available. Anyway installed them and got a pretty loud buzz from my LED bulbs. Tried replacing with multiple other bulbs and while some were quieter than others, all made some noise. Read some other posts on here that said the GE dimmers tend to do that.

Anyway, was bummed because I was having trouble finding any of the Levitons in stock at HD or Lowe’s but lo and behold I just found 12 of these new DZ6HDs on the shelf at my local Home Depot (in Tustin, CA). It doesn’t show up on their website, and YMMV, but they may be starting to show up in store. I’ll try to report back when I have them installed and set up.

1 Like

Do you have the neutral wire connected to the switch and are the LEDs dimmable? I have LEDs through my whole house and GE dimmers and never get buzzing.

Yes and Yes. I tried several bulbs and the Sylvanias were the quietest, but still made some noise. Others seem to have a similar problem as evidenced here:

I’m excited that the Levitons have different settings for LED/CFL/Incandescent so will test that out tonight.

The site for the company that makes the GE dimmers (Jasco) does list some bulbs as compatible, but there are only a few of them. It’s certainly possible you just have ones that work with them.

I spent a good chunk of this weekend testing bulbs and looking at the compatibility lists on some of the sites. If you look at the compatibility lists, there are about a dozen listed on the Jasco site, hundred or so on the Leviton, and multiple hundreds for the Lutron C-L. If these still buzz I might need to change my hub to Wink and the dimmers to Lutron Caseta, but we will see…

1 Like

Before I went to smart switches I had Lutron dimmers and fan controls almost exclusively in my home. Well made stuff. For some new chandeliers I installed with Cree dimmable LED bulbs I installed Lutron Maestros that said they were compatible with the bulbs I had. Nope. Horrible buzzing in the bulbs. So, take those compatability list with a grain a soft. I was a bit miffed too as one of the chandeliers was on a 4-way so the switch set up was not cheap.

Now, to be fair, when I installed my GE dimmers the bulbs still buzzed and changing to another brand of LEDs (Phillips dimmable Warm Glow) cured it 100%. But it does not take away from the fact Lutron had the older bulbs listed as okay.

So you really get what you pay for, at least with LEDs. Just bit the bullet and bought Phillips warm glows and they work perfectly and are silent. Still think the Leviton are much nicer looking and working than the GE, but the bulbs were probably the issue.


I just installed one of these on some Lowe’s Utilitech Pro LED retrofits, which have given me good luck with other dimmers I’ve tested in the past. They didn’t buzz with Caseta or GEs very much unless I got about 2 ft away. With the Levitons there is a faint buzz when I’m standing under them. I have to try to hear it though. Not a big deal. I do love the look of these. The paddle seems a bit looser than I’d like. Instant status works great. ST updates the brightness value about 1 second after I change the brightness physically on the dimmer. The issue I’m trying to rectify is that there seems to be no difference in brightness past 70%. Also, when they go to 100%, my LEDs dim ever so slightly after hitting 100%. I’ve been messing with the max brightness setting but it’s a bit wonky to adjust. EDIT: OK, I was able to trim the max brightness and now it’s working much better. EDIT 2: It seems it just limits the max % the switch goes. Now my max brightness in ST is 78%. When I slide it to 100% in the ST app, it corrects back to 78%. I don’t like how that works. The trimming should set that as the 'new" 100%. Anyone experiencing this too?

Does anyone know a way we can send commands to these switches to set the advanced configuration parameters? Do we need to wait until someone creates a Device Handler that exposes these values? I was thinking of dusting off my Veralite to try and set the parameters.

I’ve been waiting for these for a while and they finally showed up at my local Home Depot (East Windsor, NJ). I installed one yesterday and it works great and looks great.

Under “Advanced Options,” the manual lists everything that you can program, but apparently fade on/off time is only programmable via a Z-Wave controller (at least, they don’t give instructions on how to set those via the paddle). Anyone know how to set these options with SmartThings or is there no way currently? Is someone going to need to write a SmartThings app to do this?

It wont need to be a SmartThings app, customer device handler can be configured to allow the user to make those changes from within the device settings. It may take a while for someone to get around to it though.

1 Like

I just bought and installed a Leviton DZ1KD-1BZ dimmer switch. It has 7 LED lights that it controls. The switch paired easily with my Smartthings. But after a few minutes, the switch shut off, the LED on the switch flashed red and the switch disappeared from Smartthings. Do I need to return it to Home Depot? I’ve repeated this several times with the same result.

Try adding it manually by selecting the model manually when you’re adding it. It seems to work better when pairing and it won’t error out. It also takes a while for ST to finally see the device even though the dimmer reports a successful pairing.

I think mine might need to go back to Home Depot though. These have been acting really wonky for me lately. They stopped updating status to the controller. I repaired the z-wave network, removed, re-paired the dimmer itself and still no luck. Using the switch manually isn’t updating the status anymore. ST also stopped reporting the dim value. Now it’s two dashes instead of a percentage. I had changed nothing since installing and using them for several days. I started noticing the incorrect device status a couple days ago. Did ST change something in the Z-Wave Dimmer Switch Generic device handler? That’s what mine gets added as each time and I don’t see an alternative option to change it to in the IDE. There is also some physical wonkiness with the dimmer that I noticed since I first got it. Sometimes when I try to make it brighter or dimmer by one level, just tapping the dim bar will take it to full bright or off. It doesn’t matter what level it’s currently at. If I’m at dim level 3, it will go all the way to the brightest. My last resort is to try and factory reset the dimmer itself.

EDIT: Seems like a factory reset and re-pairing of the dimmer has fixed the reporting issue. Seems back to normal. Let’s see if things deteriorate again in a few days.

Does anybody have the Leviton DZ6HD or DZ1KD dimmers with matching dimmer switch remote DD00R hooked up and working?

I know that the DZ6HD sends instant status updates to the hub when physical adjustments are made, but do the same instant updates occur (no manual refresh needed) when physically adjusting the DD00R remote?

Does anyone have the DD00R remote?

I installed one yesterday but I think there’s a bug. The remote has the LED dimming indicator (left side) always on.

On the DZ6HD these indicators are only ON when the lights are ON

Yes, the LEDs on the DD00R are not tied to the settings for the LEDs on the DZ6HD as you would expect. Also, if you try to adjust the dim level before turning the light on you need to wait a few seconds before turning the light on or it won’t work. Also, instant status updates for on/off do not get reported to the hub when using the remote.