New ecobee sensors are not available in the device list

Hi All,

Just installed two new ecobee sensors, but I can’t see them in the “Things” list of smartthings hub. Is there a way to add them without removing and installing ecobee thermostat itself?

Thanks,
S

If I remember when I added mine, I just added to the Ecobee thermostat & they showed up in Smart Things. It has been a while & age maybe getting to me but think this is what I did.

Mike

Once they are added to the Ecobee you have to re-run the Ecobee (Connect) program. Go to Automation -> SmartApps -> Ecobee (Connect). Under “Select Ecobee Sensors” you should be able to add them then click Done.

3 Likes

@vseven, can you point me toward the Ecobee (Connect) Smartapp? I don’t see it available under SmartApps within the ST app (neither classic nor new version). I’ve located a couple of apps developed by community members (MyEcobee and EcobeeSetZoneWithSchedule), and I don’t mind paying for an app that does what I want, but I thought I’d follow up on this first since it sounded like an official Ecobee app.

All I’m trying to accomplish is being able to ask Google Assistant what the temperature is in my office, etc. I can’t do that now, and I think it’s because my SmartThings system doesn’t know about the room sensors even though Ecobee does.

Thanks for your help!

@vseven, oops! I found it! I went back to ST Classic, and Ecobee (Connect) was right in front of me. Going to leave the comment here in case anyone else was looking for it. It looks like it may be available in ST Classic only. Once I enabled the sensors, there, though, they showed up in the new ST app.

In the new app… go to the menu (3 bars in the upper left of the screen) click on settings (the cog) and look in Connected services