SmartThings Community

New app — which CUSTOM DTH’s will work?

(might be my fake name?) #1

I was encouraged by other forum community members to start a topic to discuss which custom device handlers a.k.a. DTH’s will be supported in the new app. (If any )

For those of you that are using the new app, can you confirm any custom device handlers that are working?

Below are the ones that I use and am seeking info on… Thanks in advance…


Also, if custom DTH’s are not going to work, Will those devices show up in the new app? Or do I have to exclude them and then add them again using their default device handler?

Can I use old Zigbee DTH for new hub (2018)?
Migrated to Samsung Account - all devices are "unknown" in new app
New SmartThings app
FAQ: An Overview of Using Custom Code in SmartThings (SmartThings Classic)
[MODIFIED] Netatmo Weather Station
All devices show "disconnected" except new TV
Multiple devices can't connect on new app
New Smartthings app recognizes Monoprice Z wave motion/temp detector but gives error cannot connect
My new Zigbee Device Handler shows "Checking status" in Smartthings App but working fine in Smartthings Classic
Device shows on Classic but not new Smartthings App
[BETA] Community SmartApp Installer
Can't connect devices to Samsung connect home pro
*Request* For New SmartThings (Samsung Connect) App
[RELEASE] Remotec ZXT-120 AC IR Controller (2015)
SmartThings isn't (Smart, that is) anymore. How does one install an existing Smart App for a device in new app?
How do I add a custom device handler?
SPECIFIC differences between "SmartThings (Samsung Connect)" and "SmartThings Classic"
SPECIFIC differences between "SmartThings (Samsung Connect)" and "SmartThings Classic"
Can I use old Zigbee DTH for new hub (2018)?
Smartthings classic app & samsung account
Hiding child devices in new app
Custom DTHs in the new Samsung Connect app?
[SOLVED] Tradfri bulb + new hub & app (V3)
Making Dome Siren sounds work with SmartThings Button?
Is there any update on smartthings app issues after uodate
Classic app and new app don't agree?
All devices show "disconnected" except new TV
Help needed with new app
Sinope Zigbee thermostat- ST hub v3 2018
Disconnected devices, Smartthings vs Smartthings Classic
Hub V3 - use the old or the new app?
[RELEASE] Garadget (Connect)
New App vs Old App - disconnects
Out of the loop - Many errors with new App, Classic app doesn't have my Things
Hue motion sensor (no hue bridge)
Where to get Smart Apps?

Tagging @prjct92eh2

(jkp) #3

All the devices you have installed will show in the Samsung Connect app. For those with device handlers that don’t work, the device will either show as Disconnected or when you click on it, it will display Can’t connect to Device.

Can I use old Zigbee DTH for new hub (2018)?
(Jimmy) #4

Every device except for mobile presence will show up in the new app. Whether it will automatically work or not is the big question. Some of mine such as Xiaomi contact and motion worked automatically. Others I’ve recently gotten working myself. I suspect at or before Samsung Developers Conference in November they will publish documentation of how to get custom handlers working. In the mean time, if you want to do some tinkering, go to their public GitHub and search for mnmn and vid entries in the metadata definition. Add the same to your custom handlers and edit and save the device to test.

V3 Hub can take Custom devices here is the work around
New App vs Old App - I am confused
(Bob Kerr) #5

I found that mnmn is not required, but vid is, along with health check. Most vid are intuitively named but some are not. The most awkward one is the thermostat. Here is a list of known vid:

· SmartThings-smartthings-Z-Wave_Thermostat
· generic-arrival
· generic-button
· generic-carbon-monoxide
· generic-contact (contact, battery)
· generic-dimmer
· generic-dimmer-power
· generic-dimmer-power-energy
· generic-doorbell
· generic-humidity
· generic-leak
· generic-lock
· generic-motion (motion, temp, battery)
· generic-motion-3 (Motion, Acceleration, Battery)
· generic-motion-4 (motion, Temp, Illuminance, battery)
· generic-motion-5 (motion, temp, illuminance, tamper, battery)
· generic-motion-6 (motion, temp, humidity, illuminance, battery)
· generic-motion-7 (motion, temp, humidity, illuminance, tamper, battery)
· generic-rgb-color-bulb (edited)
· generic-rgbw-color-bulb
· generic-shade
· generic-siren
· generic-siren
· generic-smoke
· generic-smoke-co
· generic-switch
· generic-switch-power
· generic-switch-power-energy
· generic-valve

Zigbee Thermostat control shows "Couldn't connect to..." in SmartThings App but works in SmartThings Classic App
RGB Light Connect App
(PPO16) #6

Hi and really thanks for the hint. I ported 2 self-written DTH but seems I have to remove them and then put them back to have the DTH working.

Same on your side?

(Bob Kerr) #7

Yes, it takes a little dance to make some come up. Have two Nests, (thanks again @tonesto7). One showed up instantly, the other one was a pain, and don’t know what actually triggered it to show up, but I am glad it did…

Quick preview…

[RELEASE] NST Manager v5.0
(PPO16) #8

Thanks. It seems also that for now, only standard attributes are displayed/displayable and I did not find a way to display temperature first rather than humidity when a device of “generic-humidity” is used. I did not find a “generic-temperature” so I am wondering how to have the temperature first.


(Jimmy) #9

You don’t have to remove the device to get the new UI to “stick”. Just edit and save. Sometimes change the device type, save, change back and save. Sometimes force close the app and re-launch.

(Bob Kerr) #10

Sometimes after you’ve done all that, just go for a run and come back to it later…

(PPO16) #11

Found how to force the refresh. On Android, go to the setting/app and delete data/cache. The force stop and restart the app.

( #12

I tried to add vid: “generic-switch” to Inovelli (@Eric_Inovelli) DTH for dimmer w/scenes and it works. It showed in new app. It’s time to add thise values to all custom DTHs.
Also all my Monoprice devices showed, thanks to @RBoy’s updates.

(Jimmy) #13

With the stipulation that this can break at any time without notice since it isn’t officially documented/published yet.

(Arn B) #14

Any VID (vendor id) suggestions for the Iris/Centralite Keypad DTH?

definition (name: “Centralite Keypad”, namespace: “mitchpond”, author: “Mitch Pond”) {

  capability "Battery"
  capability "Configuration"
    capability "Motion Sensor"
  capability "Sensor"
  capability "Temperature Measurement"
  capability "Refresh"
  capability "Lock Codes"
  capability "Tamper Alert"
  capability "Tone"
  capability "button"
    capability "polling"
    capability "Contact Sensor"
  attribute "armMode", "String"
    attribute "lastUpdate", "String"
  command "setDisarmed"
  command "setArmedAway"
  command "setArmedStay"
  command "setArmedNight"
  command "setExitDelay", ['number']
  command "setEntryDelay", ['number']
  command "testCmd"
  command "sendInvalidKeycodeResponse"
  command "acknowledgeArmRequest"
  fingerprint endpointId: "01", profileId: "0104", deviceId: "0401", inClusters: "0000,0001,0003,0020,0402,0500,0B05", outClusters: "0019,0501", manufacturer: "CentraLite", model: "3400", deviceJoinName: "Xfinity 3400-X Keypad"
  fingerprint endpointId: "01", profileId: "0104", deviceId: "0401", inClusters: "0000,0001,0003,0020,0402,0500,0501,0B05,FC04", outClusters: "0019,0501", manufacturer: "CentraLite", model: "3405-L", deviceJoinName: "Iris 3405-L Keypad"


(Bob Kerr) #15

I actually have one too, but didn’t get a chance to play with it yet. That and an Aeon Labs HEM are the two that don’t work currently, out of 100+ devices. If anyone figures these out, please share.

(Jimmy) #16

You could probably use switch-power-engergu for the HEM. The switch wouldn’t do anything, but at least you would have the power readings.

(Jimmy) #17

Is the button capability the main one with the iris keypad? If so try generic-button. It won’t bring all the capabilities, it would at least bring the main one.

(Arn B) #18

Switch likely the best of many poor choices for this device.

(Jimmy) #19

It doesn’t have capability switch

(Arn B) #20

Sigh, you are correct on that. Perhaps “generic-motion”, since that will also give the device’s temp and battery.