New app simple automation not completing reliably

Here’s my simple automation;

The problem comes when turning the lights off. They just remain on all the time. When I used the smart lighting smartapp in the classic app it works fine…?

Same Smart Lighting app exists in the new app…

I realise this, but was trying the new rules based system from the new app. Wondered if anyone had a similar experience when using it, or if there was a known reason why it’s not working.

I’ve never used the V3 app so I can only offer questions, not answers.

My first question would be, what does the ‘turn off after 3 minutes’ actually mean?

If you get rid of the illuminance condition, how does the automation behave? Does it turn off after three minutes regardless of whether motion is still detected? Or does it only turn off if you keep moving for three minutes? Or something else?

The reason for the questions is that the illuminance condition is likely to be false after you turn the light on.


I hadn’t considered that, so will test without the illuminance condition. I let you know the outcome.

Thanks :blush:

Just to update, it was the illuminance setting casing the issue. This kind of renders this use case unviable with this rule engine as it stands. \switched back to webcore for now.

Did you also try the Smart Lighting app? You said that worked for you with the Classic app, but I don’t see where you tried it with the new app.

I did have it working better with the smart lighting app, but WebCoRE does it better.

In the new app I just created a new automation using the IFTTT style creator.