Netvox ZigBee devices compatibility

Hi all,
I have just joined the community. Hope to learn from you all!.
I live in Spain and I have received today my brand new smartthings start kit from UK (hub2). Everything seems to work fine. I also have some Zigbee devices (door and motion sensors) from Netvox and thought they would pair with the hub… but they don´t… In fact the hub does not even detect them. I have tried to pair them manually but netvox is not in the list of third party devices. Does anybody know if there is any reason why a Zigbee certified device cannot pair with the smartthings hub or if I am missing something?
Thank you for your help!

ZigBee protocol allows manufacturers to put their own proprietary code so it can only be used with their own hubs. Your best bet is to search through the device or UK specific threads and see if somebody has had any luck getting a device handler for those specific devices.

1 Like

Might not be the right profile. See the following (this is a clickable link):

Thank you very much JD. Very interesting indeed!
I was not aware of such “profile issues” with ZigBee, in fact I chose smartthings hub because of its apparently wide compatibility (I am not an expert and just wanted to start playing with these things). In fact the two devices I am trying to pair claim to be based on ZigBee HA. I suppose that is a good starting point as it looks that they could be using some kind of ZHA 1.2 “dialect”, right?. Devices are both from Netvox (door sensor Z302A and motion sensor ZB01A). Dou you happen to know if any integration or device handler exist for them?

Here it is the catalogue with the ful tech specs:

So the good news is that the Netvox sensors are supposed to be using the same profile as SmartThings, ZHA.

So now there are two things to try.

First, make sure that you have reset the sensors to factory specifications so that they are not still looking for the netvox Coordinator. There should be reset instructions in the user manual for each device.

Then, just do add the new device in the SmartThings mobile app. The devices may just add as a “thing” in which case you would need to go into the IDE and try them with one of the generic zigbee devices with a similar function.

If they aren’t showing up as a “thing” after you try to add them, then I’m not sure what’s going on.

Thank you again. I tried from the app. Now i will try from IDE and also will try to find out how to set factory default…

I’m sorry, I am very tired today and I’m not going to be able to help you with the steps for this. Hopefully someone else will. But the steps are going to be:

One) factory reset the sensor using in the instructions in that sensor’s manual

  1. use the SmartThings mobile app to add a new thing. The sensor should add just as a generic “thing”

Three) after it has added as a thing and you can see it in the things list in the mobile app, then go into the IDE and change the device type handler to one of the zigbee devices with a similar function

4). Then go back into the mobile app and see if it is working

Good luck!

Thank you. You have already helped me a lot. I got the “thing” in the app!!. I will go to IDE.

1 Like

Hi JD,
Just to let you know that I got my Netvox things integrated!!!. It took sometime to find out how to factory reset the devices but once I did it they were recognized as “things”. Later on at IDE I linked them to a generic motion sensor and an open/close sensor profiles and bingo! I can detect those events. It is a very basic profile (although they are also very basic devices) so probably low battery indication will be missed when it happens… Now the next challenge will be to integrate a very basic IP Cam (Ipux/Fitvision CS303C) (no zigbee nor zwave). I have factory reseted it but it is not recognize by the app… I am afraid I will have to play a little bit with it… Anyway it has very basic capabilities… Thanks again for your help!!