Need help with GE 26933 motion dimmer switch changing occupancy to vacancy


#1

I have a 26933 and wanted to switch from occupancy to vacancy at night. I installed DTH 1.0.3 but it doesn’t seem to be working right. It seems to mess up the light. I manually just switched it to occupancy. When I switched back to vacancy, light didn’t act right. Would only turn on light if my hand was about an inch away. Also, the app takes a very long time to reflect the changes. It still showed Mode: Vacancy. It eventually went back to “normal” response.

I then tried setting it to manual and use the Smart Lighting SmartApp to turn on light when motion was detected (so I could set a restriction to not do this at night). It doesn’t work at all. “Recently” will only very occasionally show motion detected.

All I want to do is to switch from occupancy to vacancy at night so dogs won’t turn on lights all night. Seems like this should be a simple thing to do.

SmartThings is not acting very smart. Very frustrating. Any help would be appreciated.

Thanks.


(Alex) #2

The GE motion switch and dimmers I have all work quite well. In a few cases there were issues that became apparent right after including them on my mesh network which were resolved by excluding them, resetting them and including them back. I chalked it up to occasional ST or device weirdness :wink: but they were more likely due to poor zwave network conditions (too much traffic, interference, or a poor route to the hub). You might have the same issue especially if it appears to take a long time to switch modes when you press the Node tile within the DTH. I wonder if the hub has to try more than once to send the command. Mine takes about 3 seconds to update (busy network).

In your case I would suggest excluding, doing a reset and trying to include the device back. Make sure there are solid repeaters close by if the device is far from the hub.

Either way, to do what you want to do I use webCore:

The bathroom where I do this is just outside my kids’ bedroom so at night I don’t want the light turning on automatically. During the day, I do. In the define section I use some global variables to define when I want this to happen as their bed time does not coincide with anything else. I use those same variables in other pistons too.


#3

So, do you think it _should_work with Smart Lighting app with switch set to manual? I don’t know how to use Webcore. Thanks


#4

And when you say repeaters, do you mean wifi repeaters or Z-wave repeaters? Thanks.


(Alex) #5

@Chele - Zwave and Zigbee are “mesh networks” which means they relay messages (on their own specific network) up to a certain number of hops. If your devices are too far from the hub the signal may not be able to reach reliably so you need to ensure you have wired devices in between that will act as repeaters. How many repeaters and how far apart will largely depend on the building type… wood/drywall versus brick and or metal. If moving the hub closer for test purposes is not possible, then you could get a Zwave Plus plug in device and plug it in to an outlet half way between the hub and the motion switch. A network repair or excluding the motion switch and including it again should hopefully cause the motion switch to adopt this repeater as the best path to the hub making the communication more reliable.

I do not believe SmartLighting supports changing modes however I believe you can use the motion sensor to turn on the light but the response time will be much slower than having the device do that. I use the motion sensor to trigger other things in the rooms I have these motion dimmers/switches, and I also have other devices assisting with turning on the light. As an example, I have a motion switch in my garage that turns on the light way too late when I arrive home. SmartLighting is set to turn on the light when the garage door opens so by the time I am driving in, the light is already on.

There are a lot of people that will be glad to help you on the webcore forums if you want to start using it. It offers so much more power! The piston I posted above can be imported and modified very easily for your purpose. Enter time instead of my global time variables, and enter the actual devices. You can also change it to use your day/night location modes instead of time if you prefer, or even sunset/sunrise.


(Micheal ) #6

I recommend moving this issue to the proper forum thread:

However, to comment on @Chele comment, what you are seeing is not normal, but is more about SmartThings than the DTH. As mentioned about, you have to have a very strong network (mesh) to get all of the required commands to the switch. And if you have multiple things going on in your house at the same time (like on a schedule) it could be a situation where the commands don’t all get to the switch.

Hope that helps.


#7

So any type of z-waves plug will act as a repeater? I don’t have to buy a dedicated z-wave repeater/extender? I assume a z-waves light bulb does not act like a repeater, only a plug in switch?

Thanks.


(Alex) #8

A Zwave light bulb should act as a repeater however it may be worth checking if it supports that feature and/or if it does it well (I read about some zigbee bulbs not behaving properly or not acting as repeaters). The issue with bulbs is that they can be used as regular bulbs behind a switch. If you cut power to a zwave bulb it cannot repeat zwave messages (no power!) so I would pick some other device. Easy to install devices that can serve this purpose are plug in Zwave plus outlets. If you are ok with hardwiring, then you can install in-wall zwave plus outlets or in-wall zwave plus dimmers/switches.


#9

Thank you.


#10

You might want to take a look at the FAQ section of the forum. I think you’ll find a lot of your questions are answered there. :sunglasses:

https://community.smartthings.com/c/wiki/faq

In particular, the following two FAQs should help. (These are clickable links)

Start with post 11 in the following thread, then go up to the top and read the whole FAQ:

And specifically on lightbulbs as repeaters: