Need help turning off lock notifications

I could use some help turning off the notifications every time my Schlage connect is unlocked with the keypad. I have looked everywhere in ST app and can’t figure out why this is happening. The only app I have installed for the locks is RBoy Lock User Management, and within this app, under Manage Users, “notify on use” is deselected. This started happening after installing Lock User Management. What am I missing?

Classic or STSC app?

1 Like

Since you paid for the license, Rboy apps has their own support who should be able to help you.


If you’re using new app Smart Lock Guest Access there isn’t much you can do besides turn off notification for that device from the notifications menu in settings.

I am using the classic app.

If you have disabled notifications in the @rboy app, you may want to check if you have installed any custom alerts in Smart Home Monitor. Also check to see if you installed any smart apps such as Notify Me When.

I contacted RBoy for support and they are saying it’s not related to their app.

I checked Home Monitor and confirmed that I do not have any Custom alerts related to the lock. I do not have any Smart Apps installed other than Lock User Management and Alexa.

Thanks everyone for the help.

You can verify the source by checking in a few places. If the notification is coming from the SmartApp it will show up in the “Notifications” tab.

If the notification is coming from SmartLocks, it won’t show up in the Notifications tab in the Classic App but will show up on the new App History/Notifications tab and there’s no way to disable it other than uninstalling SmartLocks.

I don’t ever recall Classic Smart Locks pushing me notifications. Smart Lock Guest Access in the new app does, and it pushed through both apps.

1 Like

I am new to ST so not very knowledgeable at all. But from playing around with it it looks like that is part of the built in smart home monitor. The notifications could be coming from the ST app based on your setting up the monitor. Go into monitor settings and see if you can turn off notifications. Hope this helps.