SmartThings Community

My Somfy-SmartThings Integration

somfy
project_shades
(Dawn Fairbro) #21

Ash,

Please keep me posted. My Somfy cell shades (Bali) arrive on the 28th of this month. :slight_smile:

0 Likes

(Ash Raj) #22

I have the same shades you do. The fact that your MY level is halfway/50% and I said to dim your shades to 50% is purely coincidence. The dim level set by the routine doesn’t correspond to the actual shade level — it just sends an UP, DOWN, or MY command.

Since SmartThings routines do not officially support the MY button, I implemented this functionality in my device type using the dim level control. (And if you followed @Mbhforum’s instructions, you’re already using my device type.) So what I’m saying is, if you tell your routine to set dimmers to 50%, it will press the MY button. It’s that easy!

After seeing that this does indeed work, you should probably update to my new device type, because I just fixed a major bug.

0 Likes

(Keith) #23

I think that makes sense, I will try it out tonight. Thanks for the explanation and updating the device type!

0 Likes

(Eli Luria) #24

I loaded your latest Somfy device type. I am trying to get the shade to go to the My position. The controller is running the standard Z-wave controller app. I set up a routine with dim level at 50%. I tried the routine with open, then with close. In both cases the shade went fully open or closed, respectively. It appears to be ignoring the dim level.
What am I doing wrong?
Thanks so much.

0 Likes

(sbe) #25

Hi Ash,

I’m using your device type.
From the Things screen, MY command stops movement, and also goes to preset - like it should.
However, from a routine, if set to 50% like you said - it does stop movement, but from stopped it doesn’t go to preset - it moves for a second and stops again.
Do you know what I’m doing wrong?

Thanks,
sbe

0 Likes

(Ash Raj) #26

SBE,

I think the problem is that a routine can’t send just a DIM command. First it sends an ON command, which raises the shade, then it sends a DIM command. Since the shade is being raised, the DIM command is interpreted as “STOP” instead of “go to MY preset.” The workaround for this problem is to fully raise the shade with another routine before running the dim routine. If the shade is already raised, the ON command will be ignored by the shade, and the DIM command will be interpreted as “go to MY preset.”

If SmartThings allows routines to send DIM commands without ON commands, this workaround won’t be necessary.

Hope that helps!
Ash

(Btw, if anyone knows how I can change the logic of my device type to prevent this problem, let me know!)

0 Likes

(sbe) #27

Thanks Ash - the workaround works, but it’s not really a solution.

I’ve used routines so that I can control the shutters from my Minimote and have one less remote on my coffee table.

Is there a way to properly send MY command from Minimote?
Is there a better remote that can do that, such as Remotec Z-URC550 or ZRC-100?

0 Likes

(Ash Raj) #28

As far as I know, there are not separate MY and STOP commands. The same RTS command is interpreted as MY or STOP by the shade itself. This is a Somfy limitation, so it doesn’t matter which remote you use. Even Somfy’s own remotes have this limitation.

That said, there is a way to change my device type so that your routine works. You can modify the code to send the STOP/MY command twice when the shades are dimmed:

On lines 112 and 102 change

zwave.switchMultilevelV1.switchMultilevelStopLevelChange().format()

to

delayBetween([ zwave.switchMultilevelV1.switchMultilevelStopLevelChange().format(), zwave.switchMultilevelV1.switchMultilevelStopLevelChange().format() ], 500)

When the routine is run, the shades will rise, then stop, and then go to the preset MY level. I know this still isn’t an ideal solution, but hopefully it addresses your issue for now.

0 Likes

(sbe) #29

Thank you.

What this does is:
From down: a little up, stop, then more up until preset.
From up: a little down, stop, a little up back to up.

So I guess this gives me access to go to preset in some way.

What I meant about the Remotec remotes, is maybe they can access the dim command directly and not though a routine?

0 Likes

(Ash Raj) #30

Yeah… this workaround it a bit wonky :disappointed:.

Maybe, but I don’t know for sure because I’ve never used that particular remote.

I posted this issue on the developer forum. Hopefully a smarter developer than I can suggest a real solution.

0 Likes

(Raj Balwani) #31

Hey everyone! I just got my Bali Rollers for my huge bi-fold door! Works awesome! however im already itching to get it configured with SmartThings. Am I correct in understanding I will need Z-Wave to Radio Technology Somfy Interface (ZRTSI)? Also is this thing really $300?!?!? Anybody know where to get this cheapest?

Is there anyway to use Somfy MyLink with SmartThings or is only option to use ZRTSI?

Thank you oh great experts in the SmartThings community!

0 Likes

(Rick henry) #32

could you provide details on how to “associated to a virtual node channel.”? Thanks

0 Likes

(Marc) #33

The MyLink hub does not use zWave and is Cloud to Cloud.

If you want to do zWave, you can try and order it through Lowe’s for $95 by calling the store and giving the part #. There is another thread on how to do that by searching the forum.

0 Likes

(Marc) #34

Check out the top of the thread:

  1. Plug in the zWave RTSII Module into an outlet and follow the instructions to program your zWave Controller and blinds to your Smartthings controller (Manual53). For the channels (Virtual Node), in the ST app, you do Connect New Device, and then on the zWave RTS Controller, you add your virtual nodes. I had 5 virtual nodes, 4 blinds plus the "All Blinds: channel, They correspond to how my Telis remote is programmed. In my case, I now have 6 “things” show up (5 Blinds Channels and the controller). Below is the All Blinds channel:
1 Like

(Dawn Fairbro) #35

@Mbhforum you are so awesome to help the way you do::fireworks:. @Fehenry with help from mbhforum I was able to get my Somfy blinds working with smartthings (V2) and even have echo controlling them now… and still working perfectly :smile:

3 Likes

(Raj Balwani) #36

Thanks for confirmation @dfairbro1 that this will work with ST v.2
I ordered my RTSII module from Lowes yesterday $95 with a 10% coupon. When it comes in I should be good to go! Now hoping there is an Echo under the tree so I dont have to order one :wink:

1 Like

(Rick henry) #37

Thanks, I think I’m almost there in that I have set up with the Z wave controller in Smartthings and added virtual nodes in the Z wave controller and then added those to Smartthings but I get no response when pressing the small things control. It sees them as a dimmer. Smartthings originally interpreted the virtual note is a dimmer which was set up at the factory for channel five. Any suggestions are appreciated. Thanks

0 Likes

(Eric) #38

The issue is extra calls to setlevel with a null value. I have sent a pull request for Ash that fixes this, and add multi-tile support. It also tracks open, close or my/stop as status

https://github.com/imnotbob/SmartThings-1/blob/Develop/somfy_shades.groovy

1 Like

(Ash Raj) #39

Thank you so much Eric! I’m still a novice programmer, so I’ve been hoping someone like you would come along. I just added you as a collaborator so you don’t have to wait for me to make changes in the future.

0 Likes

(Eric) #40

Updated device type to add new Window Shade capability

0 Likes