My devices don't show online?

When I login here:

It doesn’t even show my hub? My hub is in the IOS app but not on this website. I am pretty sure I logged in someplace that actually did have my devices but I don’t recall the URL. What is the link I posted above and what is the real management link?

Are you US or UK?

If UK you need to go here:

If in the US you could also be on this shard

Information about shards can be found here:

Why is there a difference? Its is very odd and confusing?

Your link (in the U.S.) worked!

Different accounts are assigned to different shards. You can think of them as different database servers. Two different reasons. First is geographical region, they need to separate EU/U.K accounts from US accounts for some legal reasons. The second reason just has to do with processing speed. When they had too many accounts on one side, there were a lot of logjams. Things got a lot better when they added the second one.

All of this is really common with big companies. Most of them use multiple shards.

What’s unusual about SmartThings is that it will allow you to sign into the wrong Shard. Most companies automatically transfer you behind the scenes to the one your account is associated with.

My guess is it works this way because SmartThings didn’t realize they were going to have the problems and they added the second shard in a kind of emergency situation when a lot of things were broken and they just never redid the sign in process.

Maybe one day they will finish it :slight_smile:

1 Like

I tried this link, as well as the UK one just to see, (i’m in US) and I still don’t see my hub or my device. Like the op they’re both on my app, just not on the web. Any other solutions?

I believe the normal link now works for everyone. You should no longer need to log directly into your shard. As a note, I believe they’ve added a 3rd and/or 4th US shard.

If that still doesn’t work you can follow the directions below.

I’m not sure what happened, but after checking and rechecking and then rechecking some more, it all finally popped up.

It definite does not work correctly. I just checked (since I have test accounts for ActionTiles on multiple shards).

My FAQ has over 3400 views. Perhaps I should have used it as a promotion channel for my product. :confounded:

1 Like

Ah you are correct. The new universal login is

That should work for all shards.

1 Like

Hey… you’re right! :open_mouth:


  • That’s damn hard to spell … WTF - They couldn’t come up with a simple domain name alias?!?

  • It ain’t LastPass auto-fill compatible (for some reason; graph-api is, even through it redirects through the above at some point…).

Thanks! This worked!