Multipurpose sensors range

Thanks, I did actually reboot it several times, and the batteries are all new (though they are not of a known brand).
Is there any way to check what signal the base is getting from the sensors, before spending even more money on repeaters?

Check the device list in the ide… the closer to 0 the better

2 Likes

Thanks, that is really useful, I am completely new to ST.
Having checked it, the sensor I am working on now shows a Last Hop RSSI of -77 and it’s sitting literally next to it (20 cm away). Any explanation?

The battery is brand new, it’s Lithium battery and it’s showing as 100%, but it’s not of a known brand (bought from Amazon)

Make sure your hub is at least 2 meters away from any WiFi access points or usb cables.

Can you try moving the hub as an experiment? Is the antenna blocked by other things? Is it close to a WiFi router?

I had a chuckle at “internal walls can be bent by blowing at them” :slight_smile:

Yes, Physics… which is why it doesn’t make sense to most of us and that is ok. In the example i posted there are 3 physically closer zigbee repeating devices it should be connected to, but due to a bunch of stuff i cant see and too time consuming to measure like interference from my neighbors or even my wifi or Bluetooth the Guest AV is the best device to connect to and its on the complete opposite end of my house 2 rooms away.

There are so many things that can cause interference in a zigbee network it can be really difficult to figure it out even when there are vast differences in signal and only 20cm distance. Below are some articles that have helped many with your situation find some solution. You may even find out that you have so much interference on the 2.4gz bands that zigbee is not a good fit for your home and zwave may work better due to less interference in your home in the 800mhz bands.

1 Like

It is. I also tried moving it to a different room.

I tried everything I could. I even opened it in case the antenna was damaged (I bought it used on eBay), but it looked fine to me. Do the sensors have any ‘preference’ on what batteries are used?

Yes agreed, but physics doesn’t explain why my Philips Hue light bulbs and Hue motion sensors, which if I’m not wrong use the same frequency, have absolutely no problem at all. Not to mention the normal WiFi.

I understand that there could be interference and all that, but I find it really really hard to believe that the SmartThings sensors are the only thing affected, while everything else, using radio waves in the same frequency and in the same place, are working absolutely full speed.

I am sure there is an explanation, other than interference, why none of the sensors are able to communicate with the hub if they’re behind a wall.

Are you mounting on or behind metal doors (or other material that could block signal)?

I don’t believe the battery makes any difference, as long as it’s the right voltage. You can always test it with a multimeter.

I’m not sure how accurate is the RSSI number reported by the IDE. I have a button and never had any issue with it. I walked over to the hub, activated it, and checked the device. It reported -68, which seemed kind of low. Then I walked over to the garage (at least 2 walls between that and the hub), pressed the button again (and verified that it triggered the light it was controlling) and noticed that the RSSI is still -68.

I have a multi-purpose sensor arriving today, I’ll keep you posted on my experience. I have no Zigbee repeaters in my network. On Zigbee, I have only the button and a smart lock.

Same frequency, but not necessarily the same channel. You can verify that by checking which Zigbee channels they are using if you want. But my guess would be that it’s a defective device. “Used on eBay“ is not typically a good source for these devices. just sayin’…

Yes, for two reasons.

  1. battery shape. Different batteries are shaped slightly differently and some don’t sit tightly in the slot. But in that case, they don’t make a connection which is not the problem that you are seeing.

  2. don’t use rechargeable’s. There are several discussions about this in the forum already, and I’m quite tired today, so I won’t go into the details. But As long as they are standard batteries, not rechargeable’s, and you were able to get the device paired, it’s likely not the batteries.

No, tried on a table, on the wall, in the middle of the room, changed room, no difference, as soon as the sensors leave the room, the signal goes and they show offline.

Thanks, that would be useful to know. As I said, I have plenty of other wireless devices (Hue lights, Hue motion sensors, WiFi door sensors) and they all work just fine.

Would that be possible on both Hue and ST?

Yes, you can check the channel both are on (for ST in IDE, for Hue in the app), but you can only change the Hue channel. In the Hue app, go to settings, select your bridge, then click the information “i” icon. There you will see the zigbee channel and can change it. For ST, login to IDE at https://account.smartthings.com then select Locations, select your hub, and then look at the zigbee section to see the channel. I have my Hue bridge set to channel 11 because my ST came on channel 20.

1 Like

Thanks, I just checked and I have ST devices using channel 20 and Hue on channel 25.

And what channels, if any, do you have your 2.4 WiFi on?

WiFi is on channel 11, but I also tried to switch off the access point completely.