Motion sensor and light switch

I have a SmartThings motion sensor and Honeywell dimmer switch. I have it set to detect motion from 7pm to 6am and turn on the kitchen light and so far that works. I have it set to turn off if no motion is detected but if we are in the kitchen and stop moving (example Waiting for a baby bottle to warm ), it won’t turn back on for several minutes even with moving again.

How can I set it to always detect motion as long as you are in the room. I feel like I’m just not setting the automation correctly.

Any help please

Check your sensor activity history. Did it register the movement? If not that could explain it and you may need to look into your mesh stability.

I checked the history and during the same minute it would detect motion and detect no motion.

The way I have it set up is, one automation detects motion to turn it on and the another automation detects no motion for 2 minutes to turn off.

Do you think it could be a WiFi issue because I am running it on a mobile WiFi router/mobile hotspot? I just moved here a few weeks ago and haven’t had home internet hooked up yet.

If it eventually turns back on then it may be a mesh issue causing the packets to get delayed (rare to be delayed by minutes but has been known to happen). You would need to deep dive into the events/logs to trace it out.

Sorry for hijacking but how did you see it was a mesh issue and how did you resolve it?

I have the exact same issue with extreme delays 5-10 miuntes and zwave repair don’t find any issues and I’m so out of ideas…
Checking the affected devices in the IDE show’s the route is direct to the hub but that is perhaps not the way to use that info…

Kinda of hard with having the proper tools, but indicates one of a couple of things:

  1. Slow internet latency (but it can’t be that slow, it usually in seconds)
  2. Slow platform, this affects timers, typically if a timed actions executes after a few minute it could be the platform running slow
  3. If it’s a command executing after a few minutes, it’s likely a mesh issue + maybe slow platform
    • The best way to test this is to use a local running device (you can verify if the device is running locally in the cloud from the IDE under My Devices) and execute a simple command like turn on/off the switch.

Couple of things you can do:

  1. Reboot the hub and internet router
  2. Exclude and re pair the device closer to your hub, check the routing in the IDE -> My Devices -> Click on the device -> See the routing details
    • Here also, if one or a select few devices are running slow, check the routing table in the IDE for those devices and identify if they are running through a common repeater. If so that repeater may be the culprit. Some older GE switches (non zwave plus) tend to create such issues over time in our experience. Replacing them with newer zwave plus devices or resetting and re-pairing those repeaters often helps.

Thanks for the reply!
Sorry for the delay in responding…

  1. Shouldn’t be slow internet , got 110Mbps up and down with 3ms response
  2. Platform however is likely but not much I can do about it right?
  3. Devices affected (some but not all Fibaro Double Switch 2 ZW5) are all cloud but not meshed, they’re going straight to the hub.
    If it had been all the Fibaro Switch 2’s acting up I could understand it but some work and some dont…
    The only Fibaro that works perfectly is the Fibaro Dimmer which executes locally…

Thanks for all the suggestions!
I’ll start to re-pair a few to see if it makes any difference.
rebooting doesn’t seem to have any effect unfortunately.