Motion on, then won’t turn off issue in smart lighting

I have Zwave switches with one connected to my backyard spotlight and a Arlo Camera I’m using as a motion sensor to turn said spot light on overnight. I have the time I want this to happen between sunset + 20 minutes to sunrise - 30 min. I have set this to do this when this switch is set to off. I have set them to go off after motion stops after 5 minutes. So, the lights come on with motion the. they do not turn off as instructed to do. Do I have to create a Separate routine to have the lights go off? The idea is that I want them to come on if someone enters my back yard and then turn off after motion stops. So either in the middle of the night or when I’m away, I don’t have to worry about the spotlights staying on and bothering the neighbors. This can’t be the first time this topic has been discussed. Please point me in the right direction. Haha. Thanks!

This should work relatively simple in SmartLighting. Check you motion event history for the Arlo to see if it is actually sending motion on/off events. Also, post a screenshot of your rule.

1 Like

Thank you for the reply. I will try and check the motion events like you stated. This is how I have it set up. I feel like it used to work and then it stopped working. But is been a while.

A picture is worth a thousand words!

Wish it was that easy. It does not matter what I put there for minutes. It still doesn’t work.

I use webCoRE for most of my automations. It’s super simple and just works.

It’s uses an If This Than That approach with the ability to really dig deep and be as creative as you like.

If motion changes to active
Then with light turn on

If motions stays inactive for 5 minutes
Then with light turn off

It’s as simple as that.

So, just a guess. I wonder if the “Only if Switch Spotlight is Off” setting is interfering with the “Turn off when motion stops”? (So it goes to turn off, but the spotlight being on blocks it?). I’d turn off the “Only if Spotlight is Off” setting, which is unnecessary (it doesn’t matter if it sends an on when light is already on) and see if that helps.

This works fine for me…


If my light is already on, the automation doesn’t run so I can turn on the light manually and it will not shut off on me. If the light is off, it turns on with motion and off after 5 mins of no motion. If it’s not working for you, submit a ticket to get someone to look into it. I have had no issues with this automation for months since I set it up.

I can try this again. When I didn’t have “only when the switch is off” set. If I manually turned on the spot light and went outside, my camera would detect motion and then turn the light off on me.

I believe this is how I have it set up. I think my Arlo camera doesn’t play nice with the reporting the motion stop or something?

Also, I would think it is set to only when the switch is off, it will then turn the switch on when the camera detects motion and then have the ability to turn the switch off after motion stops. In a perfect world.

So, I turned off the option of “only when the spot light switch is off” and the light turned off after motion stopped. From what I remember though, before when I didn’t use the only when switch is off setting, that if I manually turned on the spot light and went out back, the light would turn off on me leaving me out in the dark. The camera caught the motion and the timer started. So how do you fix that issue??

You set the “After this number of minutes” to whatever works with you - I do 3 minutes but YMMV depending on how long you hang out in back yard without moving. It takes a while to figure out what works best for you. Good luck!