Mode not changing


(Dtm) #1

I have a routine set to run every weekday morning at 7am, the activity feed confirms it runs, but part of the routine is to change the mode to “at work”. The mode never changes though, always remains as Home.

What’s wrong? How to fix?


(Ron S) #2

There is no fix but force kill and open your app. Report it to support. Reported it months back across releases with no fix.


(Dtm) #3

Where does the issue lie do you know? Any workarounds? I just want to set a mode change at a specific time on certain days…


(jkp) #4

Any Arlo cams.


(Ron S) #5

I have no Arlo cams. It’s the app which is hosed. The actual mode change happens and your routines should still trigger, IDE will show correct state but your mobile app will show wrong stale state. Force kill the app and reopen to see the right state.

This of course does not apply to the current presence related issues and mode/routine changes based on that. Presence is hosed and anything tied to it.


(Dtm) #6

Okay, so if I understand correctly, the mode was probably changing as it should, but wasn’t reflected in the app? I’m fairly certain I’d tried a force close and reopen and the mode stayed the same…


(Ron S) #7

But did your routine fire even though it showed incorrect stale state in the app?

PS: Ignore anything presence related stuff on IOS 11.

If these do not apply, open a support ticket for sure.


(Dtm) #8

Yes the routine fired, but no mode change reflected.

Does this mode glitch only apply to mode changes via routines, or all mode changes regardless of trigger? I realized I could make a piston to run every day at the same time to accomplish the same as a routine granted this workaround generates the desired result?

Also, dumb question but how does one go about submitting a ticket for support, I thought I’d done so before, contacting them, but never hear back


(Ron S) #9


(Ron S) #10

I have not used the pistons. :slight_smile: These days I rely on mostly native apps like which comes with ecobee, hue, rachio, nest…


#11

If it is working but not reflected in the app, you could force close and re-open the app but a quicker way is to just click on the gear icon and then click “Done” to return back to the previous screen. It should update the mode status.

If your routine doesn’t seem to be changing your mode, then might want to create a virtual switch that will change your mode. Then use IFTTT to create an applet to “turn on” the virtual switch at a given time. This can be used as a work around back up procedure when your routine doesn’t run for some reason.