SmartThings Community

Migration to V2 - Hurdles and Best Practices

Trying to delete the location of my V1 hub, but not having any luck. I have two device types that are stuck in Limbo.

If I try to delete the device type I get the error:
“DeviceType still in use by devices”

If I go to devices I get:
“You don’t have any devices yet. Add one now.”

Smart Apps are gone as well:
“You don’t have any apps yet. Add one now.”

Trying to delete my location (doesn’t work through app either):
Error
500: Internal Server Error
URI
/location/list

I reached out to support yesterday, but have not heard back. Since I got my devices excluded does anyone think I would have any issues setting up the new hub, while I wait to hear back from support? Does anyone have any suggestions on removing those two device types in limbo so that I can delete the location?

2 Likes

Don’t feed the trolls

All my devices have unique labels (added through the IDE), for easier identification. Suppose I unpair the devices from the v1 hub and pair them to the v2 hub, will I lose the labels?

I wonder if that little wonder (the Iomega wifi powered from USB) would be good enough for those of us not planning on using the native video features… or even maybe for those who are… hmm… I really wish I could put my hub in places that don’t have hardwire.

JD how are you integrating Echo to Harmony?

I have a step-by-step report for the process I’m using under projects:

JD- Thank you, I will take a look,

@kmugh Yes, you will need to repair and rename everything. It’s a blast :wink:

Different things will work for different people. Choice is good. :sunglasses:

1 Like

[quote=“sychophobic, post:328, topic:20762”]
Trying to delete my location (doesn’t work through app either):Error500: Internal Server ErrorURI/location/list
[/quote]I too am getting this error while trying to delete my v1 home location to setup my v2 hub.

Great. Now that I have everything deleted in my house, SmartThings own instructions for migrating will not work.

I had problems removing my location as well; support took care of it for me.
To be fair, it’s part of the instructions, since it apparently was a known issue.

“Note: This action may fail for some users. For assistance with Location deletion or any other steps that give you trouble, email migrationhelp@smartthings.com.”

An extremely painful and time-consuming re-installation process (please stop calling it “migration”), not sure if I will buy v3 after all this :smile: (at least hope there is no v3 for another 2 years, not doing this again …)

  1. Adding ST sensors devices is fairly straightforward - especially since they are cleanly excluded from v1. Click button for 6 seconds and pairing is done. Only issue is manually picking up sensors from hard to reach places (ex. moisture sensors under the fridge, etc)
  2. Same holds for Zigbee devices (example GE link), the pairing process is relatively simple.
  3. Wifi devices are easiest to add, again since there is no exclusion/inclusion bullsh*t.
  4. Zwave devices are the absolute worst. Excluding them from v1 is not easy, and almost impossible. Need to put v2 in exclusion mode and try and try and try again … The AeonLabs minimote comes in handy for some devices here.
    a. Monoprice/Ecolink devices are easy to unpair/repair (the manuals have documented methods to reset/unpair/pair)
    b. GE switches are easy to exclude using Minimote and repair from ST v2 (Start exclusion on Minimote, and single click switch ON/OFF)
    c. Linear Switches can also be excluded with the Minimote, but you will need a double click.
  5. Still issues with: Nest Protects, First Alert ZCOMBO devices, Aeon/Monoprice Motion Sensors. Will update this post as I get more to work.

EDIT 1:

  1. Nest Protects DONE. Please see https://github.com/sidjohn1/SmartThings-NestProtect
  2. First Alert ZCOMBO DONE. Damn things take some tries to exclude. My SO was pissed off with all the beeps.
    Takeaways (1): Z Wave works so well once included. But the inclusion and exclusions are a big PITA. Aeon Minimote is a staple - can exclude devices in a snap.
1 Like

I managed to migrate everything except for my Linear GD00Z-4 Garage Door controller. Can’t pair it with the new hub. I ran the force exclusion function, but still can’t re-connect it.

Hahahaha, Yeah started and almost completed the migration process this weekend. I did my best to use the IDE for any steps instead of using the phone interface, which helped quicken the process, but man oh man. The migration was/is (like several people) are saying, a good solid weekend project.

1 Like

For anyone who will be going through this project, my advice to everyone who have a ton of devices:

Friday Night
Mental Prep

  • Grab a cold beer
  • Have a good TV show on
  • Take breaks
    Start the removal process of all devices and work until your brain melts
    Saturday
  • More cold beer
  • Take more breaks
    Start the pairing process and work until your brain melts again
    Sunday
  • Troubleshoot those pesky devices that hate being included and excluded. Melt brain.
    Monday
  • Message ST customer support for any device problems you had over the weekend.

seems we all start with the same first step

MORE BEER

1 Like

Question is what type of beer? That new root beer flavored alcoholic beer is really really good.

3 Likes

Uh oh. I have some mono price sensors and fire alert combos, that are next on my list of getting paired to my v2 hub :confused:
Hopefully I don’t have the same experience you do with that.

I tried that new hard root beer stuff a few weeks ago. Not a big fan, but not bad. Great concept though.

Just make sure to not drink too much beer or your troubleshooting skills will suffer. :smiley: Good luck to everyone.

I have two of these I migrated last night… here’s what I did. On the app with v2 hub, went to exclusion mode. Slide battery tray out on the First Alert, then hold the “Test” button down and slide battery tray back in, when FA beeps, release test button. FA will beep again in a few seconds - it should be removed now. Then “Add Device” and repeat the slide battery tray out then back in while holding the test button until the unit beeps. It should beep again a few seconds after you release the test button - and at the that point you should see it get recognized in the app.