Meross Garage Door Opener: ST Won't Add Device

I picked up a Meross garage door opener as it was highly rated and half the price of the Go Control device so I figured I’d give it a shot. I showed up on Saturday and I had it up and running that evening. Took about an hour to get it all set up. Pretty painless and simple. Nice little unit.

So then I looked for their SmartThings integration support and realized they don’t directly work (if at all) with the Classic ST app. Their integration goes through the the new app. We do a lot in WebCore so we’ve been pretty tied to the Classic app for the time being.

I found their FAQ on how to install it and gave it a shot. It sort of worked. There’s an Authorization step (1) where you log into your Meross account and after authorizing it’s supposed to go to Step 2, but it did nothing. I just manually clicked Next which put it on Step 2 which essentially says you’re done. The next part just connects ST to the device and, presto, the device was in ST’s new app. So we went over to Classic but there was nothing there.

My son then jumped into WebCore’s dashboard and notice there WAS a device from there there listed as Placeholder. He found a post here noting that this is how such devices are being handled for the time being (new app to old). For some reason he decided to delete the Placeholder device. Still not sure why. The device vanished from the new ST app.

Now, no matter what I try, I cannot get the device to show up again in the new ST app or as a placeholder in WC. I’ve tried removing it from the Meross app and re-adding it. Nothing.

Anyone have any idea how we can get it back, at least to the new ST app? Support swears that once it’s there it will sync with the Classic app. I have my doubts on that given that it didn’t the first time around.

At this point, go to the Things section and click on Add Device and it should show up at which point you will click Save.

Start over. Remove the device from IDE. Go to the new app, click on menu > settings > connected services and remove the meross integration. Then start over and add it again.

Do not change the device type in IDE, placeholder is normal for integrations from the new app.


Okay. Thanks. It wasn’t in Classic at all and wouldn’t add to Things, but after removing the Connected Service in the new app and repeating the process it ended up re-appearing in the new app.

Next I went over to the Classic app to Add a Thing and it doesn’t appear during the scan phase.

Add a Device Manually doesn’t seem like a valid option, but maybe it is.

Possible it may not show in the Classic app. Maybe someone who has the device can chime in…

I should also point out, you need to start looking toward using the new app. The Classic app is in the early stages of being phased out.

I was able to add it to Webcore under “Which Automatic Doors”, but it still won’t appear in Things.

However, I’m with you. We are looking to migrate to the new app. Apparently the big hurdle right now is that Smart Home Monitor isn’t fully connected (or something like that) except for using Automations.

I have so many pistons and not sure how those will all be dealt with. On the PLUS side, it appears we may no longer need the hack for adding a delay to SHM for things like entering a code after coming in. That will clean things up quite a bit.