Major Zwave Problems-Help!

I had tried to experiment with making my ST hub a secondary Zwave controller and to also make the other hub (Staples Connect) a secondary Zwave controller. I think that was the start of my problems!

I now can not get my ST to pair with any Zwave device. I have excluded them and ST sees the device to exclude it just fine but then does not see the same device when attempting to pair to it. I have noticed that my ST Hub is now defined as Zwave Node ID 2. I assume that the hub should actually be Node 1. I have tried Zwave Network repair and it fails with “Network repair for device [01]: Failed to update mesh info” and “Network repair for device [01]: Failed to update route” which is what makes me think that the hub being Node ID 2 is the problem.

Anyone with any experience or insight on this? Should the Hub be Node ID 1 or does that matter? If so, how do I get change the Hub Node ID?

I’ve thought about resetting my hub back to factory settings but obviously that would take a lot of time to “rebuild” all of my Zigbee, WiFi, SmartApps, Routines, etc. and I don’t know if it would even solve my Zwave issue.


It’s still secondary and as such it cannot add anything. I ran into that and the only way to fix it was to reset it by removing location in IDE then readd it and start all over again with all my devices.
If you really need 2 controllers, keep ST as primary.
This is what I have now

I could not find any way to edit Suc ID fron 2 (secondary controller) to 1 which is needed to make it primary.

1 Like

It might be worth getting in touch with support before you do anythong else if you are worried about having to start from scratch again.
They may be able to poke the settings for you.

You may try putting your primary controller (Stsple Connect) in exclude mode, then in SmartThings IDE, go to Z-Wave utilities and click “Join/Leave another Z-Wave network”.

The support policy on this has changed in the last few months. You can try, but They are now likely to tell the OP just to factory reset and start everything over from the beginning. From the official knowledgebase article:

SmartThings strongly discourages adding the Hub to another Z-Wave network. We cannot offer support for disconnected Z-Wave devices or the inability to add devices through the Hub as a result of including the Hub into another Z-Wave network.

This is a change from what they used to do, but unfortunately for some technical reasons SmartThings just doesn’t work very well either as a secondary or as the primary to another secondary. It meets the minimum requirements to be certified as a Z wave primary controller, but it doesn’t have some of the advanced features that systems which are designed for secondary controller management offer. Such as controller shift, which is what would change the SUCID.

I wish I had a better answer to give, but unfortunately there isn’t one. Once you’ve made it a secondary, you can’t get it back to primary without a full reset. :disappointed_relieved:

Can’t hurt to ask.

1 Like

Thanks for the responses. I did reset the ST hub (removed it from the Home location and then re-added it to the Home location). Zwave pairing seems to work well and the controller Zwave Node ID is 1.

1 Like