Magic Home and white channel led help needed

New to the community and just set up 4 rgbw controllers for different zones in my kitchen. The are the 5050 RGBWW led strip lights. I seem to have gotten everything working properly except the white channel. I can control fine through the magic home app, Google assistant and Alexa, but the only way I can turn on the warm white is by switching it on in the magic home app. Is there an easier way or command for Assitant or Alexa. Sorry for my ignorance, a friend told me I may have to do something in smart things to make it work. Any help would be greatly appreciated.

First things first:

what model smartthings hub are you using?

What country are you in?

Which version of the smartthings mobile app are you using, smartthings classic or “smartthings (Samsung connect)“?

1 Like

JD I have no hub yet. I am using my Samsung cell phone with Google assistant to command lights… I’m in the USA. I’m using the cheap little magic home pro wifi controllers you see all over Ebay. I have the smart things app on my phone but I’m embarrassed to say I’ve never even opened it.

These are the little controllers I’m using which seem to work fine but I didn’t know if there is a way to make Google assistant use the white channel which is the primary color i will be using.

1 Like

The white channel does work I can only cut it on in the Magic Home app though.

It appears that magic home has not added the color “white“ as one of their Google home options. It’s not in the list on their website.

You still might be able to do this with the free IFTTT service, you won’t need smartthings at all.

The next step, though, is to determine if you can use IFTTT with magic home to get the color you want. I’m just not sure if it works with IFTTT or not.

So to begin with, you’re just going to set up an applet where when you say a particular phrase to google assistant , the light turns to the color you want.

Use this for the IF:

And this for the that:

If that doesn’t work, you’ll need to contact the magic home support and see if they have another method.


Thanks so much for your help, I’ll give it a shot, they have a link in the app to the ifttt site you shared but it was foreign to me I’ll dig a little deeper and see if I can get and repost once I do. Thanks again! JD!

1 Like

Try telling Google to set the device to cool white or bright white and see what happens. It might be trying the control to color temperature instead of white level.

1 Like

I only have warm white LEDs, and when I give command for white, or warm white it doesn’t respond.

So you tried cool white and bright white and neither worked?

Create a “scene” in the MagicHome or MagicLight that sets the color white on the RGB strip. Call it “snow-white”. Then install the MagicHome skill into Alexa. Then you can tell Alexa to run the skill that turns on the lights to White, by telling it to run the scene. “Alexa run snow-white”, will turn on the light and make it white.