Lyasi Wifi wall switches (Sonoff plus Ewelink Cloud)

Hello Todd,
Now the wifi led comes on and off, matching the switch status. I would like to act as intended, to show status of wifi connection. I have been all through the tasmota code and cannot find how to get it to work. Let me know if you have a solution. Thanks in advance…


I can’t find any option to allow the LED to reflect the network status, the options are related to relay states and MQTT messages. I have mine set for the inverse of the power so that the switch has the led on in the dark making it easier to find. Haven’t swapped out the switches in the bedroom yet so we will see what the wife says about those.

Might be worth adding a pull request for Wifi status…

Did anybody have any luck with this? I tried it too. The Wifi LED flashs but the Button LED doesn’t do anything. What GPIO is the Button LED using? I looked at the circuit but I couldn’t follow the path all the way back to the microcontroller. Part of the signal for the Button LED comes off of the signal to the Relay which implies to me that, that is the power side of the LED which means the ground side of the LED is controlled by the microcontroller somewhere… For the sake of say it, I do not have this attached to 120VAC. I’m simply using the USB power. More info is better than not enough…

Anyone know if the OMOTION switch is based on Sonoff?

Andre- what is the part number for this other design? Curious on where to find it And how much $$. Thanks!

No idea, but it uses the same Tuya smartlife app that many cheap Chinese switches do, so at the very least you should be able to get some integration through their IFTTT channel. It’s not as good an integration as if it is based on Sonoff, but it’s another possibility.

1 Like

I purchased one and it looks to be similar design, but with a button instead of the touch sensor. DLX-KS602S.

Having read this thread and searching on the net I ran across this blog as well.

I bought the KS-602S (This model - and took some photos:

I superimposed the images to confirm that you can likely just ground the pad under the board to avoid the tweezers.

Since I’m limited on the photos I can upload I will add to the thread .

Slightly different KS-602

One last one, with super imposed with the bottom and top of the board.

I have reached my limit on posting links or upload I can’t share it properly. https://i.imgur . com/yP6N6sq.jpg

Did you flash anything onto that KS-602 with the push button? I picked one up as well as I think a tactile button is better than a touch button when it comes to usability. Do you know what the pin out is for the LEDs? I plan on flashing Tasmota onto it but wasn’t sure on the GPIOs.

Haven’t done any flashing yet. I will try to try this coming weekend.

I was able to flash the KS-602S (push-button version) with Tasmota. I haven’t verified the relay control yet, but LED works with standard Sonoff config. I was able to flash with the topboard - using the J1 pins and pushing the button down to put the device in flash mode.

I successfully flashed Tasmota as well. I have it configured as a Sonoff Touch. Everything works but there is a short delay from pushing the button and the relay reacting. Not sure if it’s because Sonoff Touch isn’t the right choice or if there is some other issue.

When you said you flashed it with Sonoff Touch, do you mean the Sonoff Touch firmware and run the custom DH for Sonoff Touch? Or controlling it via eWeLink from IFTTT? The later has a lag of around a second. If the first method is used, it should be instant. I have an original Sonoff Touch flashed with the custom firmware and using the custom DH. It works perfectly fine without delay.

I’m going to try a 3-gang wall switch running on Tuya SmartLife app to see if any of the custom Sonoff firmware and DH works.

Here’re the picture of the top control board in the switch.

UL is a must

1 Like

I flashed it with the Tasmota firmware. Then I selected it module as being a Sonoff Touch. I control it via MQTT in my own local node-red system. The delay is very minor, less than a second. I do not use the stock firmware or any stock apps. They delay is only when hitting the button, using MQTT it is immediate.

Does someone knows how to turn off the wifi led indicator once its setup and working. I cant sleep with those two bright blue lights in my face.

Thank you!

What settings did you use to flash it I’m having issues

Do you have full instruction on your method using MQTT?