Lost 4 of 6 Virtual Switches, or did I

I just purchased a new Amazon Echo. I created 6 virtual switches to help integrate Echo with my Hues bulbs. Last night I was in the app trying to pair an Aeon Labs Aeotec Z-Wave Multi-Sensor when I noticed that 4 of my Virtual Switches were no longer in the Things.I thought it must be a ST app issue so I went to the IDE. They were missing there too. I figured I must have screwed up somewhere and was ready to re-create them but decided to do some testing first.

I told Alexa to turn on some of the missing switches. She did, like they weren’t gone at all. So, I went to the Echo/Alexa app, clicked ‘Forget’ on all 4 switches that were missing in the ST App and had Alexa do a new Discovery. Behold, Alexa found all 4 missing Virtual Switches again and continued to control my lights even though they are missing from ST. Now that is what I call Virtual.

How can this happen? How do I get back my missing (or are they) switches?

Were the switches controlling Phillips hue bulbs? Do you your Phillips hub connected to both your echo and ST?

I have that set up and went through the same issue?

The Phillips integration I’d very good, with both echo and ST.

But even if ST doesn’t see the bulbs from Philippe, echo will.

Just like with all of the issues we’ve been having lately, my hue bulbs continue to work with echo with no problems.

May @jdroberts can be more insightful.

Now I have lost all of my Virtual Switches from both the mobile app and the IDE. I know they are still there as my Echo still has access to them.

  • Update -

I found my Virtual Switches listed as devices in the IDE under the HUB section. But they still are not showing in the regular Device section, thus can’t do any more programming with them in the mobile app. Also, under the devices in the HUB section of the IDE, the status shows REMOVED.

@bamarayne that is my setup. The Virtual devices are listed under the hub, but not under the Device list any longer. Although, they are still running my Lighting Automation and Mode changes when activated from Echo. But I need them back on the regular Device list (things) so I can continue to tweek them. And why are the statuses of these REMOVED?

That is interesting. I’m trying to remember what all was going on with mine. I believe my virtual switches were still visible, just that the ST app would not control the lights while echo was still controlling then. Have you tried deleting from both ST and echo and then rebuilding them?

@bamarayne No, I haven’t tried to delete/rebuild. I am afraid after the work the same thing might happen. That is why I am hoping someone can tell me what the heck is going on.

When I first created them, I made them On/Off buttons. I then changed them to Momentary Button Tiles. I am setting a mode when clicked and have a Smart App watch for mode changes and then changes the light colors. But as a On/Off button, many times the button would remain on when going to a different color. By changing to a Momentary Button Tile, the switch never stays in the on position.

I don’t know if it is that that caused the problem or not. I don’t think so. I went to the hub/devices and changed one back to On/Off Button and it had no effect. Still no visible in the My Device List.

I’ve done the same thing with my switches and haven’t run across this. I’m mobile right now and can’t t/s too much.

OK, I deleted all of my Virtual Devices that were displayed on the Hub/Devices list in the IDE. I uninstalled the Echo from ST and started over. Now, rather then using the ‘Alexa Helper’ app, I created a Virtual Device as a Momentary Button Tile and use it as a trigger in the ‘Lighting Automation’ app.

The 2 I have setup are currently on the Device List in the IDE and Things in the app. I will continue to add my other 4 VD’s and see what happens.

I’ve had a similar issue for several months (“semi-disappearing” virtual switches, but no Hue or Echo involved), and finally opened a support ticket on it last week. We had to manually re-add the virtual switches (on/off and momentary button), but once done, they “reconnected” to their previous state and the Removed status went away. All that remained was to re-add the buttons to their respective smartapps. One thing the support person noted though… when you add virtual switches via the IDE, they don’t, by default assign a Hub. He had me manually edit each one to assign my home hub, and said it would be helpful. I was skeptical, but so far, so good.

P.S. In my case, I had a screenshot of the Devices page from before I lost the virtual switches. So we were able to add them back using the same Device ID. I don’t know if the results will be different if a new ID is assigned.

Thanks for the response @Mr_Lucky. It is nice knowing I am not the only one.

I have recreated most of my switches and I did assign them to the hub. My original ones were also assigned to the hub. We will just have to see how things go I guess. Hopefully it won’t happen again.

That is a very good point. I didn’t even think if that. When I first started with ST I was having trouble getting my virtual devices set up. I got some advice from @jdroberts on how to do it. I’ve always assigned a hub when I create my virtual device.

That may be the trick that has to be done to prevent this.

Well, unfortunately I didn’t have a screen shot, so I had to assign them different numbers. But it is currently working.

1 Like