Linkind Door/Window Sensor Model: ZS1 10050078

Recently bought a pair of door/window sensors. It says it’s ZigBee 3.0 and you can pair it to Echo Plus. Figured I could pair it and change the DTH. (

I did get it to pair and it reports it as a “Thing”. I changed the DTH to SmartSense Open/Closed Sensor as that is what I’ve had to do with other door/window sensors. This time no luck with it generating feedback.

Under the device info it does report this info:

  • application: 25
  • endpointId: 01
  • manufacturer: lk
  • model: ZB-DoorSensor-D0003
  • zigbeeNodeType: SLEEPY_END_DEVICE

I just cannot get it to report open/closed at all. It remains on “Open” state.

Anyone have any suggestions on a DTH that I should be using?

What does the Raw Description show? It should be formatted like this:

Try one of these. If those don’t work, then a DTH needs to be built, which isn’t really too bad to do.

Raw Description 01 0104 0402 00 06 0000 0001 0003 0020 0500 0B05 01 0019

Just tried all these with no luck :frowning:
How does one go about updating a DTH to allow for this. How does the RAW description come into play?

Raw description tells what zigbee clusters are supported by the device (along with a few other things), and the important number in that string is “0500”. If you’re interested, more info about clusters and attributes can be found here: (start at page 8-3)

The DTH’s I provided the links for include that specific cluster, so those should have worked, but if your device isn’t using the correct Zigbee attribute ID spec, then I can see why the device won’t show open/close.

I know this may be more work for you, but you can try any of those DTH’s again but this time force a Configuration. That can be done via the Classic app by going into the device’s preferences (the little gear in the upper right hand corner) and then tap on Save. That should force a configure cycle, and you can see those events in the device’s event log and clicking on “all”, as well as live logging if the developed turned on debugging.

It may just be that the device didn’t get configured correctly. As soon as you force a config, use the device in some way, like open/close the sensor. Since those are sleepy devices, it may need this done for the device to wake up and receive the config commands.

If all that still doesn’t help, a DTH will have to be written.

Thanks! Got it to work!!!

1 Like

Sweet! Which handler worked? I’m in the market for a few new sensors and the price for those looked good.

I did multiple factory resets and pairs. Tweaked the inCluster on some of the DTH. Nothing was working.

The Factory Reset says to hold the button for 3 seconds. I held it this time for like 10 seconds. Paired it back to ST and it automatically showed up as SmartSense Open/Closed Sensor. Working perfectly now!

Thanks for everything. I’m going to read up on that RAW Description and the PDF you attached. Thank you very much!

ok now scratch my last comment.

When I said I tweaked some code, I added

fingerprint inClusters: “0000,0001,0003,0402,0500,0020,0B05,FC02”, outClusters: “0019”, manufacturer: “lk”, model: “ZB-DoorSensor-D0003”

to the SmartSense Open/Close DTH. Once I removed the sensor and added it back to SmartThings it registered my addition and BAM.

So far so good. If you purchase. Just modify the SmartSense DTH and add that line of code and your good to go.

1 Like

Glad to have helped out in any way and that you’ve got these working!

thanks for info on those. Just saw that Amazon has a package of two for $16.50. At that price is well worth the effort.

Just wanted to say that these are really good value devices. You get 2 for £20 on Amazon and they are very small and unobtrusive and work really well. You have to install them as a “thing” change the DH to SmartSense Open/Closed Sensor then reset the dvice and reinstall it and it works perfectly.

I just bought 2 of these for $20 yesterday. The DTH method works well. thank you @matthewsfamily0914 for your workaround. I was trying hard to create an EdgeDriver but I have failed so far. And found this thread. I am happy

@blitz79 - No problem :slight_smile: Glad it worked for you!