Linear Z-Wave Garage Door Controller Issues


(Rocky Cherry) #1

Hello everyone,

I’m hoping someone has had similar issues with their Linear GDC and has some ideas for me. I can’t get one of my controllers to enter “discoverable” mode. Both worked fine before, but then I had to remove them from ST due to resetting my ST hub. I successfully removed both using the buttons on the side of the GDC… press it 5 times and you get a short beep followed by a long beep. I then made sure they were removed from my device list in ST.

Upon re-adding them, the main one worked fine. I put it into “discoverable” mode by pressing the button once, which gives a short beep followed by 3 more short beeps, and then it was discovered by ST. However, the 2nd GDC won’t enter “discoverable” mode. When I press the button once, it beeps once and then gives another long beep, as if it is going into “remove device” mode.

Any ideas? Everything else on the GDC is working. I.e. I can press the button for 7 seconds to enter pairing mode with the tilt sensor and then it responds as expected to get the tilt sensor paired.

I can’t find any support for these controllers. The phone support costs $50, which is about what I can get a new one for on ebay! Online support is non-existent. I can’t find anything that explains what the different sequences of flashing lights mean while trying to enter “discoverable” mode. I can’t find anything about a true “factory reset” feature. I’m hoping someone here has encountered this before and has some advice for me.

Thanks,

Rocky


(Amauri Viguera) #2

Unfortunately that’s pretty much all the documentation you’re going to find about these devices… a single page PDF or image out there that tells you about the button presses.

Did you try running the device exclusion anyway? The reset should have done the trick, but you never know if that would help.


(Rocky Cherry) #3

Yea, device exclusion only works if you can get the controller into “discovery” mode, which really seems to be the issue. It’s looking more and more like I just have to buy another one and write this one off.


(Rocky Cherry) #4

I actually figured this out… I took the controller down and moved it into the other garage and powered it up and it properly went into “discoverable” mode. Then I put it back in the other garage and it continues to work. My theory is that the 2nd garage is too far from the SmartThings hub, so when you first press the “discoverable” button, it must be looking for a hub nearby, and the typical 3 beeps is confirmation there is a network near-by. The single long beep must be it saying it can’t find any hubs.

The weird part is why it discovered so easily the first time I installed it, but would not discover at all now, w/o being moved closer.

Oh well, happy ending either way. Maybe this’ll help someone else down the line.


(Amauri Viguera) #5

That’s pretty strange. I thought the garage door openers were also repeaters, which would mean the first one would have made things easier. Or perhaps that doesn’t work when in discovery mode.

Either way, glad you figured it out