Linear WD500Z-1 compatibility

I installed this dimmer and it worked great for about 3 days. Then it became out of sync and would report off in ST but would be physically on. If I hit it while it says"Off" it would turn the already on lights off and then say it was on. Each time toggled it would do the opposite and report the opposite… sometimes ST would hang on displaying turning on or turning off. However, the dimmer function would always work even if ST thought it was off.

I tried the ZWAVE repair utility in ST and get a “Network Repair for Dimmer [03]: Failed to update mesh info” and sometimes “Network Repair for Dimmer [03]: Failed to update route” if I keep trying.

The dimmer works great by itself without ST app just using the physical buttons. I only have 7 devices this being the only dimmer and the dimmer is only about 15 feet from the hub line of sight. I have removed it and added it back to the network but continue to have the same problems.

Any suggestions?

Hey Josh,
Have you ever figured out what was wrong? I have exactly same issue with my Linear dimmer.

Hey murzik,

After spending much time with this dimmer, in the end I just removed it from my network and use it as a dumb dimmer. After doing so, all my SmartThings devices started working better, having faster response and reported correct status. My feeling was that any device that connected through the Linear dimmer to get to the hub was having issues too.

I worked with SmartThings support a couple times and they were able to work their magic a few times but after a few days things got out of sync and stopped responding. I added a GE switch and have not have had any issues in a couple of months. My feelings are the Linear just was problematic and cause the whole mesh to be unstable. Could have been just this particular dimmer but I fiddled with it for months.

Let me know if you have anything else I can answer for you.

The strange part in my case that I have Linear dimmer and switch. Switch still works fine. Dimmer was working fine for 4 month. I doubt that dimmer suddenly became bad, because it does respond on z-wave commands from smart apps. It just does not report state. Looks more like ST changed something.

Hey guys, brand new here. I’m just barely breaking into the home automation gig, I bought this same Linear dimmer to install in the bathroom, pulled the other switch off, and theres a white, black and ground. No blue, no nothing else. Nothing turned on with it, or even remotely worked at all. My home is brand new (<5 years), what do I do from here?

See if this helps:

I just installed my first one tonight. I have 4 led bulbs on the line with 100w equivalent for each bulb. I might be crazy, but it just doesn’t seem as brightening the room anymore. Could this be?!?!

Just Depends on the bulb. You can look up the “lumens” measurement for the light. That will tell you the brightness. Bulbs can vary a great deal even in the “60 W equivalent” range.

Hi! sorry if this was already posted… I linked successfully a WD500Z with my hub, but for some reason I can’t get it to turn completely off… Both manually and through the app, even if it shows 0% power my led keeps turned on (at a 5% I would say). How can I fix this?

posted this on another thread but hoping someone can help out with this…didn’t see anyone else with the same problem in any of the existing threads…

brand new to home automation, just received my smart things in the mail this afternoon and busy trying to figure it out tonight! got my first device, WD500Z-1 linear dimmer, paired after a bunch of trial and error (thanks to all the previous messages here).

But even though I got it to pair, it just doesn’t respond at all. When I try hitting on or off on the iPhone app, nothing happens at all.

Have no idea if there’s another setting I need to activate?

The physical switch still works fine as a dummy switch, but real reason to buy was to use the z wave connectivity / iphone ap feature to control too…

Any luck with this? I can’t seem to get the light to operate for me.

Hi , I have exactly the same issue, that I cant get the lights turn off 100% - did anybody get it solved?

Still “Looking for things”

I have added something like 15 or 20 devices and sensors to the ST hub, plus an Ecobee, and no problems. This switch will not show up. I’ve closed and reopened the app, did a hard reset on the phone, unplugged the hub and pulled the batteries, and nothing. Single, double, triple taps, held the button up for 10 seconds, held it down for 10 seconds, nada. The switch works on the wall manually, but will not pair.

The instruction sheet included with the switch talks about a reset to default settings. I tried the steps and don’t get the blinking light. Is there some sort of magic words to be used? Because I have GE dimmers installed with no problems whatsoever. I even have another GoControl switch (non-dimmer) installed in the same gang box and that paired immediately. What’s next?

Here’s the magic words… It occasionally happens that a new Z wave device arrives still paired to a test network from the factory. You need to get it to clear the old controller information so then it will be ready to pair to SmartThings. That process is called “general exclusion.”

It could just be a defective device, it happens, but try a general exclusion first.


Thanks! I got both of them to work. The only problem is they broke the rest of the GE switches. So I ran the network repair. It fixes it for one cycle of on/off. Then it breaks again. So I ran the repair again, same problem. Then I did a manual exclude of the dimmer, and the problem happened again, same way. So I re-added the dimmer, did a manual exclude of the on/off switch, repair. Same problem. Then I did a manual exclude of both GoControl devices, and then a repair again. The GE switches work fine again. Then I re-added the GoControls, and everything broke again.

These are going back. I’ll stick to GE from here on out. Not because they’re better or worse, but because I have more of them, and the newly introduced GC’s are surfacing the problem. There is some sort of interference problem between the two brands. The hub is 10 feet from the closest GE, and 20 feet from the closest GoControl in-wall switch, and 5 feet from the closest lamp dimmer module. The lamp dimmers work fine, but these in-wall GoControl switches have issues for me.

By the way, FWIW the repair choked at first when I had my outdoor switch unplugged, which is listed as a device. I went and plugged that in, and the repair cycle worked flawlessly. (GE)

There shouldn’t be any interference – – both are certified Z wave devices, and all the certified chips are made by the same company. Many community members have both brands.

That sounds more like a wiring issue, but it’s hard to say. There’s no problem if you just want to return them, obviously, but I just wanted to mention it because it’s possible that any switch that you put in that location would generate the same problem, even another GE.

I happened to have a GE switch and dimmer on hand. I installed those, and had an immediate issue. But with those I ran the repair and the problem went away, so the issue could have been a remnant from all the repair cycles I did earlier. I cycled them a good 50 times over a few hours, and they’re still working. Before I clicked “reply” on this, I just tested them again. Still fine.

Believe me, the GE’s are more money, so I’d rather the GC’s work, lol.

However I will agree it could be wiring. The previous owner of this home was a little scary. He was a salesman for an electrical supply company, and I think he thought that alone made him an electrician. When I moved in my attics were a spider web of heinously run electrical wire. My garage had a 2x4 nailed to the drywall with an in-wall electrical box attached to it. My GFCI’s went off when I sneezed.

I’ve been here about 5 years and I think I’ve repaired it all, but one never knows, lol. You are probably right about the wiring. But why the different behavior between the switches? That’s what concerns me. A wiring problem should be present with both, no?

A little update. Just to be thorough I reinstalled the WD500Z-1 in another room. It works perfectly.

Here are the two scenarios.

First Install that failed:

The ST hub is installed at the top of a basement stairway. In between the hub and the location where the switch(es) failed is a wall with a sheet metal lined cavity for an HVAC return. Just to the left of that, about 2 feet, are two GE switches, which end up being between 6 and 8 feet from the hub. One dimmer, one on/off. The failed location was directly across that room, about 18 feet away. No matter what I did, which I documented above, even if I got the switches to work they would always eventually fail. So I replaced with GE switches, and they work fine.

Second install, successful.
I installed only one, the dimmer, in the kitchen. That ends up being about 10 feet from the hub, with only a closet in between. (no wire, no duct in closet). THAT location works fine. It’s also about 6 feet away from the first set of GE switches I mentioned.

Given that the two GoControl switches had LINE OF SIGHT to two other GE switches, I really don’t understand what the issue was. Even without the GE switches as repeaters, the first install of the GC’s was more than close enough to the hub.

So I’m going to store this away in my head as this. If one brand of switch has reception issues in a given location, try another brand. Yes, I’m keeping the GoControls, and will buy more. If they don’t work in a given location, I’ll just head down to Lowes and pick up a GE.

But thanks for your help JD!! It’s always fun to troubleshoot issues that have no technical rhyme or reason, lol. From a technical perspective, the only GUESS I can make is this. Due to the proximity of the existing GE switches, the hub, and the GoControls, I’m guessing the GC’s maybe couldn’t “decide” between connecting to the GE’s as repeaters, or straight to the hub. With that metal ductwork in the way, the reception would be wonky if going straight to the hub. When I replaced them with new GE’s, maybe the GE’s will attach to other GE switches as a repeater a little better than the GoControls will? That’s my best guess.

Did you run a Z wave repair utility after installing the new switch?

With zwave, each device keeps its own neighbor table which lists just the closest repeaters to it. The repair utility just instructs all the devices to update their own neighbor tables, which improves the efficiency of the network.

Z wave is very good about trying an alternate route if one is temporarily blocked, so as long as the tables are up-to-date that should work if there is any clear path to find.

I ran the repair utility several times when trying to resolve the issue with the first install. That’s what kept fixing it, and then it would break again after I switched the light on and off once. Very weird.

1 Like