Linear GD00Z-4 Z-Wave Garage Door Opener and Amazon echo

Every thing is in that post. Its nice an easy.,

I was using the stock Z Wave Device type with my Go Control Garage Door opener and Echo / Alexa would not allow voice commands to either open or close even though I received an “OK” response from Alexa. I installed this custom code for the Linear GD00Z Wave garage door opener and not Alexa can open and close the garage door using voice commands.

This is a great help. One thing I noted was that one can not issue back to back commands to open and close the garage door and have them be acted upon. There is about a 30 second delay that needs to be observed before one issues a close command after the open command to have it recognized.

Is this a setting in the code that I can alter? If so what line of code controls this delay?

my modified stock version adds switch control so alexa can use it…

This is my second try at adding a custom device handler. I was successful on my first one (a Bloomsky) with the help of JD’s tutorial, but that was many beers ago. I’ve been using Taco’s guide, N00bs guide to ST & GD00Z (Garage Door Controller) to help me install Bamarayne’s device type.

The problem is my developer page doesn’t show the options that Taco pictures in his tutorial. There is no “My Device Types” to click on. Just, my location, my hubs & my devices. Is this because I’m still on the V1 hub?

Edit: never mind, I figured it out. I was in the “manage” part, not the “developer tools” part of of the IDE. I think that same thing messed me up the first time I tried to use it.

Need some help please. For 3 weeks everything worked perfect. I could open my garage door with Alexa, the ST’s app & smarttiles. Now nothing will open or close it. The tilt sensor is stuck on “open”.

Any ideas?

Could just be the battery on the sensor.

Does it work at all via ST? If not then you might need to just change but the battery and re-pair the tilt sensor.

There are a few threads floating around about how to do this.

Thanks, I’ll give that a try.

Still need some help. Everything worked perfect, ST’s app, STiles & Alexa. Then I had a 30 second power outage & then nothing worked. Unplugged the Linear GD00Z for 30 seconds & then my ST’s app & STiles can control my garage door.
But Alexa is “not sure how to help me with that”. The opener shows up in my Alexa devices. I “forgot” it & re-added the device, still no luck with Alexa. Any ideas?

Edit: In the Alexa app it shows my garage door opener as a “device”, not a switch. I’m guessing that my be my problem? Sorry, I only know enough about my ST’s toys to piss my wife off.

SO every thing was working find a week ago, but know Alex does not recognizes the voice command “Alexa open or close the garage door. Know i have to say " Alexa garage on or off”

Same here, on/off works but not close/open! My blinds are doing the same thing.

“Edit: In the Alexa app it shows my garage door opener as a “device”, not a switch.”

Are you referring to the official app called “Amazon Echo”? I don’t even have a device section. Mine is currently working but I just installed it and tested it once. I can say Open and Close.

Maybe uninstall the Echo app and reinstall it. Maybe switch your device type back to ‘z-wave garage opener’ and try adding it as a switch and then change it back after its detected as a switch.

I’m so new to this. How does one “add the code” in step 2 above. Really need it dumbed down.

Hi, I have the Gocontrol garage door opener… works fine in Smartthings, but Alexa cant find it. Also, I have read these posts and people refer to an Alexa app in the Smartthings Smarftapp section? I dont see this on my ST spp. Can anyone help? Thanks…