Lights turning off every night at midnight—why?

i have been using the “Smart lighting” app to control my outdoor lights. They are to be turned on 1 hour after sunset and turned off 1 hour before sunrise. This automation was doing well when i was using the Classic smartthings app UNTIL, the NEW Smarthings app where nothing remains consistent anymore.

Now with the New ST APP, my lights turns off exactly at 12:00 midnight. I do not know how to track/trace what app or what automation is triggering the lights to turn off at the same time. is there such a way? when i check history of the ST APP it just says OFF.

this has been going on for a while now and it has really become annoying. I just took time to post here and see if i get lucky enough to get help. i am planning to upgrade to a Ring doorbell and it would better if my outdoor lights remain ON when they need to be.

could this be an app (smart lighting app) compatibility issue as well? is there a better lighting automation app that is better than what im using that i can try out?

thank you in advance for your kind help.

I’m not 100% up-to-date on this, so hopefully someone who knows for sure will comment, but I believe there has been a recent bug where if you try to create an automation that goes “sunset to sunrise” it doesn’t work. So people end up with two different automations for the same use case, one that starts at sunset and ends at, say, 11:59 PM and another one that starts at 12:01 AM and ends at sunrise. I don’t know if that would help, but it might be worth a try.


hmm i may be on to something.
i do have a piston that i created but its not triggering right but i saw this separate post which probably my issues and the bug that you are referring to.


Dec '19

If your trigger is:
Every day at 20 minutes after sunset
It only fires once a day, at that precise moment…

but if your condition is:
then it will be true from 12AM until shortly after sunset


  • IF Time is before sunrise = 12AM until sunrise
  • IF Time is after sunrise = sunrise until 11:59:59PM
  • IF Time is before sunset = 12AM until sunset
  • IF Time is after sunset = sunset until 11:59:59PM
1 Like

If you open IDE with live logging and update your automation data in samart lighting, you don’t need to change it. When you click on DONE you will see a live log with the start and end data with UTC time.
You can check if “on” and “off” have been programmed well.
I put a capture of one that I have made and you will see that the programmed hours have been well saved. In Madrid we have GMT + 2

1 Like

Are You found the solution?
If You need feedback, Smart lighting app works fine using sunset and sunraise for lights control.

OK, so it sounds like you are using Smart Lighting set to turn on at sunset with a one hour offset, and with the option to turn off at sunrise also selected, again with an offset. There is no reason for that to be affected by app migration. The SmartApp controlling sunrise and sunset times will have been moved (eventually) but if the lights are turning on correctly an hour after sunset that suggests it is likely to be working fine.

@Mariano_Colmenarejo has already described how Smart Lighting has some useful logging. It may also be worth monitoring your Live Logging in the IDE at midnight, just to see if anything interesting appears. Your mileage does vary though depending on the type of device and whether it is executing locally. You won’t see anything about new integrations, but legacy apps and handlers can be quite talkative.

The mobile app History is a little quirky, and sometimes needs a nudge to populate with older information. However if an Automation, Rule or Scene is activated you should see an entry in the History.

The device entry for the lights in the IDE will tell you if any legacy Automations subscribe to the state of the lights, and in the case of webCoRE pistons, also whether they use them in commands. Just in case there is any forgotten usage.

Don’t forget to consider anything that voice assistants might be doing.


SOB! thanks for the suggestion! I guess i just found the culprit!