LFM-20 Evolve for garage door

My experience is the same @professordave. I have not had a false fire to date over last year plus (at least not caused by LFM-20). I did an experiment with mobile presence triggering the garage door and it did cause a few false triggers but it was the cause not the relay. Had sames experience with ST presense senor too. Sometime ST looses connect with them and believe they left when they did not. I just stopped using it and have been very happy

@natescook1 yes the whole presence thing is a whole 'nother story!

I did not find presence sensing is reliable enough to base opening and closing the garage door automatically.

Except for this one rule I setup, but the rule itself is not that helpful.

I took the smart app “A Ridiculously Smart Garage”

And I hacked it in the following way, I commented out the line that actually opens the garage door but leaves in the code that will only close the door if it thinks it opened the door and an interior door is opened and then closed.

The garage door is only automatically closed if it thinks it opened the door, because I came home, and then I close the interior garage door to the house, which has an IRIS open closed sensor.

So, presence detects I am home, I manually open the garage door with my car remote, drive into garage, get out of car, open interior garage door, step into laundry room from garage and close interior door, that door closing then causes the garage door to close.

Not that useful as at this point I can close the garage door myself by just hitting the button.

I also have some garage door lights that turn off after ten minutes after the garage door is closed.

Just passing on a tip to all with this. After getting this to work for many many months it stopped working. I ensured that it was still set up as a Z-Wave Virtual Momentary Contact Switch and I even tried re-applying that setting. via

* Log in to https://graph.api.smartthings.com
* Click on "My Devices"
* Click on your LFM-20's device name
* Click "Edit"
* Select "Z-Wave Virtual Momentary Contact Switch" from the "Type" drop-down.
* Click "Update"

When I tried to use this feature it would turn off the little LED light on the evolve relay and the garage door would not work at all (even with the wall switch) unless I powered off the relay and powered it back on.

So this did not work for months. So last night via a browser I deleted and then did a force delete for this device.
https://graph.api.smartthings.com

Then I spent an hour or two trying to re-add this lfm-20 to my smarthings hub. I had no success, but then this morning it was there as a z-wave relay. (I tried the trick of hitting the small slitted button on the lmf-20 two times very fast while my app was looking for devices, that may have done it).
After the device was found in my app, I went to the browser and changed the type to Z-Wave Virtual Momentary Contact Switch as described above.

Then and only then did this work again!!! I now can use the app on my iPhone and when I use it the status goes from on to off (after a second or two delay) and the garage door opens or closes.

So the trick was to delete it and re-add to the smartthings hub to get this working again

1 Like

My Liftmaster P3 Security+ 2.0 Garage Door doesn’t travel…

Here’s a different twist on this topic. I have my LFM-20 wired directly to the garage door opener unit for the power and wall switch connections. The LFM light comes on when the garage door opener is plugged in, and I had little trouble getting the ST app to see the Light Relay Switch and connect. I then edited the Device Type to be “Z-Wave Virtual Momentary Contact Switch” and when I touch the Switch button on the ST app, it momentarily switches ON then back OFF as promised. BUT - My garage door does not respond / move / try to close.

On the back of the garage door unit there are UP and DOWN buttons with lights that when depressed, cause the door to travel. When I touch the switch on the ST app, the garage door unit UP/DOWN lights flash correspondingly - but again, no actual garage door movement.

Thoughts?

Ok - let me close the loop on my own question. The new-er garage door openers have a second generation rolling code system. Mine, the Liftmaster P3 Security+ 2.0 had to have one of the actual garage door remotes (not the wired one on the wall) connected to the Evolve LFM-20 by soldering the LFM blue wires to the remote button. You may be able to discern the same points on the circuit board up in the garage door controller, but this was much easier to manage, sitting at my workbench instead of up on a ladder.
See this video: https://www.youtube.com/watch?v=vADl3FO0hGk

As far as adding the LFM-20 to the ST App, the most updated version of the app doesn’t list the LFM-20 under Evolve “+Things”… but just choose the Evolve LFM-15 single switch, and edit it as a Z-wave Virtual Momentary Switch, as explained here: LFM-20 Evolve for garage door

As far as the lights flashing on the back of the garage door unit; it turns out they were not indicating a ‘trigger’ to open/close, but were a flashing code indicating some fault. In my case, 1-UP and 3-Down, was indicating something wrong with the wall-mounted remote, where I originally had the LFM-20 blue wires connected…and it was basically saying, ‘no rolling-code connectivity.’

Now the LFM-20 works perfectly. I put it, the power plug wires, and the garage door remote circuit board all in a project box and mounted it to my garage wall, next to a power plug below my wired garage door switch. Works great with all SmartApps to auto open/close my garage door in whatever situation I want.

1 Like

Is it possible to have an ST motion sensor trigger the LFM-20 for a momentary closure when it’s edited as a z-wave virtual momentary switch?

When I trigger the Evolve set in VMS my wall oppener switch for a Lift Master premium 8355 2015 just shuts off (the green light goes off). But nothing happens (the garage door doesn’t move). After three seconds the Evolve LFM-20 goes back to off and the wall panel light goes green again. My smartThings Hub found the Evolve no problem. It is plug according to what it should be. I guess the new Lift Masters are protected or something. Did someone find a workaround for this issue.

Hi @duncan, I did exactly that with my relay and all it does is cut the power to my wall switch to open the garage door. The wall control light goes out for 2-3 second and then comes back as soon as the relay is off again. There is no action from the garage door in the mean time. I have a bran new lift master that maybe doesn’t communicate the same way as others. If you could help I would appreciate.

@dopey were you able to use your lift master with a z-wave relay eventually since I have the same problem. The relay clics and is open and close after 2 sec as it is set as a VMS. The only thing it does is shut my wall panel off but it never opens the garage door. What did you end up doing?

I replaced my original hub with a Version 2 and had no problems connecting existing Hue and ZWave devices from the original setup to the new hub except for the Evolve LFM-20. Never did get it removed from the original hub and couldn’t get it to connect to the V2 hub. Tried the suggested reset procedure from Evolve but didn’t work. Spent about over an hour with ST Chat and we couldn’t get it to work so went to the Evolve site to start a ‘Ticket’. When I clicked to send the problem to them, a popup appeared and asked me to check 3 previous similar questions already submitted. One of them had the solution to my problem as follows…"Nat
MAY 25, 2016 12:22AM EDT
For anyone who is trying to reset this device ignore the documentation on “three taps then 10 second hold” A quick double tap will do the trick as long as your hub (vera, smarthings, etc) is in exclude mode.

Ed Hanks
NOV 23, 2016 05:19PM EST
Many hours of experimenting resulted in the following which Evolve seems to keep a secret: If your LFM-20 is release 5.1, the three taps & hold is the solution. If your LFM-20 is release 5.41, the double tap is the solution. Any other releases that may exist is a mystery unless someone tries to figure it out as Evolve will not tell you. The only instruction sheet I have received, even with my release 5.41 is for the release 5.1."

2 Likes

@rbeckert I have dealt with this a few times. Here is link to posts I made about getting it to re sync. Hope that helps. I believe late on in the thread I talk about moving from V1 or V2 hub.

Hi everyone - I’m curious if I’m the only one having this problem. I’ve now gone through 4 of these relay units. They seem to last roughly 6-12 months but inevitably die on me. I’ve observed that it seems to be after lightning storms of any kind that I lose the units, but that’s a circumstantial observation on my part. Am I the only one experiencing this? I’ve contacted the company and they’ve said I’m the only one who is reporting problems, but I just can’t see how that’s possible. Is there a major ESD sensitivity issue associated with these? Anyone?

-Jeff

sounds like they’re blowing smoke. Anecdotally (second-hand info) these false-trigger enough that I would not apply them to anything critical, unrelated to ST cloud problems, it seems to be the hardware.

Just to chime in with a different experience. I must be really lucky. I have one that I purchased and installed for a garage door on 12/2015

There may or may not have been one false trigger, once. We were on vacation, the garage door was open for a couple of hours. It is possible that I accidentally hit the button in the app, but I do not think I did, or it was a false trigger.

Other than that it has worked fine.

Edit: Installed 12/2014, a year earlier, not 2015

I’ve never had that happen before. But with 4 units down, I’m not purchasing any more - and even warrently replacements seem silly since they just keep dying on me. I’m going to try one of these: http://a.co/5hU06uS

-Jeff

I’ve had mine for 3 1/2 years and plenty of power surges. So far no issues.

Can you describe how you are hooking it up? I’ve thought maybe I need a resistor on the switch hookup to the garage door since it’s pushing some AC… But since it’s an isolated unit that doesn’t make a ton of sense. I feel strongly that I’m just missing something. Also this is three separate garage door openers, across two different brands, in two different homes. This just screams user error.

Be sure to wire it as a dry contact, not wet. There isn’t a need for any resistors. Also make sure your load is not exceeding 20amps. Here is the wiring diagram:http://www.evolvecontrols.com/wp-content/uploads/2016/03/LFM-20.pdf

Michael

jeff1 Jeff L
August 11 |

Can you describe how you are hooking it up? I’ve thought maybe I need a resistor on the switch hookup to the garage door since it’s pushing some AC… But since it’s an isolated unit that doesn’t make a ton of sense. I feel strongly that I’m just missing something. Visit Topic or reply to this email to respond.
In Reply To

mcvoss
August 11 |

I’ve had mine for 3 1/2 years and plenty of power surges. So far no issues. Visit Topic or reply to this email to respond. To unsubscribe from these emails, click here.

Yea, I’m pretty sure I’m hooking the up right. I just wire power in directly from a plug, and have the two blue wires straddle the two terminals on the garage door where the buttons attach. So basically the relay just pushed the button. It all works perfectly. Right up until it doesn’t. And then the units are dead. No indicator light. Nothing. Just dead. 3 of them in 1 year.

All, here are the instructions I wrote for pairing hsm-200 temperature sensor with smartthings. I thought these were for the garage door opener (lfm-20) that is why I posted them. They may be useful for new people trying to pair a new device with smarrthings. I posted them here once I finally figured it out as a newbie

Here is a copy and paste
After reading various things here and on Amazon.com 1 reviews here is how I finally configured this to work with SmartThings hub (version 2 in my case)
Instructions to get EZMultiPli is also known as the HSM200 working with SmartThings Hub version 2 hub.

  1. Plug the EZMultiPli is also known as the HSM200 into an outlet. When you do this it should flash green.
  2. On the side of the EZMultiPli (or HSM200) you will see a very small button that is about 1/8 of inch long and a few millimeters thick. Press and hold this for about 30 seconds, it will start flashing colors (I think red) and then it will stop flashing, at this point open your SmartThings app on your iPhone or Android device and click the “Add A Thing” under My Home
  3. You will then see a new thing called “RGBW Light” added to your SmartThings. At this point it is not configured yet.
  4. Go the https://graph.api.smartthings.com and log in
  5. Go to My Device Handlers at the top and click button “Create New Device Handler”
  6. Under “Create New Device Handler” Click on the “From Code” link at the top
  7. Go this this URL https://github.com/drzwave/ExpressControls/blob/master/EZMultiPliDeviceType.gy 13and copy the code into your clipboard or memory of your PC or Mac. The URL no longer works, the device handler for this is now native to smartthings, here is how how to get the device handler now and get it to work with smartthings https://drzwave.blog/2017/04/27/ezmultipli-how-to-for-smartthings/
  8. Then Paste the code into the blank white box under the Create New Device Handler in the From Code link
  9. Click the Create button at the bottom
    10)From https://graph.api.smartthings.com/ 3 go to My devices and you should see the RGBW Light Device, click Edit
  10. Click the Type* field and scroll to the very very bottom and you should now see “EZmultiPli” select that
  11. Optionally select Label to something more useful as in “Temperature Outside” (you can do this from the SmartThings app on your phone)
  12. Click Update
  13. Now in the SmartThings app on your phone you will see the temperate, you will have to enter the “thing” and leave it and it will soon show up with the temperature