Kwikset smartcode 914 not reporting correctly

I replaced my kwikset 916 with a 914. The new unit added ok and appears, I can even send codes to it however I cannot open or close it remotely and it doesn’t properly show locked unlocked. I tried deleting and re-adding already also

Zwave or Zigbee and which device handler are you using? Also, is the lock engaging with the keypad? You can try a simple reset by removing the battery pack for a minute

Did you swap the z-wave module or get a module with the 914? It may help to try adding a buffering device but since you’re able to program codes I suspect it may be something else (however adding a buffering device will rule out this issue of mesh packet loss): FAQ: why would I need another beaming repeater if my zwave lock is already close to my hub?

I swapped it completely for a new unit. The 916 still functions on my system. I’m using the smart lock guest access in my Samsung app and the keypad is working fine. I don’t know what a buffering device is. Thanks for your replies

solved my own issue. The door wasn’t showing locked because the hole was not deep enpugh to lock. It wa locking but just no enough to indicate it was locked. drilled the hole deeper and its all good now.

Glad you got it fixed