Keen Vent New Smartthings App

Has anyone been able to figure out how to discover a Keen smart vent with the new Smarttthings application?

I can find and install it in the Classic app but no luck with the new one.

Before you say just use classic, realize I am using the Samsung Home Connect Pro which only allows you to control your wifi hub settings with the new app.

Not possible…

Before you say just use classic, realize I am using the Samsung Home Connect Pro which only allows you to control your wifi hub settings with the new app.

For the price of a vent you can buy a real SmartThings hub so you can integrate your vents, today. Available at Best Buy for 86 bucks.

1 Like

I have connect Home Pro and have no problem to use classic app

Hi IG,

Does the classic app find and install the WiFi router? If so are you able to go in to the router and WiFi settings in the new app afterwards?

I’m pretty sure the home connect pro is a real SmartThings hub…

1 Like

No, you doing initial installation on new app and than going to classic…

Yes but once I go to the classic app it finds a device named the same as the WiFi router and adds it. I can’t canel, it adds it automatically. Once it’s added to the classic app if I go back to the new app I can no longer connect to the router nor modify WiFi settings.

What issue are you running into? My keen vent shows in the new app just fine. You can pick any device to add to get it in pairing mode and then put the Keen in pairing mode and it should find it.

1 Like

Hi Jimmy,

I tried multiple devices, switches, dimmers, etc.

With the hub in search mode and the vent in pair mode It never finds it.

Do you remember what device you selected?

Well, I added mine in classic. Have you tried resetting the vent and bringing it within 10 ft of the hub? I do remember having to reset mine.

I can add I in classic no problem. The problem is if I add anything in classic it finds the WiFi router and adds it… after that I can’t connect to it in the new app.

Can’t add the Keen vent in the new app no matter what I try.

Thanks for the info

This is an old conversation, but I ran into the same issue today and figured out a solution. For Keen vents that have not been paired to the old hub with the new app, you’ll need to do the following:

  1. Remove the vent from the duct. This is in part to get it closer to your hub, but more importantly, to access the black reset button which sits behind the metal louvres inside the duct.
  2. Remove the batteries. Be sure to put new ones in. If you still have the batteries that came with the vent when it was new, they’ll be ready to expire in March 2021 if you purchased it in the USA. That’s pretty close to the time I’m writing this, so you’ll definitely want to replace them so they don’t leak.
  3. Put new batteries in the holder. Do NOT insert them in the vent. If you already did, remove the holder and move to step 4.
  4. Go into the new Smartthings App, select Add a new device by Brand, pick Keen Home and choose the Smart Vent (it’ll be the only one you can select). Once you get to the point where it asks you to remove the green activation tab, proceed to step 5.
  5. Press and hold the black reset button behind the louvres, then insert the battery holder while still holding the button for a few seconds, then release it. The app should then accept the device and you should be good to go.
    If it doesn’t work, try pressing and holding the reset button again after you’ve inserted the new batteries.
    If the louvres don’t move, don’t worry: you just need to get the device paired. Once the device has been paired, remove the batteries and then manually open the louvres all the way using the black slider before reinserting the batteries. They should find their way once the batteries are reinstalled.

Hope this helps!

Any ideas why the Keen Home brand is missing in my list of available brands in the new app?

I’m in the United States and just added a Keen Vent today to my ST system. It was listed under Brands. Is working great. Are you in a different region?

I think you right. I just found out my Samsung account set at the different from the US region. I asked Samsung to change it to the US.

Thank you