Kasa switches no longer working in SmartThings

Had 4 TP-Link Kasa HS200 switches, all working for over a year with automations in SmartThings based on Samsung Motion sensors.

Added 1 HS210 and 2 HS200’s yesterday. Now none of the switches are working in SmartThings, even the old ones that worked up until I added the new switches.The motion sensors correctly report motion/no motion.

All switches work in the Kasa app.

When I try to add the new switches to SmartThings, only the 4 old switches show. I removed 1 to try to re-add it, and now it won’t show either. (Kasa account is linked.)

Have tried factory reset on the 1 I removed, and it works in Kasa again, but still won’t import into SmartThings.


If you have a ST hub there is an Edge Driver that works with single gang Kasa devices. It don’t work with multi-gang gang devices like power strips.

1 Like

OK. I visited that site and clicked Install…anything else? No other instructions on the page after install. Do I need to reboot/restart the ST Hub?

Still don’t see any new switches and existing switches don’t work and show as Offline in ST App. They still work in Kasa app.

Once you install the driver you need to run San Nearby. Then your devices should show up.

Run what now? What is San Nearby and how does one run it? (searching the forum for it)

Go to Add Device and then select Scan Nearby.

Thanks. They show up now, but the icon shows as a plug rather than a switch. App says it hasn’t updated all of its status information yet, and to check back later. I’ll wait a bit to see what happens.

Switch is not as available but you have these options under change icon.

Try physically operating the switch to see if that helps.

Manually turning on/off a couple times gets them to work. Looks like I’ll have to either adjust existing automations in Smart Lighting or delete & create new ones.

At least I’m on the road to recovery though!

And Thanks! You’ve been very helpful.

1 Like

The HS200 switches all work now, and the prior automations have all been rebuilt.
The HS210 dimmer switch…works as a switch in ST app, and shows a slider for dimming, but I can’t use the dimmer function in the ST app. Still says it hasn’t updated all of it status info yet.
I’ve tried up/down/up/down with the dimmer controls. Have tried all the way up/all the way down a couple times and the dimmer function still isn’t available in ST app.

1 Like

I had the same problem and in the end simple fix - check your kasa password.

If you got a new phone since installing your old devices, and reset your kasa password during install of the new device, as I did, SmartThings will stop communicating as Kasa is a linked service (rather than a stand alone device). Once you sign in to kasa from SmartThings with the new password, everything will work. The generic server error message the SmartThings app gives is not very helpful. The tell here is it works on the kasa app, but not the SmartThings app.