Is there a way to easily just make lightning scenes without Core?


(Psycho Bunny) #1

Core and WebCore never work for me, they do for a day, come back the next day and nothing works so I refuse to use it. I just want to easily create lightning scenes but pulling my hair out with ST. Can I not just easily make a scene or event that does something like:

Game Time:
Set Basement Lights to 10%
Turn off Basement Stairs Light
Turn off Server Closet Light
Turn off Laundry Room Light
Set Couch Hue Spotlights to 100% and deep blue
Set Basement Hue Bloom 1 to 100% and pink
Set Basement Hue Bloom 2 to 100% and deep blue
Set Hue TV Spotlight Left to 100% and deep blue
Set Hue TV Spotlight Right to 100% and deep blue
Set TV Spotlight Middle to Off
Turn on the Fireplace

I can easily make that in Core, but as mentioned it never works after a day (anything in Core not just this) so don’t want to use it. Is there no way to do this otherwise? It’s so weird to me that a home automation controller can lack something so basic. Isn’t half the reason people get into this to be so that they can do complex lighting scenes?


(Bob) #2

Instead of moving away from CoRE/ WebCoRE why not post your piston and ask for guidance as to why you are having issues.
There may be something that can be changed to get it working 100%.


(Bobby) #3

Not exactly complex. But simple scenes can be done. If you really want “complex” you need to look beyond stock options. I really think using webCoRE is the way to go. Have been using CoRE and webCoRE since day one. It is developed by a very responsive developer that takes pride in his work and is around any time to help fix bugs when someone finds any. I wouldn’t just give up. Now, for simpler scenes SmartThings stock options are just fine. If I had a scene like yours, I would do something like this:

Build a Routine "Game Time"
Turn OFF:
Turn off Basement Stairs Light
Turn off Server Closet Light
Turn off Laundry Room Light
Set TV Spotlight Middle to Off

Turn ON and set level:
Set Couch Hue Spotlights to 100% and deep blue
Set Basement Hue Bloom 1 to 100% and pink
Set Basement Hue Bloom 2 to 100% and deep blue
Set Hue TV Spotlight Left to 100% and deep blue
Set Hue TV Spotlight Right to 100% and deep blue
Turn on the Fireplace (assuming this is a switch)

Create a Smart Lighting instance
Turn on and Set Level
Set Basement Lights to 10%
When Fireplace turns on (assuming this is a switch)

Depending on what can trigger your “Game Time” you can certainly automate the routine to run when something happens…


#4

Ummmm… routines in SmartThings treat all lights as one group. You can’t set The couch hue to one dimmer level and the bloom 1 to a different level. Unless you know a trick I don’t.

You can certainly do it in Core. Or you could use one of the custom lighting smart apps like Hue B Smart or
Hue ( Re) Connect

http://thingsthataresmart.wiki/index.php?title=How_to_Quick_Browse_the_Community-Created_SmartApps_Forum_Section

But I don’t think you can drill down for individual device settings if you included multiple lights in a routine. Or have I missed something?


#5

Have you asked for help from the core team to see if you can get that working more reliably? That would definitely give you the most options.

https://community.smartthings.com/c/smartapps/core


(Psycho Bunny) #6

Thanks, disappointing that ST doesn’t support this out of the box. I’m not interested in Core, I’ve posted numerous times. It’s the same thing, install it, or WebCore, create 10 pistons even, each works perfectly. Come back 24 hours later, not one of them works. Have to fully remove Core, reinstall it all, then exact same issue 24-48 hours later.

Or what it does is even simple things, like “If virtual switch is turned on, then turn on the lamp.” this will work fine. Create another that does the same thing, that one won’t work. Edit this first one without changing anything and hit save, now it doesn’t work either, full reinstall needed. I’ve never had Core or WebCore work more than 48 hours. Not really into wasting more time on it so wanted to see if there’s other options before I pull the plug and go back to HomeSeer but looking like that’s what I’ll be doing. Sucks because HomeSeer doesn’t work the best with Alexa, and doesn’t work at all with Google Home which is why I like ST. But I think having proper lightning scenes is more important to me than perfect Alexa integration.

Thanks!


(Bobby) #7

Ha correct, but if you notice, the levels are all 100%… The odd one that is at 10%, I recommended following up with a Smart Light instance when one of the switches in the routine turns on :slight_smile:


(Bob) #8

Wow. Have you been going round kicking black cats, breaking mirrors and walking under ladders?

I’ve got over 50 pistons and 99% of the time they work well.
Some people on here have a lot more than that and a lot more complex.
Without WebCoRE I can honestly say that ST would not be what I would want it to be.
Horses for courses.


(Psycho Bunny) #9

The 10% is just one on this scene though also, like that’s not a Hue light. In other scenes it’s things like some lights go to 10% with one color temperature, others are 5%, others are 50%. ST seems to be all or nothing when using routines.

Maybe I’ll try it again, just don’t have the energy! It was always frustrating things, even with CoRE not the WebCoRE one. I had one just like the above, if virtual device Game Time is turned on, then do the following. Worked for maybe 2 days. I go “Alexa turn on Game Time” nothing happens. Check the ST app, shows the virtual device is already on (WebCore piston said to wait 5 secs then set it to “Off” so that I can always say turn on game time). I turn it off in the ST app, wait a sec, turn it back on, nothing happens. Core shows last run 8 hours prior. So it’s stuff like that, will fully work fine, then just day later nothing works, triggers, runs, etc.

Maybe I’ll try a factory reset on ST and see if that helps. I’ve already mostly moved back to HomeSeer, but things like Lutron and Hue can work with both since it’s just a bridge, so maybe I’ll just add those 2 back to ST and do a basic WebCoRE event. Run that for a few days vs moving 200 devices back to it and then trying to set up events.


(Bobby) #10

That right there is calling for trouble. ST has issues handling less than a minute timers. Also when turning things on/off from the app, events are not reported timely (sometimes).

The nuclear option is not necessary. I think what you may need is time to learn a little bit abut ST quirks. It has many, but also could be avoided.

ST is not the perfect solution but it can be turned into a positive experience… That’s what this community is all about. If you struggle, yell. Someone will give you a good advice. That someone might be @JDRoberts , 99% of the time is, …and if he doesn’t know, he’ll tag someone who will :slight_smile:


(Psycho Bunny) #11

It’s not really a timer though. Like the Game Time virtual device is On or Off. So the event says:
If Game Time is turned On
Do the following
Then wait 5 seconds
Then turn Game Time Off

So that it’s ready for the next time when I say turn Game Time on. Again, works fine for 24 hours or so then just fully stops. Even when I deleted the wait 5 secs, turn game time off (as the WebCore forum someone said the event is probably running too fast) it still didn’t work, and even the “last run time” shows the day before. Eventually I got to the point it said “If game time is on, turn on the lamp” nothing more, and it still wouldn’t work.


(Bobby) #12

It sounds like an issue with your “virtual device”…which one do you use?. I use uDTH for everything and never fails in webCoRE or any other apps . You can even use it as lux restriction with Smart Lighting and Routines…


(Psycho Bunny) #13

Sorry just to be clear, that’s just one example. It can even be something more basic, like “If motion is detected, turn on the lamp” and even that just stops working. Like it doesn’t matter what the piston does, they always just stop working. Like it will work 24 hours, stops working, I delete it, create it again, never works again. So it’s really with all pistons, but I haven’t spent tons of time on it mostly because I’ve already spent $500 on HomeSeer but was just playing with ST. The pistons in WebCore are almost the same as HomeSeer in terms of writing events, so I’m not new to this or anything, I have super complex ones with HS. It’s just weird it always stops, not sure if it’s because pretty much every day it says there’s an update to WebCore, dunno if it needs the update to function but there’s an update almost daily.

Again what I’ll try is just using it in the basement, with Caseta and Hue lights and will start small, get that piston working for a week etc then move devices over, give that a try vs going full blown.


(Bobby) #14

I understand these are just examples… I suggest the next time it stops, before you change anything share the problem (logs, screens, etc) Doing the same thing over and expecting different result…you know…it really could drive you … @Psyko lol :slight_smile:

That’s because webCoRE is being actively developed. You don’t need to upgrade every day. The updates are mostly new features or squashing existing bugs, If your piston is working, that is an indication you don’t need to update immediately. And I can tell you, I am running the updates every day and rarely had a piston stop working after an update. Not saying it never happens, because never doesn’t exist with technology, as I am sure you know already …


(Psycho Bunny) #15

So quick update, did a factory reset, started all from scratch. Started with just a few devices, installed WebCore, set up a couple pistons, worked perfectly. Today I write one, works great, really simple, if a switch is turned on, set the lamp to 50%. I then write another one, doesn’t work. Go back to the lamp one, also doesn’t work. Go back to my others I made yesterday, guess what, they don’t run anymore either! Honestly so over this, glad it works for everyone else but this plugin is super broken for me so I give up. Thanks for the help. :slight_smile:

Just to show how stupid this is, look at this manual test piston below. Supposed to set 2 Hue lights to 100%. You run it, it sets one to 20%, the other to 100%. Set them both to 5%, run this piston, sets one to 60% the other to 100%. 30 minutes, cannot get both to set to 100%. Delete both, readd them, they both work for a few mins, run the piston, right back to one going to 20-30%, the other 100%.


( I hate Mondays) #16

Hold on, slow down a bit there. Enable full logs in the piston and try again, post those logs please. You also mentioned Hue - are those bulbs updating in your ST app in time? The reason I am asking is because both CoRE and webCoRE have a feature called “command optimization”. If the level you are requesting is the same as the current bulb level, no command is issued (you will get some skipping message in the logs). How are you changing the level of the bulbs? Via ST or via Hue?

Also, go to the bulb that does not want to go to 100,go to its Recent tab, post a snapshot of that pls