Is the TV Hub the same as a standalone hub

I have just integrated my Samsung TV into smartThings. I have been trying to set up a virtual switch to trigger an Alexa Routine. I was able to build it and everything in Groovey and Alexa see’s it, but it does not show up in the Smarftthings app to turn it on or off. Will this never work in the TV version of the hub, or am I doing something wrong?

Did you look in No Room Assigned in the app?

I was able to assign the switch to one of my rooms in Groovey, but I see nothing in my mobile app that says No Room Assigned. However, it does not appear under Home. Also, when creating the switch, it shows no hub. That is why I questioned the hub in the tv.

I don’t have any Samsung TV so I can’t help you with that.

If this is an Edge device it is installed on your hub, but it will NOT show up under the Hub tile in the mobile app.

Edge Drivers are Not supported for TV-only configurations at this time. :disappointed_relieved:

Thanks! That is kind of what I thought. I’ll see if I can find a smatapp that will control my Philips Hue scenes. That’s all I needed it for.

What’s the model number of your TV?

Up through 2021, TV only configurations were not referred to as a “SmartThings hub.”

Instead, there is a tv-only app that runs on the television called “Samsung Smart Hub,” but at least the last time I looked that was for entertainment only, like selecting Netflix. It didn’t have any home automation features.

A new dongle has been announced that will plug into the television and add some home automation features, but I don’t think that’s been released yet. :thinking:

It has also been announced that some Samsung smart television models will be able to act as a “matter hub”, but no details on those yet and they definitely haven’t been released so far.

Now it gets complicated. (OK, more complicated.)

Everything above is about features which have the word “hub“ in the name.

Separately, some models of Samsung smart televisions, but not all, are not hubs and don’t call themselves hubs but they do have a TV version of the smartthings app. And you can use that to control at least some of your home automation devices.

In order to use that app you have to first add the television itself as a device into your smartthings app on your phone. This may prompt a firmware update to the television.

After the TV shows up as a device in the app on your phone, you can then access the “smartthings app” (not the “smart hub” feature) on your TV screen and you should see most of the devices that you have added to your smartthings account show up there. Including a Groovy version of a virtual switch if you have one.

(As previously mentioned, Edge Driver Versions of virtual switches can’t be used at the present time without an actual standalone hub, but I don’t think you’ll even be allowed to download one, so that’s probably not the situation you’re in.)

To add the tv to your phone app:

To access the “SmartThings app” on your TV screen after you have added the TV as a device to the phone app:

So… if your specific TV model supports it the steps for what you want to do are

  1. add a groovy virtual switch to your smartthings account and make sure it shows up in the smartthings app on your phone. It sounds like you’ve already done that.

  2. add your television as a device to the smartthings app on your phone. This may prompt a firmware update to the television. Make sure you have control of the TV through the phone.

  3. now, using your tv remote, choose the “smartthings app” on the TV screen. (Not the “smart hub“ option.) that should allow you to access at least some of your home automation devices from your TV screen.

If you’ve already done all of that and it’s still not working, you’ll need to contact support.

So… as of this writing The answer to the question in your thread title is no, the TV hub is not the same as a standalone hub and doesn’t have the same features. That might change in the future when some of the other options I’ve described above are released, but that’s how it is now.

However, you don’t need the TV to be the same as a standalone hub just to be able to access a virtual switch. That uses the “smartthings app“ on your television, not the “smart hub“ feature. Again, details above.

I hope that helps and doesn’t just feel overwhelming. It is definitely confusing because Samsung does have a bad habit of using the same word to mean different things in different contexts. :face_with_raised_eyebrow:

Unfortunately The smartthings/Hue integration does not give you access to Hue scenes. If you can’t get the effects you want by re-creating the scenes in smartthings as smartthings scenes then then you do have to use an intermediary, either Alexa routines or IFTTT. But both of those methods do require the use of a virtual device, so you do need to get that part straightened out.

I do have the Smartthings app on my tv. It’s a Samsung Q8. Forgot I installed it. The Switch does show there, but not on my mobile app and because of that I can’t build an Automation. I have the IOS version of the mobile app.

Hmmmm….sounds like they might be pointing to different locations, but honestly I’m just guessing. I have a hard time using the phone app because it’s not voice navigation friendly. :disappointed_relieved:

Hopefully someone who knows more than I do will chime in. Or again you can contact support, but I don’t know if you’ll get any response on the weekend.

Tagging @Automated_House just in case he has any additional ideas.

A funny thing just happened. Just for kicks I deleted my phone app. I reinstalled it and the only device that came up was the Switch, nothing else. It also had no room to put it in. I logged out and logged back in to see if it would restore everything and it did! All came back BUT the switch. I tried repeating that scenario, but can’t get the Switch back. I have no idea what happened. The only place the switch shows up is in Alexa and the Smartthings app on my TV. Go figure.

Is possible that you have multiple locations? Click on the house in the upper left corner on the favorites page. It should open and show all locations.

2 Likes

I think that was the problem. “Home” does not appear in the drop down when I built the switch. So I created a location and named it what one of my rooms were. I think that is why it isn’t working because it’s 2 locations. I hadn’t realized that location and the rooms were different. The drop down list when your creating the switch is blank and you can’t type into it. Why it doesn’t appear I have no idea. No hub shows up either. It’s not that big of a deal. I wanted to run an Alexa routine when the tv turns on. I can still have the lights dim when the tv comes on. They just don’t fade slowly like the Alexa routine. I can still tell her to do it, but I’m not fond of voice commands

Your hub will only show in one location and that is the one it belongs to.

You could delete the virtual switch in wrong location and recreate it in the right location.

1 Like

That’s what I was trying to explain. When creating the Switch it asks for a location. It will not let you type into the drop down box. I go to Locations and it has Home in it. Home has all my devices, but it does not appear in the drop down on the device page. I have no idea how to get that Switch into home when I create it. Maybe there is someway of renaming it or something so that it appears in the drop down.

In the original architecture, you were only allowed to have one hub per “location,“ and in all of the examples the idea was a different locations would be different physical buildings. Like “home“ and “office.“ Or maybe in houses that had a lot of architectural issues with interference, like a building made out of Adobe or cement, you might have the first floor as one location and the second floor as another location with a different hub on each.

Later, they did allow you to have more than one hub per location, but it didn’t always work very well. To be honest I’m not sure what’s allowed right now.

And also, some people did use locations for other purposes to group their devices, in particular if they had an Airbnb section of the home that might be given its own location name. And that one might not have a hub at all, it might just have some Samsung smart appliances and a Wi-Fi lock and doorbell.

A “room” is a subset of a location. Again, in most examples, you would have a location of “home“ and rooms for living room, kitchen, bedroom, etc. And maybe another location of “office“ and rooms like “lobby,“ “conference room,“ etc.

When you set up a new account, it automatically creates a default location for you called “home.“ But you can change other locations to be the default if you want.

Here’s the official support article on locations and rooms

It sounds like you may have put your television into a different location then your primary location and that started the confusion. If you don’t have a reason to have two locations, I would go ahead and combine everything into one.

I wasn’t able to tell if you do actually have a standalone hub as well? If you do, then I would make the location where that hub is your primary location as it’s harder to move a hub with it Zigbee and Z wave devices into another location than it is to move Wi-Fi devices. But that’s up to you.

I don’t know if you always have to have a location named “home” or if you’re allowed to rename that. Hopefully someone else will know.

You aren’t supposed to type into that box. When you tap on The little arrows on the far right of that box, you should see a list of all the locations you have created. It’s kind of a weird list because there’s a checkmark at the top of it that looks like it’s on a blank line, but it’s actually trying to tell you that you have to check the location that you want to use. By tapping the name of that location.

That’s what I was trying to say. The Box was Blank. Clicking on the arrow did nothing, just a blank box. But I solved that. I went into the Location settings, chose HOME and did an update without changing anything. HOME now appears in the drop down in the Device page. I’m going to clear everything and redo just so everything is in synch. I’ll let you know how I come out. Not sure if I’ll have time this evening. I appreciate the help.

1 Like

Just to let you know the Simulated switch is now working just great. The location was the problem. Why home didn’t appear on the device page I have no idea. I originally thought it was because it was the TV Hub and not the full hub. Updating did the trick. Now the TV state triggers my Hue Scenes thru Alexa. Thanks for your help.

3 Likes